aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jna
diff options
context:
space:
mode:
authorRobert Schuster <rschus@tarub.tarent.buero>2011-03-12 12:23:34 +0100
committerRobert Schuster <rschus@tarub.tarent.buero>2011-03-12 12:23:34 +0100
commit9dd12ec76eaf413ab19119ce4a96f834a878c9f6 (patch)
tree21f51e541bf329e941d5a7a7fcbec0d2d8474763 /recipes/jna
parent5280bbec3f6ba6902b1f7d3f2b094cc9e5e6b1b0 (diff)
downloadopenembedded-9dd12ec76eaf413ab19119ce4a96f834a878c9f6.tar.gz
jna 3.2.7: Some more notes and pretty formatting.
Diffstat (limited to 'recipes/jna')
-rw-r--r--recipes/jna/jna_3.2.7.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes/jna/jna_3.2.7.bb b/recipes/jna/jna_3.2.7.bb
index 2676d2e8e4..548ca87e06 100644
--- a/recipes/jna/jna_3.2.7.bb
+++ b/recipes/jna/jna_3.2.7.bb
@@ -23,10 +23,14 @@ do_compile() {
# Move created jar into subdir and give it proper name
mv build/jna.jar ${JARFILENAME}
+ # Native compilation in build.xml is overly complex. With full control of the
+ # output directories we just do it on our own.
${CC} ${CFLAGS} ${LDFLAGS} -shared -fPIC -o libjnidispatch.so \
native/dispatch.c \
native/callback.c \
- -Ibuild/native -I${STAGING_INCDIR}/classpath -lffi
+ -Ibuild/native \
+ -I${STAGING_INCDIR}/classpath \
+ -lffi
}
do_install_append() {