aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/junit/junit4_4.3.1.bb
diff options
context:
space:
mode:
authorHenning Heinold <h.heinold@tarent.de>2010-07-12 16:01:32 +0200
committerHenning Heinold <h.heinold@tarent.de>2010-07-26 15:35:21 +0200
commit4275fd6f178a8666df6a7a3746bdbf8e5f704be7 (patch)
tree776c0a15b746f8e8ed89c77d5267fabfc58a538d /recipes/junit/junit4_4.3.1.bb
parent1fabe54f9dc7a695a7e018509db7924e3a0b53df (diff)
downloadopenembedded-4275fd6f178a8666df6a7a3746bdbf8e5f704be7.tar.gz
junit: backport from openembedded-dev
* checksums already in conf/checksums.ini Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes/junit/junit4_4.3.1.bb')
-rw-r--r--recipes/junit/junit4_4.3.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/junit/junit4_4.3.1.bb b/recipes/junit/junit4_4.3.1.bb
new file mode 100644
index 0000000000..2733aff2e1
--- /dev/null
+++ b/recipes/junit/junit4_4.3.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "JUnit is a testing framework for Java"
+LICENSES = "CPL"
+AUTHOR = "junit.org"
+HOMEPAGE = "http://www.junit.org"
+
+SRC_URI = "http://downloads.sourceforge.net/junit/junit-${PV}-src.jar"
+
+S = "${WORKDIR}"
+
+inherit java-library
+
+DEPENDS = "fastjar-native"
+
+do_compile() {
+ mkdir -p build
+
+ # Workaround for jamvm.
+ bcp=${STAGING_DATADIR_NATIVE}/classpath/glibj.zip
+
+ javac -source 5.0 -bootclasspath $bcp -sourcepath . -d build `find . -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}