aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/junit/junit_3.8.2.bb
diff options
context:
space:
mode:
authorHenning Heinold <h.heinold@tarent.de>2010-07-12 16:01:32 +0200
committerHenning Heinold <h.heinold@tarent.de>2010-07-26 15:35:21 +0200
commit4275fd6f178a8666df6a7a3746bdbf8e5f704be7 (patch)
tree776c0a15b746f8e8ed89c77d5267fabfc58a538d /recipes/junit/junit_3.8.2.bb
parent1fabe54f9dc7a695a7e018509db7924e3a0b53df (diff)
downloadopenembedded-4275fd6f178a8666df6a7a3746bdbf8e5f704be7.tar.gz
junit: backport from openembedded-dev
* checksums already in conf/checksums.ini Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes/junit/junit_3.8.2.bb')
-rw-r--r--recipes/junit/junit_3.8.2.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/junit/junit_3.8.2.bb b/recipes/junit/junit_3.8.2.bb
new file mode 100644
index 0000000000..2ba54b63a7
--- /dev/null
+++ b/recipes/junit/junit_3.8.2.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "JUnit is a testing framework for Java"
+LICENSES = "CPL"
+AUTHOR = "junit.org"
+HOMEPAGE = "http://www.junit.org"
+
+SRC_URI = "http://downloads.sourceforge.net/junit/junit${PV}.zip"
+
+S = "${WORKDIR}/junit${PV}"
+
+inherit java-library
+
+DEPENDS = "fastjar-native"
+
+do_unpackpost() {
+ mkdir -p src
+
+ # Prevent deletion by do_removebinaries.
+ mv src.jar src.zip
+
+ unzip src.zip -d src
+}
+
+addtask unpackpost before do_removebinaries after do_unpack
+
+do_compile() {
+ mkdir -p build
+
+ # Workaround for jamvm.
+ bcp=${STAGING_DATADIR_NATIVE}/classpath/glibj.zip
+
+ javac -bootclasspath $bcp -sourcepath src -d build `find src -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}