summaryrefslogtreecommitdiffstats
path: root/recipes/justreader
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/justreader
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/justreader')
-rw-r--r--recipes/justreader/files/correct-settings-path.patch16
-rw-r--r--recipes/justreader/justreader_2.0k.bb29
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes/justreader/files/correct-settings-path.patch b/recipes/justreader/files/correct-settings-path.patch
new file mode 100644
index 0000000000..e33bf37620
--- /dev/null
+++ b/recipes/justreader/files/correct-settings-path.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- TextReader2/qpex/config.cpp~correct-settings-path
++++ TextReader2/qpex/config.cpp
+@@ -109,7 +109,7 @@
+ case User: {
+ QString homeDirPath = QDir::homeDirPath();
+
+- QDir dir = (homeDirPath + "/Choices/common");
++ QDir dir = (homeDirPath + "/Settings");
+ if ( !dir.exists() )
+ #ifndef Q_OS_WIN32
+ mkdir(dir.path().local8Bit(),0700);
diff --git a/recipes/justreader/justreader_2.0k.bb b/recipes/justreader/justreader_2.0k.bb
new file mode 100644
index 0000000000..f3f71493fc
--- /dev/null
+++ b/recipes/justreader/justreader_2.0k.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "An E-Books reader for Qt/Embedded based Palmtop Environments"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://justreader.sourceforge.net/"
+PR = "r3"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/justreader/justreader_${PV}.tgz \
+file://correct-settings-path.patch;patch=1"
+
+S = "${WORKDIR}/TextReader2"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += 'INCLUDEPATH+="${STAGING_INCDIR}/qpe" LIBS+=-lqpe'
+export OE_QMAKE_LINK="${CXX}"
+
+do_configure_prepend() {
+ find . -name "Makefile"|xargs rm -f
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/pics/${PN}/ \
+ ${D}${palmtopdir}/apps/Applications
+ install -m 0644 apps/Applications/justreader.desktop ${D}${palmtopdir}/apps/Applications/
+ install -m 0755 bin/justreader ${D}${palmtopdir}/bin/
+ install -m 0644 pics/* ${D}${palmtopdir}/pics/justreader/
+}