aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kexec-tools
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2010-07-07 01:04:33 +0200
committerAndrea Adami <andrea.adami@gmail.com>2010-07-07 01:04:33 +0200
commit89ab4e3296970c5a4bb79c3104174d96fdf118a6 (patch)
treed45d619ea5f2bd19c88a9ada9eb615f2bf9c676d /recipes/kexec-tools
parent6112efc57e5c640b6acb2df6a72fd18bc329589c (diff)
downloadopenembedded-89ab4e3296970c5a4bb79c3104174d96fdf118a6.tar.gz
kexec-tools: add patch for autoconf >2.63 to version 1.101.
* taken from kexec-tools-2.0.1 recipe * bump PR.
Diffstat (limited to 'recipes/kexec-tools')
-rw-r--r--recipes/kexec-tools/kexec-tools-1.101/kexec-tools-autoconf-post-2.63.patch45
-rw-r--r--recipes/kexec-tools/kexec-tools.inc5
-rw-r--r--recipes/kexec-tools/kexec-tools_1.101.bb2
3 files changed, 50 insertions, 2 deletions
diff --git a/recipes/kexec-tools/kexec-tools-1.101/kexec-tools-autoconf-post-2.63.patch b/recipes/kexec-tools/kexec-tools-1.101/kexec-tools-autoconf-post-2.63.patch
new file mode 100644
index 0000000000..f6d192b02b
--- /dev/null
+++ b/recipes/kexec-tools/kexec-tools-1.101/kexec-tools-autoconf-post-2.63.patch
@@ -0,0 +1,45 @@
+Index: kexec-tools-1.101/configure.ac
+===================================================================
+--- kexec-tools-1.101/configure.ac.old 2010-07-07 00:58:37.000000000 +0200
++++ kexec-tools-1.101/configure.ac 2010-07-07 00:59:39.000000000 +0200
+@@ -100,23 +100,23 @@
+ BUILD_CFLAGS='-O2 -Wall $(CPPFLAGS)'
+
+ dnl ---Sanity checks
+-if test "$CC" = "no"; then AC_MSG_ERROR([cc not found]) fi
+-if test "$CPP" = "no"; then AC_MSG_ERROR([cpp not found]) fi
+-if test "$LD" = "no"; then AC_MSG_ERROR([ld not found]) fi
+-if test "$AS" = "no"; then AC_MSG_ERROR([as not found]) fi
+-if test "$OBJCOPY" = "no"; then AC_MSG_ERROR([objcopy not found]) fi
+-if test "$AR" = "no"; then AC_MSG_ERROR([ar not found]) fi
+-
+-if test "$MKDIR" = "no"; then AC_MSG_ERROR([ mkdir not found]) fi
+-if test "$RM" = "no"; then AC_MSG_ERROR([ rm not found]) fi
+-if test "$CP" = "no"; then AC_MSG_ERROR([ cp not found]) fi
+-if test "$LN" = "no"; then AC_MSG_ERROR([ ln not found]) fi
+-if test "$TAR" = "no"; then AC_MSG_ERROR([ tar not found]) fi
+-if test "$RPM" = "no"; then AC_MSG_ERROR([ rpm not found]) fi
+-if test "$SED" = "no"; then AC_MSG_ERROR([ sed not found]) fi
+-if test "$FIND" = "no"; then AC_MSG_ERROR([ find not found]) fi
+-if test "$XARGS" = "no"; then AC_MSG_ERROR([ xargs not found]) fi
+-if test "$DIRNAME" = "no"; then AC_MSG_ERROR([ dirname not found]) fi
++if test "$CC" = "no"; then AC_MSG_ERROR([cc not found]); fi
++if test "$CPP" = "no"; then AC_MSG_ERROR([cpp not found]); fi
++if test "$LD" = "no"; then AC_MSG_ERROR([ld not found]); fi
++if test "$AS" = "no"; then AC_MSG_ERROR([as not found]); fi
++if test "$OBJCOPY" = "no"; then AC_MSG_ERROR([objcopy not found]); fi
++if test "$AR" = "no"; then AC_MSG_ERROR([ar not found]); fi
++
++if test "$MKDIR" = "no"; then AC_MSG_ERROR([ mkdir not found]); fi
++if test "$RM" = "no"; then AC_MSG_ERROR([ rm not found]); fi
++if test "$CP" = "no"; then AC_MSG_ERROR([ cp not found]); fi
++if test "$LN" = "no"; then AC_MSG_ERROR([ ln not found]); fi
++if test "$TAR" = "no"; then AC_MSG_ERROR([ tar not found]); fi
++if test "$RPM" = "no"; then AC_MSG_ERROR([ rpm not found]); fi
++if test "$SED" = "no"; then AC_MSG_ERROR([ sed not found]); fi
++if test "$FIND" = "no"; then AC_MSG_ERROR([ find not found]); fi
++if test "$XARGS" = "no"; then AC_MSG_ERROR([ xargs not found]); fi
++if test "$DIRNAME" = "no"; then AC_MSG_ERROR([ dirname not found]); fi
+
+ dnl ---Output variables...
+
diff --git a/recipes/kexec-tools/kexec-tools.inc b/recipes/kexec-tools/kexec-tools.inc
index 0ff1c31cc0..eb84d5670f 100644
--- a/recipes/kexec-tools/kexec-tools.inc
+++ b/recipes/kexec-tools/kexec-tools.inc
@@ -10,4 +10,7 @@ inherit autotools
SRC_URI = "http://www.xmission.com/~ebiederm/files/kexec/kexec-tools-${PV}.tar.gz \
file://kexec-tools-arm.patch \
- file://kexec-arm-atags.patch"
+ file://kexec-arm-atags.patch \
+ file://kexec-tools-autoconf-post-2.63.patch \
+ "
+
diff --git a/recipes/kexec-tools/kexec-tools_1.101.bb b/recipes/kexec-tools/kexec-tools_1.101.bb
index 3a11b35d26..17315d561a 100644
--- a/recipes/kexec-tools/kexec-tools_1.101.bb
+++ b/recipes/kexec-tools/kexec-tools_1.101.bb
@@ -2,7 +2,7 @@ require kexec-tools.inc
export LDFLAGS = "-L${STAGING_LIBDIR}"
EXTRA_OECONF = " --with-zlib=yes"
-PR = "r5"
+PR = "r6"
SRC_URI[md5sum] = "b4f7ffcc294d41a6a4c40d6e44b7734d"
SRC_URI[sha256sum] = "280b34fefa12c3d7a3e432c3730fe5d0d56e8d169c28b695cce9ba6d8dbe6e38"