aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kexec
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/kexec
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/kexec')
-rw-r--r--recipes/kexec/files/kexec-arm-atags.patch294
-rw-r--r--recipes/kexec/files/kexec-klibc.patch151
-rw-r--r--recipes/kexec/files/kexec-static.patch12
-rw-r--r--recipes/kexec/files/kexec-tools-arm.patch417
-rw-r--r--recipes/kexec/kexec-tools-static_1.101.bb23
-rw-r--r--recipes/kexec/kexec-tools.inc13
-rw-r--r--recipes/kexec/kexec-tools_1.101.bb5
7 files changed, 915 insertions, 0 deletions
diff --git a/recipes/kexec/files/kexec-arm-atags.patch b/recipes/kexec/files/kexec-arm-atags.patch
new file mode 100644
index 0000000000..bf6f640035
--- /dev/null
+++ b/recipes/kexec/files/kexec-arm-atags.patch
@@ -0,0 +1,294 @@
+---
+ kexec/arch/arm/kexec-zImage-arm.c | 259 ++++++++++++++++++++++++++++++++++++--
+ 1 file changed, 252 insertions(+), 7 deletions(-)
+
+Index: kexec-tools-1.101/kexec/arch/arm/kexec-zImage-arm.c
+===================================================================
+--- kexec-tools-1.101.orig/kexec/arch/arm/kexec-zImage-arm.c 2007-12-26 21:17:07.000000000 +0000
++++ kexec-tools-1.101/kexec/arch/arm/kexec-zImage-arm.c 2007-12-27 01:24:25.000000000 +0000
+@@ -1,11 +1,83 @@
++/*
++ * - 08/21/2007 ATAG support added by Uli Luckas <u.luckas@road.de>
++ *
++ */
+ #define _GNU_SOURCE
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
+ #include <errno.h>
+ #include <limits.h>
++#include <stdint.h>
++#include <getopt.h>
++#include <arch/options.h>
++#include <asm/page.h>
+ #include "../../kexec.h"
+
++#define COMMAND_LINE_SIZE 1024
++#define BOOT_PARAMS_SIZE 1536
++
++struct tag_header {
++ uint32_t size;
++ uint32_t tag;
++};
++
++/* The list must start with an ATAG_CORE node */
++#define ATAG_CORE 0x54410001
++
++struct tag_core {
++ uint32_t flags; /* bit 0 = read-only */
++ uint32_t pagesize;
++ uint32_t rootdev;
++};
++
++/* it is allowed to have multiple ATAG_MEM nodes */
++#define ATAG_MEM 0x54410002
++
++struct tag_mem32 {
++ uint32_t size;
++ uint32_t start; /* physical start address */
++};
++
++/* describes where the compressed ramdisk image lives (virtual address) */
++/*
++ * this one accidentally used virtual addresses - as such,
++ * it's deprecated.
++ */
++#define ATAG_INITRD 0x54410005
++
++/* describes where the compressed ramdisk image lives (physical address) */
++#define ATAG_INITRD2 0x54420005
++
++struct tag_initrd {
++ uint32_t start; /* physical start address */
++ uint32_t size; /* size of compressed ramdisk image in bytes */
++};
++
++/* command line: \0 terminated string */
++#define ATAG_CMDLINE 0x54410009
++
++struct tag_cmdline {
++ char cmdline[1]; /* this is the minimum size */
++};
++
++/* The list ends with an ATAG_NONE node. */
++#define ATAG_NONE 0x00000000
++
++struct tag {
++ struct tag_header hdr;
++ union {
++ struct tag_core core;
++ struct tag_mem32 mem;
++ struct tag_initrd initrd;
++ struct tag_cmdline cmdline;
++ } u;
++};
++
++#define tag_next(t) ((struct tag *)((uint32_t *)(t) + (t)->hdr.size))
++#define byte_size(t) ((t)->hdr.size << 2)
++#define tag_size(type) ((sizeof(struct tag_header) + sizeof(struct type) + 3) >> 2)
++
+ int zImage_arm_probe(const char *buf, off_t len)
+ {
+ /*
+@@ -14,21 +86,194 @@ int zImage_arm_probe(const char *buf, of
+ */
+ return 0;
+ }
++
+ void zImage_arm_usage(void)
+ {
++ printf( " --command-line=STRING Set the kernel command line to STRING.\n"
++ " --append=STRING Set the kernel command line to STRING.\n"
++ " --initrd=FILE Use FILE as the kernel's initial ramdisk.\n"
++ " --ramdisk=FILE Use FILE as the kernel's initial ramdisk.\n"
++ );
+ }
+-int zImage_arm_load(int argc, char **argv, const char *buf, off_t len,
++
++static
++struct tag * atag_read_tags(void)
++{
++ static unsigned long buf[BOOT_PARAMS_SIZE];
++ const char fn[]= "/proc/atags";
++ FILE *fp;
++ fp = fopen(fn, "r");
++ if (!fp) {
++ fprintf(stderr, "Cannot open %s: %s\n",
++ fn, strerror(errno));
++ return NULL;
++ }
++
++ fread(buf, sizeof(buf[1]), BOOT_PARAMS_SIZE, fp);
++ if (ferror(fp)) {
++ fprintf(stderr, "Cannot read %s: %s\n",
++ fn, strerror(errno));
++ fclose(fp);
++ return NULL;
++ }
++
++ fclose(fp);
++ return (struct tag *) buf;
++}
++
++
++static
++int atag_arm_load(struct kexec_info *info, unsigned long base,
++ const char *command_line, off_t command_line_len,
++ const char *initrd, off_t initrd_len)
++{
++ struct tag *saved_tags = atag_read_tags();
++ char *buf;
++ off_t len;
++ struct tag *params;
++ uint32_t *initrd_start;
++
++ buf = xmalloc(getpagesize());
++ if (!buf) {
++ fprintf(stderr, "Compiling ATAGs: out of memory\n");
++ return -1;
++ }
++
++ memset(buf, 0xff, getpagesize());
++ params = (struct tag *)buf;
++
++ if (saved_tags) {
++ // Copy tags
++ saved_tags = (struct tag *) saved_tags;
++ while(byte_size(saved_tags)) {
++ switch (saved_tags->hdr.tag) {
++ case ATAG_INITRD:
++ case ATAG_INITRD2:
++ case ATAG_CMDLINE:
++ case ATAG_NONE:
++ // skip these tags
++ break;
++ default:
++ // copy all other tags
++ memcpy(params, saved_tags, byte_size(saved_tags));
++ params = tag_next(params);
++ }
++ saved_tags = tag_next(saved_tags);
++ }
++ } else {
++ params->hdr.size = 2;
++ params->hdr.tag = ATAG_CORE;
++ params = tag_next(params);
++ }
++
++ if (initrd) {
++ params->hdr.size = tag_size(tag_initrd);
++ params->hdr.tag = ATAG_INITRD2;
++ initrd_start = &params->u.initrd.start;
++ params->u.initrd.size = initrd_len;
++ params = tag_next(params);
++ }
++
++ if (command_line) {
++ params->hdr.size = (sizeof(struct tag_header) + command_line_len + 3) >> 2;
++ params->hdr.tag = ATAG_CMDLINE;
++ memcpy(params->u.cmdline.cmdline, command_line,
++ command_line_len);
++ params->u.cmdline.cmdline[command_line_len - 1] = '\0';
++ params = tag_next(params);
++ }
++
++ params->hdr.size = 0;
++ params->hdr.tag = ATAG_NONE;
++
++ len = ((char *)params - buf) + sizeof(struct tag_header);
++
++ add_segment(info, buf, len, base, len);
++
++ if (initrd) {
++ struct memory_range *range;
++ int ranges;
++ get_memory_ranges(&range, &ranges);
++ *initrd_start = locate_hole(info, initrd_len, getpagesize(), range[0].start + 0x800000, ULONG_MAX, INT_MAX);
++ if (*initrd_start == ULONG_MAX)
++ return -1;
++ add_segment(info, initrd, initrd_len, *initrd_start, initrd_len);
++ }
++
++ return 0;
++}
++
++int zImage_arm_load(int argc, char **argv, const char *buf, off_t len,
+ struct kexec_info *info)
+ {
+ unsigned long base;
+- unsigned int offset = 0x8000; /* 32k offset from memory start */
++ unsigned int atag_offset = 0x1000; /* 4k offset from memory start */
++ unsigned int offset = 0x8000; /* 32k offset from memory start */
++ const char *command_line;
++ off_t command_line_len;
++ const char *ramdisk;
++ char *ramdisk_buf;
++ off_t ramdisk_length;
++ int opt;
++#define OPT_APPEND 'a'
++#define OPT_RAMDISK 'r'
++ static const struct option options[] = {
++ KEXEC_ARCH_OPTIONS
++ { "command-line", 1, 0, OPT_APPEND },
++ { "append", 1, 0, OPT_APPEND },
++ { "initrd", 1, 0, OPT_RAMDISK },
++ { "ramdisk", 1, 0, OPT_RAMDISK },
++ { 0, 0, 0, 0 },
++ };
++ static const char short_options[] = KEXEC_ARCH_OPT_STR "a:r:";
++
++ /*
++ * Parse the command line arguments
++ */
++ command_line = 0;
++ command_line_len = 0;
++ ramdisk = 0;
++ ramdisk_buf = 0;
++ ramdisk_length = 0;
++ while((opt = getopt_long(argc, argv, short_options, options, 0)) != -1) {
++ switch(opt) {
++ default:
++ /* Ignore core options */
++ if (opt < OPT_ARCH_MAX) {
++ break;
++ }
++ case '?':
++ usage();
++ return -1;
++ case OPT_APPEND:
++ command_line = optarg;
++ break;
++ case OPT_RAMDISK:
++ ramdisk = optarg;
++ break;
++ }
++ }
++ if (command_line) {
++ command_line_len = strlen(command_line) + 1;
++ if (command_line_len > COMMAND_LINE_SIZE)
++ command_line_len = COMMAND_LINE_SIZE;
++ }
++ if (ramdisk) {
++ ramdisk_buf = slurp_file(ramdisk, &ramdisk_length);
++ }
++
+ base = locate_hole(info,len+offset,0,0,ULONG_MAX,INT_MAX);
+ if (base == ULONG_MAX)
+- {
+ return -1;
+- }
+- base += offset;
+- add_segment(info,buf,len,base,len);
+- info->entry = (void*)base;
++
++ if (atag_arm_load(info, base + atag_offset,
++ command_line, command_line_len,
++ ramdisk_buf, ramdisk_length) == -1)
++ return -1;
++
++ add_segment(info, buf, len, base + offset, len);
++
++ info->entry = (void*)base + offset;
++
+ return 0;
+ }
diff --git a/recipes/kexec/files/kexec-klibc.patch b/recipes/kexec/files/kexec-klibc.patch
new file mode 100644
index 0000000000..090b6231f1
--- /dev/null
+++ b/recipes/kexec/files/kexec-klibc.patch
@@ -0,0 +1,151 @@
+Index: kexec-tools-1.101/kexec/arch/arm/kexec-elf-rel-arm.c
+===================================================================
+--- kexec-tools-1.101.orig/kexec/arch/arm/kexec-elf-rel-arm.c 2008-02-24 14:15:46.934825202 +0100
++++ kexec-tools-1.101/kexec/arch/arm/kexec-elf-rel-arm.c 2008-02-24 14:15:47.014827381 +0100
+@@ -1,5 +1,5 @@
+ #include <stdio.h>
+-#include <elf.h>
++#include "../../../include/elf.h"
+ #include "../../kexec.h"
+ #include "../../kexec-elf.h"
+
+Index: kexec-tools-1.101/kexec/arch/arm/kexec-zImage-arm.c
+===================================================================
+--- kexec-tools-1.101.orig/kexec/arch/arm/kexec-zImage-arm.c 2008-02-24 14:15:46.982825391 +0100
++++ kexec-tools-1.101/kexec/arch/arm/kexec-zImage-arm.c 2008-07-26 01:58:20.838624318 +0200
+@@ -2,6 +2,10 @@
+ * - 08/21/2007 ATAG support added by Uli Luckas <u.luckas@road.de>
+ *
+ */
++
++/* work around for linux header files */
++#define __deprecated
++
+ #define _GNU_SOURCE
+ #include <stdio.h>
+ #include <string.h>
+@@ -110,13 +114,13 @@
+ }
+
+ fread(buf, sizeof(buf[1]), BOOT_PARAMS_SIZE, fp);
+- if (ferror(fp)) {
++/* if (ferror(fp)) {
+ fprintf(stderr, "Cannot read %s: %s\n",
+ fn, strerror(errno));
+ fclose(fp);
+ return NULL;
+ }
+-
++*/
+ fclose(fp);
+ return (struct tag *) buf;
+ }
+Index: kexec-tools-1.101/kexec/ifdown.c
+===================================================================
+--- kexec-tools-1.101.orig/kexec/ifdown.c 2008-02-24 14:15:34.025828340 +0100
++++ kexec-tools-1.101/kexec/ifdown.c 2008-02-24 14:15:47.014827381 +0100
+@@ -14,7 +14,7 @@
+ #include <sys/ioctl.h>
+ #include <sys/socket.h>
+ #include <sys/time.h>
+-#include <sys/errno.h>
++#include <errno.h>
+
+ #include <net/if.h>
+ #include <netinet/in.h>
+Index: kexec-tools-1.101/purgatory/Makefile
+===================================================================
+--- kexec-tools-1.101.orig/purgatory/Makefile 2008-02-24 14:15:34.037827479 +0100
++++ kexec-tools-1.101/purgatory/Makefile 2008-02-24 14:15:47.022825503 +0100
+@@ -13,7 +13,7 @@
+
+ PCFLAGS += $(call cc-option, -ffreestanding)
+ PCFLAGS += $(call cc-option, -fnobuiltin)
+-PCFLAGS += $(call cc-option, -fnostdinc)
++PCFLAGS += $(call cc-option, -nostdinc)
+ PCFLAGS += $(call cc-option, -fno-zero-initialized-in-bss)
+
+ PURGATORY_C_SRCS:=
+Index: kexec-tools-1.101/kexec/kexec-elf-rel.c
+===================================================================
+--- kexec-tools-1.101.orig/kexec/kexec-elf-rel.c 2008-02-24 14:15:34.025828340 +0100
++++ kexec-tools-1.101/kexec/kexec-elf-rel.c 2008-02-24 14:15:47.030825302 +0100
+@@ -4,7 +4,7 @@
+ #include <stdio.h>
+ #include <errno.h>
+ #include <stdlib.h>
+-#include "elf.h"
++#include "../include/elf.h"
+ #include <boot/elf_boot.h>
+ #include "kexec.h"
+ #include "kexec-elf.h"
+Index: kexec-tools-1.101/kexec/kexec-syscall.h
+===================================================================
+--- kexec-tools-1.101.orig/kexec/kexec-syscall.h 2008-02-24 14:15:46.950825917 +0100
++++ kexec-tools-1.101/kexec/kexec-syscall.h 2008-02-24 14:15:47.030825302 +0100
+@@ -2,7 +2,7 @@
+ #define KEXEC_SYSCALL_H
+
+ #define __LIBRARY__
+-#include <syscall.h>
++/*#include <syscall.h>*/
+ #include <sys/syscall.h>
+ #include <unistd.h>
+
+@@ -21,7 +21,7 @@
+ #define LINUX_REBOOT_CMD_KEXEC_OLD 0x81726354
+ #define LINUX_REBOOT_CMD_KEXEC_OLD2 0x18263645
+ #define LINUX_REBOOT_CMD_KEXEC 0x45584543
+-
++/*
+ #ifdef __i386__
+ #define __NR_kexec_load 283
+ #endif
+@@ -43,18 +43,19 @@
+ #ifndef __NR_kexec_load
+ #error Unknown processor architecture. Needs a kexec_load syscall number.
+ #endif
+-
++*/
+ struct kexec_segment;
+-
++/*
+ static inline long kexec_load(void *entry, unsigned long nr_segments,
+ struct kexec_segment *segments, unsigned long flags)
+ {
+ return (long) syscall(__NR_kexec_load, entry, nr_segments, segments, flags);
+ }
+-
++*/
+ static inline long kexec_reboot(void)
+ {
+- return (long) syscall(__NR_reboot, LINUX_REBOOT_MAGIC1, LINUX_REBOOT_MAGIC2, LINUX_REBOOT_CMD_KEXEC, 0);
++ //return (long) syscall(__NR_reboot, LINUX_REBOOT_MAGIC1, LINUX_REBOOT_MAGIC2, LINUX_REBOOT_CMD_KEXEC, 0);
++ return __reboot(LINUX_REBOOT_MAGIC1, LINUX_REBOOT_MAGIC2, LINUX_REBOOT_CMD_KEXEC, 0);
+ }
+
+
+Index: kexec-tools-1.101/kexec/kexec.c
+===================================================================
+--- kexec-tools-1.101.orig/kexec/kexec.c 2008-02-24 14:15:46.950825917 +0100
++++ kexec-tools-1.101/kexec/kexec.c 2008-07-26 01:58:53.545624148 +0200
+@@ -29,9 +29,7 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <getopt.h>
+-#ifdef HAVE_ZLIB_H
+-#include <zlib.h>
+-#endif
++#include "zlib.h"
+ #include <sha256.h>
+ #include "kexec.h"
+ #include "kexec-syscall.h"
+@@ -383,7 +381,7 @@
+ return buf;
+ }
+
+-#if HAVE_ZLIB_H
++#if 1
+ char *slurp_decompress_file(const char *filename, off_t *r_size)
+ {
+ gzFile fp;
diff --git a/recipes/kexec/files/kexec-static.patch b/recipes/kexec/files/kexec-static.patch
new file mode 100644
index 0000000000..549300576e
--- /dev/null
+++ b/recipes/kexec/files/kexec-static.patch
@@ -0,0 +1,12 @@
+diff -ur kexec-tools-1.101.bak/configure.ac kexec-tools-1.101/configure.ac
+--- kexec-tools-1.101.bak/configure.ac 2008-02-03 00:05:59.577094746 +0100
++++ kexec-tools-1.101/configure.ac 2008-02-03 00:06:35.579146386 +0100
+@@ -96,7 +96,7 @@
+
+ dnl ---Hard codes
+
+-CFLAGS='-Wall -g -fno-strict-aliasing $(CPPFLAGS)'
++CFLAGS='-Wall -g -static -fno-strict-aliasing $(CPPFLAGS)'
+ BUILD_CFLAGS='-O2 -Wall $(CPPFLAGS)'
+
+ dnl ---Sanity checks
diff --git a/recipes/kexec/files/kexec-tools-arm.patch b/recipes/kexec/files/kexec-tools-arm.patch
new file mode 100644
index 0000000000..6e43b76096
--- /dev/null
+++ b/recipes/kexec/files/kexec-tools-arm.patch
@@ -0,0 +1,417 @@
+Index: kexec-tools-1.101/kexec/arch/arm/include/arch/options.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ kexec-tools-1.101/kexec/arch/arm/include/arch/options.h 2006-02-06 18:28:37.027097280 +0100
+@@ -0,0 +1,11 @@
++#ifndef KEXEC_ARCH_ARM_OPTIONS_H
++#define KEXEC_ARCH_ARM_OPTIONS_H
++
++#define OPT_ARCH_MAX (OPT_MAX+0)
++
++#define KEXEC_ARCH_OPTIONS \
++ KEXEC_OPTIONS \
++
++#define KEXEC_ARCH_OPT_STR KEXEC_OPT_STR ""
++
++#endif /* KEXEC_ARCH_ARM_OPTIONS_H */
+Index: kexec-tools-1.101/kexec/arch/arm/kexec-arm.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ kexec-tools-1.101/kexec/arch/arm/kexec-arm.c 2006-02-06 18:28:37.027097280 +0100
+@@ -0,0 +1,138 @@
++/*
++ * kexec: Linux boots Linux
++ *
++ * modified from kexec-ppc.c
++ *
++ */
++
++#define _GNU_SOURCE
++#include <stddef.h>
++#include <stdio.h>
++#include <errno.h>
++#include <stdint.h>
++#include <string.h>
++#include <getopt.h>
++#include <sys/utsname.h>
++#include "../../kexec.h"
++#include "../../kexec-syscall.h"
++#include "kexec-arm.h"
++#include <arch/options.h>
++
++#define MAX_MEMORY_RANGES 64
++#define MAX_LINE 160
++static struct memory_range memory_range[MAX_MEMORY_RANGES];
++
++/* Return a sorted list of available memory ranges. */
++int get_memory_ranges(struct memory_range **range, int *ranges)
++{
++ const char iomem[]= "/proc/iomem";
++ int memory_ranges = 0;
++ char line[MAX_LINE];
++ FILE *fp;
++ fp = fopen(iomem, "r");
++ if (!fp) {
++ fprintf(stderr, "Cannot open %s: %s\n",
++ iomem, strerror(errno));
++ return -1;
++ }
++
++ while(fgets(line, sizeof(line), fp) != 0) {
++ unsigned long long start, end;
++ char *str;
++ int type;
++ int consumed;
++ int count;
++ if (memory_ranges >= MAX_MEMORY_RANGES)
++ break;
++ count = sscanf(line, "%Lx-%Lx : %n",
++ &start, &end, &consumed);
++ if (count != 2)
++ continue;
++ str = line + consumed;
++ end = end + 1;
++
++ if (memcmp(str, "System RAM\n", 11) == 0) {
++ type = RANGE_RAM;
++ }
++ else if (memcmp(str, "reserved\n", 9) == 0) {
++ type = RANGE_RESERVED;
++ }
++ else {
++ continue;
++ }
++
++ memory_range[memory_ranges].start = start;
++ memory_range[memory_ranges].end = end;
++ memory_range[memory_ranges].type = type;
++ memory_ranges++;
++ }
++ fclose(fp);
++ *range = memory_range;
++ *ranges = memory_ranges;
++ return 0;
++}
++
++/* Supported file types and callbacks */
++struct file_type file_type[] = {
++ {"zImage", zImage_arm_probe, zImage_arm_load, zImage_arm_usage},
++};
++int file_types = sizeof(file_type) / sizeof(file_type[0]);
++
++
++void arch_usage(void)
++{
++}
++
++static struct {
++} arch_options = {
++};
++int arch_process_options(int argc, char **argv)
++{
++ static const struct option options[] = {
++ KEXEC_ARCH_OPTIONS
++ { 0, 0, NULL, 0 },
++ };
++ static const char short_options[] = KEXEC_ARCH_OPT_STR;
++ int opt;
++ unsigned long value;
++ char *end;
++
++ opterr = 0; /* Don't complain about unrecognized options here */
++ while((opt = getopt_long(argc, argv, short_options, options, 0)) != -1) {
++ switch(opt) {
++ default:
++ break;
++ }
++ }
++ /* Reset getopt for the next pass; called in other source modules */
++ opterr = 1;
++ optind = 1;
++ return 0;
++}
++
++int arch_compat_trampoline(struct kexec_info *info, unsigned long *flags)
++{
++ int result;
++ struct utsname utsname;
++ result = uname(&utsname);
++ if (result < 0) {
++ fprintf(stderr, "uname failed: %s\n",
++ strerror(errno));
++ return -1;
++ }
++ if (strncmp(utsname.machine, "arm",3) == 0)
++ {
++ *flags |= KEXEC_ARCH_ARM;
++ }
++ else {
++ fprintf(stderr, "Unsupported machine type: %s\n",
++ utsname.machine);
++ return -1;
++ }
++ return 0;
++}
++
++void arch_update_purgatory(struct kexec_info *info)
++{
++}
++
+Index: kexec-tools-1.101/kexec/arch/arm/kexec-arm.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ kexec-tools-1.101/kexec/arch/arm/kexec-arm.h 2006-02-06 18:28:37.028097128 +0100
+@@ -0,0 +1,9 @@
++#ifndef KEXEC_ARM_H
++#define KEXEC_ARM_H
++
++int zImage_arm_probe(const char *buf, off_t len);
++int zImage_arm_load(int argc, char **argv, const char *buf, off_t len,
++ struct kexec_info *info);
++void zImage_arm_usage(void);
++
++#endif /* KEXEC_ARM_H */
+Index: kexec-tools-1.101/kexec/arch/arm/kexec-elf-rel-arm.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ kexec-tools-1.101/kexec/arch/arm/kexec-elf-rel-arm.c 2006-02-06 18:28:37.028097128 +0100
+@@ -0,0 +1,35 @@
++#include <stdio.h>
++#include <elf.h>
++#include "../../kexec.h"
++#include "../../kexec-elf.h"
++
++int machine_verify_elf_rel(struct mem_ehdr *ehdr)
++{
++ if (ehdr->ei_data != ELFDATA2MSB) {
++ return 0;
++ }
++ if (ehdr->ei_class != ELFCLASS32) {
++ return 0;
++ }
++ if (ehdr->e_machine != EM_ARM)
++ {
++ return 0;
++ }
++ return 1;
++}
++
++void machine_apply_elf_rel(struct mem_ehdr *ehdr, unsigned long r_type,
++ void *location, unsigned long address, unsigned long value)
++{
++ switch(r_type) {
++ case R_ARM_ABS32:
++ *((uint32_t *)location) += value;
++ break;
++ case R_ARM_REL32:
++ *((uint32_t *)location) += value - address;
++ break;
++ default:
++ die("Unknown rel relocation: %lu\n", r_type);
++ break;
++ }
++}
+Index: kexec-tools-1.101/kexec/arch/arm/kexec-zImage-arm.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ kexec-tools-1.101/kexec/arch/arm/kexec-zImage-arm.c 2006-02-06 18:28:37.028097128 +0100
+@@ -0,0 +1,34 @@
++#define _GNU_SOURCE
++#include <stdio.h>
++#include <string.h>
++#include <stdlib.h>
++#include <errno.h>
++#include <limits.h>
++#include "../../kexec.h"
++
++int zImage_arm_probe(const char *buf, off_t len)
++{
++ /*
++ * Only zImage loading is supported. Do not check if
++ * the buffer is valid kernel image
++ */
++ return 0;
++}
++void zImage_arm_usage(void)
++{
++}
++int zImage_arm_load(int argc, char **argv, const char *buf, off_t len,
++ struct kexec_info *info)
++{
++ unsigned long base;
++ unsigned int offset = 0x8000; /* 32k offset from memory start */
++ base = locate_hole(info,len+offset,0,0,ULONG_MAX,INT_MAX);
++ if (base == ULONG_MAX)
++ {
++ return -1;
++ }
++ base += offset;
++ add_segment(info,buf,len,base,len);
++ info->entry = (void*)base;
++ return 0;
++}
+Index: kexec-tools-1.101/kexec/arch/arm/Makefile
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ kexec-tools-1.101/kexec/arch/arm/Makefile 2006-02-06 18:28:37.028097128 +0100
+@@ -0,0 +1,8 @@
++#
++# kexec arm (linux booting linux)
++#
++KEXEC_C_SRCS+= kexec/arch/arm/kexec-elf-rel-arm.c
++KEXEC_C_SRCS+= kexec/arch/arm/kexec-zImage-arm.c
++KEXEC_C_SRCS+= kexec/arch/arm/kexec-arm.c
++
++KEXEC_S_SRCS+=
+Index: kexec-tools-1.101/kexec/kexec.c
+===================================================================
+--- kexec-tools-1.101.orig/kexec/kexec.c 2005-01-13 14:24:29.000000000 +0100
++++ kexec-tools-1.101/kexec/kexec.c 2006-02-06 18:28:37.029096976 +0100
+@@ -187,7 +187,7 @@
+ }
+
+ /* Compute the free memory ranges */
+- max_mem_ranges = memory_ranges + (info->nr_segments -1);
++ max_mem_ranges = memory_ranges + (info->nr_segments);
+ mem_range = malloc(max_mem_ranges *sizeof(struct memory_range));
+ mem_ranges = 0;
+
+Index: kexec-tools-1.101/kexec/kexec-syscall.h
+===================================================================
+--- kexec-tools-1.101.orig/kexec/kexec-syscall.h 2005-01-06 07:59:50.000000000 +0100
++++ kexec-tools-1.101/kexec/kexec-syscall.h 2006-02-06 18:28:37.029096976 +0100
+@@ -37,6 +37,9 @@
+ #ifdef __x86_64__
+ #define __NR_kexec_load 246
+ #endif
++#ifdef __arm__
++#define __NR_kexec_load __NR_SYSCALL_BASE + 347
++#endif
+ #ifndef __NR_kexec_load
+ #error Unknown processor architecture. Needs a kexec_load syscall number.
+ #endif
+@@ -67,6 +70,7 @@
+ #define KEXEC_ARCH_PPC (20 << 16)
+ #define KEXEC_ARCH_PPC64 (21 << 16)
+ #define KEXEC_ARCH_IA_64 (50 << 16)
++#define KEXEC_ARCH_ARM (40 << 16)
+
+ #define KEXEC_MAX_SEGMENTS 8
+
+Index: kexec-tools-1.101/purgatory/arch/arm/include/limits.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ kexec-tools-1.101/purgatory/arch/arm/include/limits.h 2006-02-06 18:28:37.031096672 +0100
+@@ -0,0 +1,58 @@
++#ifndef LIMITS_H
++#define LIMITS_H 1
++
++
++/* Number of bits in a `char' */
++#define CHAR_BIT 8
++
++/* Minimum and maximum values a `signed char' can hold */
++#define SCHAR_MIN (-128)
++#define SCHAR_MAX 127
++
++/* Maximum value an `unsigned char' can hold. (Minimum is 0.) */
++#define UCHAR_MAX 255
++
++/* Minimum and maximum values a `char' can hold */
++#define CHAR_MIN SCHAR_MIN
++#define CHAR_MAX SCHAR_MAX
++
++/* Minimum and maximum values a `signed short int' can hold */
++#define SHRT_MIN (-32768)
++#define SHRT_MAX 32767
++
++/* Maximum value an `unsigned short' can hold. (Minimum is 0.) */
++#define USHRT_MAX 65535
++
++
++/* Minimum and maximum values a `signed int' can hold */
++#define INT_MIN (-INT_MAX - 1)
++#define INT_MAX 2147483647
++
++/* Maximum value an `unsigned int' can hold. (Minimum is 0.) */
++#define UINT_MAX 4294967295U
++
++
++/* Minimum and maximum values a `signed int' can hold */
++#define INT_MIN (-INT_MAX - 1)
++#define INT_MAX 2147483647
++
++/* Maximum value an `unsigned int' can hold. (Minimum is 0.) */
++#define UINT_MAX 4294967295U
++
++/* Minimum and maximum values a `signed long' can hold */
++#define LONG_MAX 2147483647L
++#define LONG_MIN (-LONG_MAX - 1L)
++
++/* Maximum value an `unsigned long' can hold. (Minimum is 0.) */
++#define ULONG_MAX 4294967295UL
++
++/* Minimum and maximum values a `signed long long' can hold */
++#define LLONG_MAX 9223372036854775807LL
++#define LLONG_MIN (-LONG_MAX - 1LL)
++
++
++/* Maximum value an `unsigned long long' can hold. (Minimum is 0.) */
++#define ULLONG_MAX 18446744073709551615ULL
++
++
++#endif /* LIMITS_H */
+Index: kexec-tools-1.101/purgatory/arch/arm/include/stdint.h
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ kexec-tools-1.101/purgatory/arch/arm/include/stdint.h 2006-02-06 18:28:37.031096672 +0100
+@@ -0,0 +1,16 @@
++#ifndef STDINT_H
++#define STDINT_H
++
++typedef unsigned long size_t;
++
++typedef unsigned char uint8_t;
++typedef unsigned short uint16_t;
++typedef unsigned int uint32_t;
++typedef unsigned long long uint64_t;
++
++typedef signed char int8_t;
++typedef signed short int16_t;
++typedef signed int int32_t;
++typedef signed long long int64_t;
++
++#endif /* STDINT_H */
+Index: kexec-tools-1.101/purgatory/arch/arm/Makefile
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ kexec-tools-1.101/purgatory/arch/arm/Makefile 2006-02-06 18:28:37.031096672 +0100
+@@ -0,0 +1,7 @@
++#
++# Purgatory arm
++#
++
++PURGATORY_S_SRCS +=
++PURGATORY_C_SRCS +=
++
+Index: kexec-tools-1.101/configure.ac
+===================================================================
+--- kexec-tools-1.101.orig/configure.ac 2005-01-09 02:36:57.000000000 +0100
++++ kexec-tools-1.101/configure.ac 2006-02-06 18:30:19.274553304 +0100
+@@ -25,12 +25,15 @@
+ powerpc )
+ host_cpu="ppc"
+ ;;
++ arm* )
++ host_cpu="arm"
++ ;;
+ * )
+ host_cpu="$host_cpu"
+ ;;
+ esac
+ case $host_cpu in
+- i386|ppc|x86_64|alpha|ppc64|ia64)
++ i386|ppc|x86_64|alpha|ppc64|ia64|arm)
+ ;;
+ * )
+ AC_MSG_ERROR([ unsupported architecture $host_cpu])
diff --git a/recipes/kexec/kexec-tools-static_1.101.bb b/recipes/kexec/kexec-tools-static_1.101.bb
new file mode 100644
index 0000000000..670f055506
--- /dev/null
+++ b/recipes/kexec/kexec-tools-static_1.101.bb
@@ -0,0 +1,23 @@
+# the binaries are statical linked against klibc
+require kexec-tools.inc
+
+PR = "r4"
+DEPENDS = "klibc"
+
+SRC_URI += "file://kexec-klibc.patch;patch=1"
+S = "${WORKDIR}/kexec-tools-${PV}"
+
+EXTRA_OECONF = " --without-zlib"
+
+export CC=${TARGET_PREFIX}klcc
+
+# standart oe cflags don't work with klcc
+export CFLAGS=""
+export CPPFLAGS=""
+export LDFLAGS=""
+
+PACKAGES =+ "kexec-static kdump-static"
+
+FILES_kexec-static = "${sbindir}/kexec"
+FILES_kdump-static = "${sbindir}/kdump"
+
diff --git a/recipes/kexec/kexec-tools.inc b/recipes/kexec/kexec-tools.inc
new file mode 100644
index 0000000000..f806e71480
--- /dev/null
+++ b/recipes/kexec/kexec-tools.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Kexec is a fast reboot feature that lets you reboot to a new Linux kernel"
+AUTHOR = "Eric Biederman"
+HOMEPAGE = "http://www.xmission.com/~ebiederm/files/kexec/"
+SECTION = "kernel/userland"
+LICENSE = "GPL"
+DEPENDS = "virtual/kernel zlib"
+
+inherit autotools
+
+
+SRC_URI = "http://www.xmission.com/~ebiederm/files/kexec/kexec-tools-${PV}.tar.gz \
+ file://kexec-tools-arm.patch;patch=1 \
+ file://kexec-arm-atags.patch;patch=1"
diff --git a/recipes/kexec/kexec-tools_1.101.bb b/recipes/kexec/kexec-tools_1.101.bb
new file mode 100644
index 0000000000..f74c7bcd83
--- /dev/null
+++ b/recipes/kexec/kexec-tools_1.101.bb
@@ -0,0 +1,5 @@
+require kexec-tools.inc
+export LDFLAGS = "-L${STAGING_LIBDIR}"
+EXTRA_OECONF = " --with-zlib=yes"
+
+PR = "r5"