aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kexec
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-05-14 12:39:31 +0100
committerGraeme Gregory <dp@xora.org.uk>2009-05-14 12:39:31 +0100
commit8bef3a222f49e2d94d7545f440b0aba173e5d7ce (patch)
tree78c3e68f61a87c215b78aaefb8e04c37874f73fb /recipes/kexec
parent54d7edcaa7161cf273714c95e8b27fb682fba557 (diff)
downloadopenembedded-8bef3a222f49e2d94d7545f440b0aba173e5d7ce.tar.gz
kexec-tools-static_1.101.bb : fix compile on newer kernels based on work done
by Peter Chubb <peter.chubb@nicta.com.au>
Diffstat (limited to 'recipes/kexec')
-rw-r--r--recipes/kexec/files/kexec-arm-atags.patch15
-rw-r--r--recipes/kexec/kexec-tools-static_1.101.bb2
2 files changed, 8 insertions, 9 deletions
diff --git a/recipes/kexec/files/kexec-arm-atags.patch b/recipes/kexec/files/kexec-arm-atags.patch
index bf6f640035..eb3cb75990 100644
--- a/recipes/kexec/files/kexec-arm-atags.patch
+++ b/recipes/kexec/files/kexec-arm-atags.patch
@@ -4,9 +4,9 @@
Index: kexec-tools-1.101/kexec/arch/arm/kexec-zImage-arm.c
===================================================================
---- kexec-tools-1.101.orig/kexec/arch/arm/kexec-zImage-arm.c 2007-12-26 21:17:07.000000000 +0000
-+++ kexec-tools-1.101/kexec/arch/arm/kexec-zImage-arm.c 2007-12-27 01:24:25.000000000 +0000
-@@ -1,11 +1,83 @@
+--- kexec-tools-1.101.orig/kexec/arch/arm/kexec-zImage-arm.c
++++ kexec-tools-1.101/kexec/arch/arm/kexec-zImage-arm.c
+@@ -1,11 +1,82 @@
+/*
+ * - 08/21/2007 ATAG support added by Uli Luckas <u.luckas@road.de>
+ *
@@ -20,7 +20,6 @@ Index: kexec-tools-1.101/kexec/arch/arm/kexec-zImage-arm.c
+#include <stdint.h>
+#include <getopt.h>
+#include <arch/options.h>
-+#include <asm/page.h>
#include "../../kexec.h"
+#define COMMAND_LINE_SIZE 1024
@@ -90,7 +89,7 @@ Index: kexec-tools-1.101/kexec/arch/arm/kexec-zImage-arm.c
int zImage_arm_probe(const char *buf, off_t len)
{
/*
-@@ -14,21 +86,194 @@ int zImage_arm_probe(const char *buf, of
+@@ -14,21 +85,194 @@ int zImage_arm_probe(const char *buf, of
*/
return 0;
}
@@ -102,8 +101,7 @@ Index: kexec-tools-1.101/kexec/arch/arm/kexec-zImage-arm.c
+ " --initrd=FILE Use FILE as the kernel's initial ramdisk.\n"
+ " --ramdisk=FILE Use FILE as the kernel's initial ramdisk.\n"
+ );
- }
--int zImage_arm_load(int argc, char **argv, const char *buf, off_t len,
++}
+
+static
+struct tag * atag_read_tags(void)
@@ -210,7 +208,8 @@ Index: kexec-tools-1.101/kexec/arch/arm/kexec-zImage-arm.c
+ }
+
+ return 0;
-+}
+ }
+-int zImage_arm_load(int argc, char **argv, const char *buf, off_t len,
+
+int zImage_arm_load(int argc, char **argv, const char *buf, off_t len,
struct kexec_info *info)
diff --git a/recipes/kexec/kexec-tools-static_1.101.bb b/recipes/kexec/kexec-tools-static_1.101.bb
index 670f055506..ea44b57cf1 100644
--- a/recipes/kexec/kexec-tools-static_1.101.bb
+++ b/recipes/kexec/kexec-tools-static_1.101.bb
@@ -1,7 +1,7 @@
# the binaries are statical linked against klibc
require kexec-tools.inc
-PR = "r4"
+PR = "r5"
DEPENDS = "klibc"
SRC_URI += "file://kexec-klibc.patch;patch=1"