summaryrefslogtreecommitdiffstats
path: root/recipes/kexec
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-09-26 00:07:10 +0200
committerAndrea Adami <andrea.adami@gmail.com>2009-09-26 00:09:23 +0200
commit1c1c4a18003cc8cc830262502dd96f5e1304ca57 (patch)
tree980839fe3a9ca062b02e75517d0697c802c286b9 /recipes/kexec
parent90b241080260feb309bfa78947174b255076a440 (diff)
downloadopenembedded-1c1c4a18003cc8cc830262502dd96f5e1304ca57.tar.gz
kexec-tools_2.0.1: fix insane arch detection [arm], bump pref and PR
Diffstat (limited to 'recipes/kexec')
-rw-r--r--recipes/kexec/files/fix-arm-arch-detection.patch21
-rw-r--r--recipes/kexec/kexec-tools2.inc1
-rw-r--r--recipes/kexec/kexec-tools_2.0.1.bb4
3 files changed, 24 insertions, 2 deletions
diff --git a/recipes/kexec/files/fix-arm-arch-detection.patch b/recipes/kexec/files/fix-arm-arch-detection.patch
new file mode 100644
index 0000000000..a3676983b5
--- /dev/null
+++ b/recipes/kexec/files/fix-arm-arch-detection.patch
@@ -0,0 +1,21 @@
+--- kexec-tools/kexec/phys_arch.c.old 2008-07-15 02:46:43.000000000 +0200
++++ kexec-tools/kexec/phys_arch.c 2009-09-25 23:46:04.000000000 +0200
+@@ -13,9 +13,16 @@
+ return -1;
+ }
+
+- for (i = 0; arches[i].machine; ++i)
+- if (strcmp(utsname.machine, arches[i].machine) == 0)
++ for (i = 0; arches[i].machine; ++i) {
++
++ if ((arches[i].machine == "arm") && (strncmp(utsname.machine, arches[i].machine, 3) == 0)) {
++ return arches[i].arch;
++ }
++
++ if (strcmp(utsname.machine, arches[i].machine) == 0) {
+ return arches[i].arch;
++ }
++ }
+
+ fprintf(stderr, "Unsupported machine type: %s\n",
+ utsname.machine);
diff --git a/recipes/kexec/kexec-tools2.inc b/recipes/kexec/kexec-tools2.inc
index 261bfb9b3f..a4fe1b6c60 100644
--- a/recipes/kexec/kexec-tools2.inc
+++ b/recipes/kexec/kexec-tools2.inc
@@ -9,4 +9,5 @@ inherit autotools
SRC_URI = "http://www.kernel.org/pub/linux/kernel/people/horms/kexec-tools/kexec-tools-${PV}.tar.gz \
+ file://fix-arm-arch-detection.patch;patch=1 \
"
diff --git a/recipes/kexec/kexec-tools_2.0.1.bb b/recipes/kexec/kexec-tools_2.0.1.bb
index 7692081d24..f43ca60401 100644
--- a/recipes/kexec/kexec-tools_2.0.1.bb
+++ b/recipes/kexec/kexec-tools_2.0.1.bb
@@ -2,6 +2,6 @@ require kexec-tools2.inc
export LDFLAGS = "-L${STAGING_LIBDIR}"
EXTRA_OECONF = " --with-zlib=yes"
-PR = "r0"
+PR = "r1"
-DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE = "1"