summaryrefslogtreecommitdiffstats
path: root/recipes/kexec
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-10-04 22:12:14 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-10-04 22:12:53 +0200
commit1d4b26de0ac1d106420dfaadeb16f9acdc01f1b9 (patch)
tree41f55dd94319ac2514e2aa74799c34c46a4e2452 /recipes/kexec
parent7f7b1e65c6371f0c73ad89e58b9080c9bd18384e (diff)
downloadopenembedded-1d4b26de0ac1d106420dfaadeb16f9acdc01f1b9.tar.gz
kexec: add recipe for dietlibc
Diffstat (limited to 'recipes/kexec')
-rw-r--r--recipes/kexec/files/dietlibc.patch35
-rw-r--r--recipes/kexec/kexec-tools-dietlibc_2.0.1.bb17
2 files changed, 52 insertions, 0 deletions
diff --git a/recipes/kexec/files/dietlibc.patch b/recipes/kexec/files/dietlibc.patch
new file mode 100644
index 0000000000..0048d7a6a2
--- /dev/null
+++ b/recipes/kexec/files/dietlibc.patch
@@ -0,0 +1,35 @@
+Index: kexec-tools-2.0.1/kexec/kexec-elf.c
+===================================================================
+--- kexec-tools-2.0.1.orig/kexec/kexec-elf.c 2009-10-03 14:19:35.347504269 +0200
++++ kexec-tools-2.0.1/kexec/kexec-elf.c 2009-10-03 14:23:00.414497203 +0200
+@@ -9,6 +9,17 @@
+ #include "kexec.h"
+ #include "kexec-elf.h"
+
++#ifdef __dietlibc__
++#include <limits.h>
++# define UINT32_MAX (4294967295U)
++# if __WORDSIZE == 64
++# define __UINT64_C(c) c ## UL
++# else
++# define __UINT64_C(c) c ## ULL
++# endif
++# define UINT64_MAX (__UINT64_C(18446744073709551615))
++#endif
++
+ static const int probe_debug = 0;
+
+ uint16_t elf16_to_cpu(const struct mem_ehdr *ehdr, uint16_t value)
+Index: kexec-tools-2.0.1/kexec/Makefile
+===================================================================
+--- kexec-tools-2.0.1.orig/kexec/Makefile 2009-10-03 14:43:59.574859089 +0200
++++ kexec-tools-2.0.1/kexec/Makefile 2009-10-03 14:44:08.190707689 +0200
+@@ -70,7 +70,7 @@
+
+ $(KEXEC): $(KEXEC_OBJS) $(UTIL_LIB)
+ @$(MKDIR) -p $(@D)
+- $(LINK.o) -o $@ $^ $(LIBS)
++ $(LINK.o) -o $@ $^ $(LIBS) -lcompat
+
+ $(KEXEC): CPPFLAGS+=-I$(srcdir)/kexec/arch/$(ARCH)/include
+
diff --git a/recipes/kexec/kexec-tools-dietlibc_2.0.1.bb b/recipes/kexec/kexec-tools-dietlibc_2.0.1.bb
new file mode 100644
index 0000000000..0155e72793
--- /dev/null
+++ b/recipes/kexec/kexec-tools-dietlibc_2.0.1.bb
@@ -0,0 +1,17 @@
+# the binaries are statical linked against klibc
+require kexec-tools2.inc
+
+SRC_URI += "file://dietlibc.patch;patch=1"
+
+inherit dietlibc
+
+#DEFAULT_PREFERENCE = "-1"
+
+PR = "r0"
+
+S = "${WORKDIR}/kexec-tools-${PV}"
+
+PACKAGES =+ "kexec-dietlibc kdump-dietlibc"
+
+FILES_kexec-dietlibc = "${sbindir}/kexec"
+FILES_kdump-dietlibc = "${sbindir}/kdump"