aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kexecboot/kexecboot-cfg_0.1.bb
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-11-08 14:13:54 +0100
committerAndrea Adami <andrea.adami@gmail.com>2009-11-08 14:14:30 +0100
commit0d26edc49eb426f8f312ecca24bb905dae63991f (patch)
treeefc4903652b85befca72d358b792e318b2a47884 /recipes/kexecboot/kexecboot-cfg_0.1.bb
parenta9cc65b9c8e85ae61f22a05a8c2817c6abd2fce9 (diff)
downloadopenembedded-0d26edc49eb426f8f312ecca24bb905dae63991f.tar.gz
kexecboot-cfg: sync boot.cfg with upstream. Bump PR.
Diffstat (limited to 'recipes/kexecboot/kexecboot-cfg_0.1.bb')
-rw-r--r--recipes/kexecboot/kexecboot-cfg_0.1.bb30
1 files changed, 24 insertions, 6 deletions
diff --git a/recipes/kexecboot/kexecboot-cfg_0.1.bb b/recipes/kexecboot/kexecboot-cfg_0.1.bb
index f8172f442e..b867457e22 100644
--- a/recipes/kexecboot/kexecboot-cfg_0.1.bb
+++ b/recipes/kexecboot/kexecboot-cfg_0.1.bb
@@ -2,7 +2,7 @@ LICENSE = "GPL"
SECTION = "base"
DESCRIPTION = "Configuration file for kexecboot"
-PR = "r6"
+PR = "r7"
PACKAGE_ARCH = "${MACHINE_ARCH}"
SRC_URI = "file://icon.xpm"
@@ -36,15 +36,33 @@ do_configure_prepend () {
}
do_install_prepend () {
- echo "DEFAULT=${DISTRO}" > ${S}/boot.cfg
+
+ echo "# Show this label in kexecboot menu." >> ${S}/boot.cfg
echo "LABEL=${DISTRO}" >> ${S}/boot.cfg
+ echo "#" >> ${S}/boot.cfg
+
+ echo "# Specify full path to the kernel." >> ${S}/boot.cfg
echo "KERNEL=/boot/${KERNEL_IMAGETYPE}" >> ${S}/boot.cfg
+ echo "#" >> ${S}/boot.cfg
+
+ echo "# Append this tags to the kernel cmdline." >> ${S}/boot.cfg
echo "APPEND=${CMDLINE}" >> ${S}/boot.cfg
- echo "ICON=/boot/icon.xpm" >> ${S}/boot.cfg
+ echo "#" >> ${S}/boot.cfg
+
+ echo "# Specify full path for a custom distro-icon for the menu-item." >> ${S}/boot.cfg
+ echo "# If not set, use device-icons as default (NAND, SD, CF, ...)." >> ${S}/boot.cfg
+ echo "#ICON=/boot/icon.xpm" >> ${S}/boot.cfg
+ echo "#" >> ${S}/boot.cfg
+
+ echo "# Priority of item in kexecboot menu." >> ${S}/boot.cfg
+ echo "# Items with highest priority will be shown at top of menu." >> ${S}/boot.cfg
+ echo "# Default: 0 (lowest, ordered by device ordering)" >> ${S}/boot.cfg
+ echo "#PRIORITY=10" >> ${S}/boot.cfg
+ echo "#" >> ${S}/boot.cfg
}
do_install () {
- install -d ${D}/boot
- install -m 0644 boot.cfg ${D}/boot/boot.cfg
- install -m 0644 icon.xpm ${D}/boot/icon.xpm
+ install -d ${D}/boot
+ install -m 0644 boot.cfg ${D}/boot/boot.cfg
+ install -m 0644 icon.xpm ${D}/boot/icon.xpm
}