summaryrefslogtreecommitdiffstats
path: root/recipes/kexecboot/kexecboot-cfg_0.1.bb
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-11-08 01:18:09 +0100
committerAndrea Adami <andrea.adami@gmail.com>2009-11-08 01:18:09 +0100
commita719f3a73b2128ae28e13d1911256f883777af8c (patch)
treec13a8a6aba05e3ac06e03b7515742a4ae793aa5e /recipes/kexecboot/kexecboot-cfg_0.1.bb
parent563f8e80ff8f0f4a904487cfa14221eb5e4c842f (diff)
downloadopenembedded-a719f3a73b2128ae28e13d1911256f883777af8c.tar.gz
kexecboot-cfg: Deploy default icon. Bump PR.
Diffstat (limited to 'recipes/kexecboot/kexecboot-cfg_0.1.bb')
-rw-r--r--recipes/kexecboot/kexecboot-cfg_0.1.bb14
1 files changed, 9 insertions, 5 deletions
diff --git a/recipes/kexecboot/kexecboot-cfg_0.1.bb b/recipes/kexecboot/kexecboot-cfg_0.1.bb
index 97407a8a0a..f8172f442e 100644
--- a/recipes/kexecboot/kexecboot-cfg_0.1.bb
+++ b/recipes/kexecboot/kexecboot-cfg_0.1.bb
@@ -2,9 +2,11 @@ LICENSE = "GPL"
SECTION = "base"
DESCRIPTION = "Configuration file for kexecboot"
-PR = "r5"
+PR = "r6"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+SRC_URI = "file://icon.xpm"
+
CMDLINE_CON = "console=ttyS0,115200n8 console=tty1 noinitrd"
CMDLINE_CON_collie = "console=ttySA0,115200n8 console=tty1 noinitrd rw"
CMDLINE_CON_qemuarm = "console=ttyAMA0,115200n8 console=tty1 noinitrd"
@@ -29,18 +31,20 @@ CMDLINE += ${CMDLINE_DEBUG}
FILES_${PN} += "/boot/*"
+do_configure_prepend () {
+ install -m 0644 ${WORKDIR}/icon.xpm ${S}
+}
+
do_install_prepend () {
echo "DEFAULT=${DISTRO}" > ${S}/boot.cfg
echo "LABEL=${DISTRO}" >> ${S}/boot.cfg
echo "KERNEL=/boot/${KERNEL_IMAGETYPE}" >> ${S}/boot.cfg
echo "APPEND=${CMDLINE}" >> ${S}/boot.cfg
- echo "#ICON=/boot/my_icon.xpm" >> ${S}/boot.cfg
+ echo "ICON=/boot/icon.xpm" >> ${S}/boot.cfg
}
do_install () {
install -d ${D}/boot
install -m 0644 boot.cfg ${D}/boot/boot.cfg
-
- # old kexecboot versions < 0.52 were needing '/boot/kernel-cmdline'
- # echo "${CMDLINE}"> ${D}/boot/kernel-cmdline
+ install -m 0644 icon.xpm ${D}/boot/icon.xpm
}