aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kexecboot
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-02-16 09:25:08 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-02-16 09:43:48 +0100
commitbf450860bffd29c9cddd365d466dcf3eebce13eb (patch)
tree32126026f62cf07113429053cf9511519b6bbf7e /recipes/kexecboot
parent8179a444c0e403942b33f93d352a729ab2a3dabe (diff)
downloadopenembedded-bf450860bffd29c9cddd365d466dcf3eebce13eb.tar.gz
linux-kexecboot: use INC_PR for kernels, PR should get bump with every kexecboot change
* Andrea Adami wants only one INC_PR shared between kexecboot and linux-kexecboot recipes, maybe we could use sth like INC_PR = "${KEXECBOOT_PR}.19" in linux-kexecboot.inc and set KEXECBOOT_PR in some new .inc file * For now use INC_PR only for linux-kexecboot Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/kexecboot')
-rw-r--r--recipes/kexecboot/linux-kexecboot.inc4
-rw-r--r--recipes/kexecboot/linux-kexecboot_2.6.21-hh20.bb2
-rw-r--r--recipes/kexecboot/linux-kexecboot_2.6.24.bb2
-rw-r--r--recipes/kexecboot/linux-kexecboot_2.6.26.bb2
-rw-r--r--recipes/kexecboot/linux-kexecboot_2.6.29.bb2
-rw-r--r--recipes/kexecboot/linux-kexecboot_2.6.32+2.6.33-rc8_git.bb2
-rw-r--r--recipes/kexecboot/linux-kexecboot_2.6.32.bb2
7 files changed, 14 insertions, 2 deletions
diff --git a/recipes/kexecboot/linux-kexecboot.inc b/recipes/kexecboot/linux-kexecboot.inc
index a241be8751..ed3a07f4f9 100644
--- a/recipes/kexecboot/linux-kexecboot.inc
+++ b/recipes/kexecboot/linux-kexecboot.inc
@@ -1,5 +1,5 @@
-# We set PR here, since a change in the kexecboot recipe will need to get picked up by *all* the kernels:
-PR = "r18"
+# We set INC_PR here, since a change in the kexecboot recipe will need to get picked up by *all* the kernels:
+INC_PR = "r19"
LOGO_SIZE = '${@base_conditional("GUI_MACHINE_CLASS", "bigscreen", "vga", "qvga", d)}'
SRC_URI = "file://${LOGO_SIZE}/logo_linux_clut224.ppm.bz2"
diff --git a/recipes/kexecboot/linux-kexecboot_2.6.21-hh20.bb b/recipes/kexecboot/linux-kexecboot_2.6.21-hh20.bb
index 7667037037..01e7f1c66a 100644
--- a/recipes/kexecboot/linux-kexecboot_2.6.21-hh20.bb
+++ b/recipes/kexecboot/linux-kexecboot_2.6.21-hh20.bb
@@ -1,5 +1,7 @@
require linux-kexecboot.inc
+PR = "${INC_PR}.0"
+
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_hx4700 = "1"
DEFAULT_PREFERENCE_h2200 = "1"
diff --git a/recipes/kexecboot/linux-kexecboot_2.6.24.bb b/recipes/kexecboot/linux-kexecboot_2.6.24.bb
index e950ab0abf..07efd57ef8 100644
--- a/recipes/kexecboot/linux-kexecboot_2.6.24.bb
+++ b/recipes/kexecboot/linux-kexecboot_2.6.24.bb
@@ -1,5 +1,7 @@
require linux-kexecboot.inc
+PR = "${INC_PR}.0"
+
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_collie = "-1"
DEFAULT_PREFERENCE_poodle = "1"
diff --git a/recipes/kexecboot/linux-kexecboot_2.6.26.bb b/recipes/kexecboot/linux-kexecboot_2.6.26.bb
index 345d2ac764..9dfa8c0bb8 100644
--- a/recipes/kexecboot/linux-kexecboot_2.6.26.bb
+++ b/recipes/kexecboot/linux-kexecboot_2.6.26.bb
@@ -1,5 +1,7 @@
require linux-kexecboot.inc
+PR = "${INC_PR}.0"
+
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_qemuarm = "-1"
DEFAULT_PREFERENCE_qemux86 = "-1"
diff --git a/recipes/kexecboot/linux-kexecboot_2.6.29.bb b/recipes/kexecboot/linux-kexecboot_2.6.29.bb
index 4064c98582..b840f17eb7 100644
--- a/recipes/kexecboot/linux-kexecboot_2.6.29.bb
+++ b/recipes/kexecboot/linux-kexecboot_2.6.29.bb
@@ -1,5 +1,7 @@
require linux-kexecboot.inc
+PR = "${INC_PR}.0"
+
COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|omap3evm|omap3-pandora|overo|omapzoom"
SRCREV = "58cf2f1425abfd3a449f9fe985e48be2d2555022"
diff --git a/recipes/kexecboot/linux-kexecboot_2.6.32+2.6.33-rc8_git.bb b/recipes/kexecboot/linux-kexecboot_2.6.32+2.6.33-rc8_git.bb
index 216bf6479a..8ead75a691 100644
--- a/recipes/kexecboot/linux-kexecboot_2.6.32+2.6.33-rc8_git.bb
+++ b/recipes/kexecboot/linux-kexecboot_2.6.32+2.6.33-rc8_git.bb
@@ -1,5 +1,7 @@
require linux-kexecboot.inc
+PR = "${INC_PR}.0"
+
KERNEL_RELEASE = "2.6.33-rc8"
OLD_KERNEL_RELEASE = "2.6.32"
PV = "${OLD_KERNEL_RELEASE}+${KERNEL_RELEASE}"
diff --git a/recipes/kexecboot/linux-kexecboot_2.6.32.bb b/recipes/kexecboot/linux-kexecboot_2.6.32.bb
index ccb8cd642f..1851fa8bc3 100644
--- a/recipes/kexecboot/linux-kexecboot_2.6.32.bb
+++ b/recipes/kexecboot/linux-kexecboot_2.6.32.bb
@@ -1,5 +1,7 @@
require linux-kexecboot.inc
+PR = "${INC_PR}.0"
+
S = "${WORKDIR}/linux-${PV}"
S_omap3 = "${WORKDIR}/git"