summaryrefslogtreecommitdiffstats
path: root/recipes/kexecboot
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-04-12 10:39:50 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-04-12 20:16:13 +0200
commit16f464bd8cff6b6a27d9bfe691f7adc875d01ac2 (patch)
treed235ad1dba36225ca211cc7c606ecaab4ff883c5 /recipes/kexecboot
parent44985d56bc556786812a0a02d6219afd31a7381d (diff)
downloadopenembedded-16f464bd8cff6b6a27d9bfe691f7adc875d01ac2.tar.gz
recipes: move checksums to recipes from checksums.ini, part 2 manual adjustement
* all: multiple checked items in SRC_URI (needs name= param) * other fixes like non-existent URL, checksums moved ot .inc or included .bb (ie for -native) * ... * tested with micro/micro-uclibc/Angstrom/SHR with SOURCE_MIRROR_FETCH="True" (ignoring COMPATIBLE_* * also tested -c fetch with s/SRC_URI_append_[^ ]*/SRC_URI_append/g and s/SRC_URI_[^ ]*/SRC_URI_append/g to catch all URLs used only for distro/machine/virtual override (see http://build.shr-project.org/tests/jama/SRC_URI.removeOverrides.patch) * in case I downloaded different checksum then what was in checksums.ini I used the old one from checksums.ini and put my checksum in comment * I'll send to ML list of recipes which cannot be downloaded (weren't converted) and where I got different checksums Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/kexecboot')
-rw-r--r--recipes/kexecboot/linux-kexecboot_2.6.21-hh20.bb7
-rw-r--r--recipes/kexecboot/linux-kexecboot_2.6.24.bb165
-rw-r--r--recipes/kexecboot/linux-kexecboot_2.6.26.bb97
3 files changed, 87 insertions, 182 deletions
diff --git a/recipes/kexecboot/linux-kexecboot_2.6.21-hh20.bb b/recipes/kexecboot/linux-kexecboot_2.6.21-hh20.bb
index 88923988a5..a81865fe20 100644
--- a/recipes/kexecboot/linux-kexecboot_2.6.21-hh20.bb
+++ b/recipes/kexecboot/linux-kexecboot_2.6.21-hh20.bb
@@ -8,7 +8,7 @@ DEFAULT_PREFERENCE_h2200 = "1"
SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
file://linux-2.6.git-9d20fdd58e74d4d26dc5216efaaa0f800c23dd3a.patch;patch=1 \
- http://www.rpsys.net/openzaurus/patches/archive/export_atags-r0a.patch;patch=1 \
+ http://www.rpsys.net/openzaurus/patches/archive/export_atags-r0a.patch;patch=1;name=rppatch35 \
file://gcc4x-limits.patch;patch=1 \
file://defconfig"
@@ -24,5 +24,6 @@ do_configure_append() {
-SRC_URI[md5sum] = "8ab51e8ff728f4155db64b9bb6ea6d71"
-SRC_URI[sha256sum] = "75d4c6ddbfc5e4fff7690a3308e2574f89a0e2709fb91caccb29067a9dad251a"
+# ${RPSRC}/export_atags-r0a.patch;patch=1;status=pending;name=rppatch35 \
+SRC_URI[rppatch35.md5sum] = "8ab51e8ff728f4155db64b9bb6ea6d71"
+SRC_URI[rppatch35.sha256sum] = "75d4c6ddbfc5e4fff7690a3308e2574f89a0e2709fb91caccb29067a9dad251a"
diff --git a/recipes/kexecboot/linux-kexecboot_2.6.24.bb b/recipes/kexecboot/linux-kexecboot_2.6.24.bb
index 75b4994cb5..6612286605 100644
--- a/recipes/kexecboot/linux-kexecboot_2.6.24.bb
+++ b/recipes/kexecboot/linux-kexecboot_2.6.24.bb
@@ -1,4 +1,5 @@
require linux-kexecboot.inc
+require ../linux/linux-rp.checksums.inc
PR = "${INC_PR}.0"
@@ -22,33 +23,33 @@ DEFAULT_PREFERENCE_spitz = "1"
# Patches submitted upstream are towards top of this list
# Hacks should clearly named and at the bottom
-SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
- file://0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch;patch=1 \
- ${RPSRC}/export_atags-r2.patch;patch=1;status=pending \
- ${RPSRC}/lzo_crypto-r2.patch;patch=1;status=pending \
- ${RPSRC}/corgi_rearrange_lcd-r0.patch;patch=1;status=pending \
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2;name=kernel \
+ file://0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch;patch=1 \
+ ${RPSRC}/export_atags-r2.patch;patch=1;status=pending;name=rppatch54 \
+ ${RPSRC}/lzo_crypto-r2.patch;patch=1;status=pending;name=rppatch36 \
+ ${RPSRC}/corgi_rearrange_lcd-r0.patch;patch=1;status=pending;name=rppatch55 \
file://hrw-hostapcard.patch;patch=1;status=pending \
- ${RPSRC}/allow_disable_deferrred-r0.patch;patch=1 \
- ${RPSRC}/lzo_jffs2_sysfs-r1.patch;patch=1 \
- ${RPSRC}/hx2750_base-r33.patch;patch=1 \
- ${RPSRC}/hx2750_bl-r9.patch;patch=1 \
- ${RPSRC}/hx2750_pcmcia-r3.patch;patch=1 \
- ${RPSRC}/pxa_keys-r8.patch;patch=1 \
- ${RPSRC}/tsc2101-r18.patch;patch=1 \
- ${RPSRC}/hx2750_test1-r8.patch;patch=1 \
- ${RPSRC}/input_power-r10.patch;patch=1 \
- ${RPSRC}/pxa25x_cpufreq-r2.patch;patch=1 \
- ${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1 \
- ${RPSRC}/pm_changes-r1.patch;patch=1 \
- ${RPSRC}/usb_add_epalloc-r4.patch;patch=1 \
- ${RPSRC}/usb_pxa27x_udc-r8.patch;patch=1 \
- ${RPSRC}/locomo_kbd_tweak-r1a.patch;patch=1 \
- ${RPSRC}/pxa27x_overlay-r8.patch;patch=1 \
- ${RPSRC}/w100_extaccel-r2.patch;patch=1 \
- ${RPSRC}/w100_extmem-r1.patch;patch=1 \
- ${RPSRC}/poodle_pm-r5.patch;patch=1 \
- ${RPSRC}/poodle_lcd_hack-r0.patch;patch=1 \
- ${RPSRC}/poodle_asoc_fix-r1.patch;patch=1 \
+ ${RPSRC}/allow_disable_deferrred-r0.patch;patch=1;name=rppatch56 \
+ ${RPSRC}/lzo_jffs2_sysfs-r1.patch;patch=1;name=rppatch1 \
+ ${RPSRC}/hx2750_base-r33.patch;patch=1;name=rppatch57 \
+ ${RPSRC}/hx2750_bl-r9.patch;patch=1;name=rppatch3 \
+ ${RPSRC}/hx2750_pcmcia-r3.patch;patch=1;name=rppatch4 \
+ ${RPSRC}/pxa_keys-r8.patch;patch=1;name=rppatch58 \
+ ${RPSRC}/tsc2101-r18.patch;patch=1;name=rppatch59 \
+ ${RPSRC}/hx2750_test1-r8.patch;patch=1;name=rppatch7 \
+ ${RPSRC}/input_power-r10.patch;patch=1;name=rppatch60 \
+ ${RPSRC}/pxa25x_cpufreq-r2.patch;patch=1;name=rppatch44 \
+ ${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1;name=rppatch8 \
+ ${RPSRC}/pm_changes-r1.patch;patch=1;name=rppatch9 \
+ ${RPSRC}/usb_add_epalloc-r4.patch;patch=1;name=rppatch61 \
+ ${RPSRC}/usb_pxa27x_udc-r8.patch;patch=1;name=rppatch62 \
+ ${RPSRC}/locomo_kbd_tweak-r1a.patch;patch=1;name=rppatch63 \
+ ${RPSRC}/pxa27x_overlay-r8.patch;patch=1;name=rppatch11 \
+ ${RPSRC}/w100_extaccel-r2.patch;patch=1;name=rppatch12 \
+ ${RPSRC}/w100_extmem-r1.patch;patch=1;name=rppatch13 \
+ ${RPSRC}/poodle_pm-r5.patch;patch=1;name=rppatch64 \
+ ${RPSRC}/poodle_lcd_hack-r0.patch;patch=1;name=rppatch15 \
+ ${RPSRC}/poodle_asoc_fix-r1.patch;patch=1;name=rppatch16 \
file://pxa27x-resume.patch;patch=1;status=external \
file://mtd-module.patch;patch=1;status=external \
file://wm8750-treble.patch;patch=1;status=external \
@@ -57,14 +58,14 @@ SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
file://sharpsl-rc-r1.patch;patch=1 \
file://sharpsl-rc-r2.patch;patch=1 \
file://squashfs3.3.patch;patch=1;status=external \
-# ${RPSRC}/logo_oh-r1.patch.bz2;patch=1;status=unmergable \
- ${RPSRC}/pxa-linking-bug.patch;patch=1;status=unmergable \
+# ${RPSRC}/logo_oh-r1.patch.bz2;patch=1;status=unmergable;name=rppatch17 \
+ ${RPSRC}/pxa-linking-bug.patch;patch=1;status=unmergable;name=rppatch18 \
file://hostap-monitor-mode.patch;patch=1;status=unmergable \
file://serial-add-support-for-non-standard-xtals-to-16c950-driver.patch;patch=1;status=unmergable \
- ${RPSRC}/mmcsd_large_cards-r1.patch;patch=1;status=hack \
- ${RPSRC}/mmcsd_no_scr_check-r2.patch;patch=1;status=hack \
- ${RPSRC}/integrator_rgb-r1.patch;patch=1;status=hack \
- ${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1;status=hack \
+ ${RPSRC}/mmcsd_large_cards-r1.patch;patch=1;status=hack;name=rppatch19 \
+ ${RPSRC}/mmcsd_no_scr_check-r2.patch;patch=1;status=hack;name=rppatch20 \
+ ${RPSRC}/integrator_rgb-r1.patch;patch=1;status=hack;name=rppatch21 \
+ ${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1;status=hack;name=rppatch22 \
file://pxa-serial-hack.patch;patch=1;status=hack \
file://connectplus-remove-ide-HACK.patch;patch=1;status=hack \
file://connectplus-prevent-oops-HACK.patch;patch=1;status=hack \
@@ -74,36 +75,36 @@ SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
file://defconfig"
# FIXMEs before made default
-# ${RPSRC}/mmcsd_no_scr_check-r1.patch;patch=1;status=hack
+# ${RPSRC}/mmcsd_no_scr_check-r1.patch;patch=1;status=hack;name=rppatch50
# Add this to enable pm debug code (useful with a serial lead)
-# ${RPSRC}/sharpsl_pm_debug-r0.patch;patch=1
+# ${RPSRC}/sharpsl_pm_debug-r0.patch;patch=1;name=rppatch51
# Disabled until I find the reason this gives issues with cdc_subset
-# ${RPSRC}/usb_rndis_tweaks-r0.patch;patch=1 \
+# ${RPSRC}/usb_rndis_tweaks-r0.patch;patch=1;name=rppatch52 \
SRC_URI_append_collie = "\
- ${TKSRC}/mtd-sharp-flash-hack-r4.patch;patch=1 \
- ${TKSRC}/mcp-sa11x0-r0.patch;patch=1 \
- ${TKSRC}/locomo-r1.patch;patch=1 \
- ${TKSRC}/collie-kexec-r1.patch;patch=1 \
- ${TKSRC}/sharpsl_pm-4.patch;patch=1 \
- ${TKSRC}/collie_pm-3.patch;patch=1 \
- ${TKSRC}/ucb1x00_suspend.patch;patch=1 \
- ${TKSRC}/collie-ts.patch;patch=1 \
- ${TKSRC}/pcmcia_suspend.patch;patch=1 \
- ${TKSRC}/locomo_spi-6.patch;patch=1 \
- ${TKSRC}/config.patch;patch=1 \
- ${TKSRC}/mmc-spi.patch;patch=1 \
- ${TKSRC}/linux-2.6.24-SIMpad-rtc-sa1100.patch;patch=1 \
- ${TKSRC}/sa1100_spinlock.patch;patch=1 \
- ${TKSRC}/sa1100-dma.patch;patch=1 \
+ ${TKSRC}/mtd-sharp-flash-hack-r4.patch;patch=1;name=tkpatch1 \
+ ${TKSRC}/mcp-sa11x0-r0.patch;patch=1;name=tkpatch2 \
+ ${TKSRC}/locomo-r1.patch;patch=1;name=tkpatch3 \
+ ${TKSRC}/collie-kexec-r1.patch;patch=1;name=tkpatch4 \
+ ${TKSRC}/sharpsl_pm-4.patch;patch=1;name=tkpatch5 \
+ ${TKSRC}/collie_pm-3.patch;patch=1;name=tkpatch6 \
+ ${TKSRC}/ucb1x00_suspend.patch;patch=1;name=tkpatch7 \
+ ${TKSRC}/collie-ts.patch;patch=1;name=tkpatch8 \
+ ${TKSRC}/pcmcia_suspend.patch;patch=1;name=tkpatch9 \
+ ${TKSRC}/locomo_spi-6.patch;patch=1;name=tkpatch10 \
+ ${TKSRC}/config.patch;patch=1;name=tkpatch11 \
+ ${TKSRC}/mmc-spi.patch;patch=1;name=tkpatch12 \
+ ${TKSRC}/linux-2.6.24-SIMpad-rtc-sa1100.patch;patch=1;name=tkpatch13 \
+ ${TKSRC}/sa1100_spinlock.patch;patch=1;name=tkpatch14 \
+ ${TKSRC}/sa1100-dma.patch;patch=1;name=tkpatch15 \
"
SRC_URI_append_poodle = "\
- ${RPSRC}/poodle_serial_vcc-r0.patch;patch=1 \
+ ${RPSRC}/poodle_serial_vcc-r0.patch;patch=1;name=rppatch53 \
file://poodle_ts.patch;patch=1 \
file://pxafb.patch;patch=1 \
"
@@ -193,63 +194,5 @@ SRC_URI_append_zylonite ="\
S = "${WORKDIR}/linux-2.6.24"
-SRC_URI[md5sum] = "3f23ad4b69d0a552042d1ed0f4399857"
-SRC_URI[sha256sum] = "413c64fbbcf81244cb5571be4963644a1e81166a2b0f008a016528363b65c5d3"
-SRC_URI[md5sum] = "987956757c3707ba0e62ce2cd133011b"
-SRC_URI[sha256sum] = "7754930742d3c3cc2a05af38263ba58ba416b7359f8a0c598ae0f7377277d3b3"
-SRC_URI[md5sum] = "29162001c88d9dbe0ccb25103a1aefb4"
-SRC_URI[sha256sum] = "0b68f2d73dc54404d29015455ba84021a925aa2cfb6f1fe75705fe2268b2e2e8"
-SRC_URI[md5sum] = "c1bec44c92f5da5abad97137c73b1365"
-SRC_URI[sha256sum] = "d4dc8f0583e616e74ea41b103d5f6a29b6d079ce37eaf9f362825514c7082490"
-SRC_URI[md5sum] = "1cc6aee6d128edf41775472764652435"
-SRC_URI[sha256sum] = "02657350458e7d82b8c926e1f027e408e1e2e8d9570f31e7b5f84472fe2e41c2"
-SRC_URI[md5sum] = "a8b75ef4190dfc0afcfa8789d3e4c64c"
-SRC_URI[sha256sum] = "3fed945b590db46a902fa434054b967dd1bf4af1ee5f5643e00d1d66a9d69543"
-SRC_URI[md5sum] = "e9ef4b8b78ab64cd7dbd0d41b05e932c"
-SRC_URI[sha256sum] = "ed4f25e0da55714c618c2721209a2d22a7296b5dc85af028d20aff6062a4a13b"
-SRC_URI[md5sum] = "ebb78f58e9c84c73b90e9cbdde5f89d6"
-SRC_URI[sha256sum] = "7578448fc2adbfc820158b2467dbb127ab012b3a97ad95366d8d1af002defbce"
-SRC_URI[md5sum] = "896d3e29ab5715b7558b972fba626425"
-SRC_URI[sha256sum] = "29f21117a17f945783f2eee5d5c89e10959fed44ac423ad9809d6afc0db5996c"
-SRC_URI[md5sum] = "4f41fd3a0e031a26d3a2d354f5995ffd"
-SRC_URI[sha256sum] = "3959a45bb65f66a622d7752e41808604032f4ab66f736f96fee83e252d85df5a"
-SRC_URI[md5sum] = "95e9a5dfc1852e2db3d1d9da6df439df"
-SRC_URI[sha256sum] = "83097559d413b57aa67da1de975e8fbb99d02a2b2166aad57d7b30881208ff1e"
-SRC_URI[md5sum] = "33eed5a26b2776508500532c07956dc4"
-SRC_URI[sha256sum] = "a93c7f0caa8e212a4515ce209918e250e80d2643317732d707d4f25649457545"
-SRC_URI[md5sum] = "6ddb822c5ee92a58b667795b41f31963"
-SRC_URI[sha256sum] = "d42ec6f70b00100aa8816740259e3d70686aeae8c05a4f76b67f76b84c79833c"
-SRC_URI[md5sum] = "c076ac1f2368d9e8399e64a3adf3a036"
-SRC_URI[sha256sum] = "34358aa53caaf393af550d9771f02f144eafabb7518e84d872427dc297e493b4"
-SRC_URI[md5sum] = "aeea5a2614fd8f9ae7d729d1ea1dddba"
-SRC_URI[sha256sum] = "1bd129c7a68537533c77267992eaf490ff64bcc3d01c6f4b51343b8f266ae99e"
-SRC_URI[md5sum] = "e10058b52841d138630b69b954bea0b9"
-SRC_URI[sha256sum] = "779561c658ccb190f3a2cd7626e4a229834c5f9b093be8f7a06bbfaf12121b9c"
-SRC_URI[md5sum] = "042c5243ce0253341fe920a8a863e37b"
-SRC_URI[sha256sum] = "6d2ae5d70609df7d2c2b518eca0624c4a59328b277ed114b9e5b57dd030e6e94"
-SRC_URI[md5sum] = "d4bbe2b9ef6b5879d72875896632d8b3"
-SRC_URI[sha256sum] = "c4bf829816c3e53b0807bb12cfdc8b1f0e0c1eae14a5be2ffb1a59ad71bbb188"
-SRC_URI[md5sum] = "f126bdd73fa79a770b8c0caa95c5bae8"
-SRC_URI[sha256sum] = "a80748d7438ffa589eaee6d4870c74cebc90cc5c8134d070c8f4090fe9bab58c"
-SRC_URI[md5sum] = "94926c8dbea9035ca9e5b44d9dd68726"
-SRC_URI[sha256sum] = "8848bf269257316e845857d58023fec82e7e2ff5a8092915ec4a8b033429a5cc"
-SRC_URI[md5sum] = "2c958056e0a82da4d85810ea51b9e07b"
-SRC_URI[sha256sum] = "c8e0cf191fb60b26eb5481c24d162c3675c72bc940c42393af2f0b62897de90f"
-SRC_URI[md5sum] = "a17be90788c4ccd6ee8253659b9321f8"
-SRC_URI[sha256sum] = "56dfd5365848095793faa31ee1cf753c10891dd076944d3533b05c6547965134"
-SRC_URI[md5sum] = "3ed63ce3884d6cdd71b6d471e3c49407"
-SRC_URI[sha256sum] = "e87d44d5a77c591db83598295109c033708a458797247a31cfa20d54c52d7b41"
-SRC_URI[md5sum] = "05766128b2b0abdd01048e5e08430600"
-SRC_URI[sha256sum] = "5fcd54adf3c8e7e99078a585683926224b5b49a99e4e675694621c3e08e6aad0"
-SRC_URI[md5sum] = "7c766563674dec668baa5f650a14b7cd"
-SRC_URI[sha256sum] = "3f78e714248cdaa0b83f530a3b7f80da02446b179e86fbb043d57c3e05ae0d7e"
-SRC_URI[md5sum] = "ce6d8a7a25cc1c9593417746bcf84ca0"
-SRC_URI[sha256sum] = "24aac1d158095007a10a47e38320a1618fab2d536f19caff94f4dd0ab29f306b"
-SRC_URI[md5sum] = "9b69a1f5951ebd26d5b29ac326c5c414"
-SRC_URI[sha256sum] = "8de4e1a8696c2f47ed1b9009498b4f89ba9dd3fbda6083531ef40c35ce001996"
-SRC_URI[md5sum] = "b60a6035a3e84ba68771fef999ccc96f"
-SRC_URI[sha256sum] = "fe3dcba12eab368a5c14e6c247886bcbaa3fafc662ea8de00fd579f956a21a71"
-SRC_URI[md5sum] = "15a09026135382c716a11633344ba3c4"
-SRC_URI[sha256sum] = "49521feb1a6e2bc9b355e93b3251e3c74ebe2327eb89c6e681347464e81e3664"
-SRC_URI[md5sum] = "b67218e773a236631b41a1718049bbc7"
-SRC_URI[sha256sum] = "f6ddc6636b2a8e4392dab43fdcfd9521e2d7f9022e56c39ecee66d50a94bdc98"
+SRC_URI[kernel.md5sum] = "3f23ad4b69d0a552042d1ed0f4399857"
+SRC_URI[kernel.sha256sum] = "413c64fbbcf81244cb5571be4963644a1e81166a2b0f008a016528363b65c5d3"
diff --git a/recipes/kexecboot/linux-kexecboot_2.6.26.bb b/recipes/kexecboot/linux-kexecboot_2.6.26.bb
index db78d7a4a4..ff0ef14190 100644
--- a/recipes/kexecboot/linux-kexecboot_2.6.26.bb
+++ b/recipes/kexecboot/linux-kexecboot_2.6.26.bb
@@ -1,4 +1,5 @@
require linux-kexecboot.inc
+require ../linux/linux-rp.checksums.inc
PR = "${INC_PR}.0"
@@ -21,32 +22,32 @@ DEFAULT_PREFERENCE_akita = "1"
# Patches submitted upstream are towards top of this list
# Hacks should clearly named and at the bottom
-SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.26.tar.bz2 \
- ${RPSRC}/lzo_jffs2_sysfs-r1.patch;patch=1 \
- ${RPSRC}/hx2750_base-r34.patch;patch=1 \
- ${RPSRC}/hx2750_bl-r9.patch;patch=1 \
- ${RPSRC}/hx2750_pcmcia-r3.patch;patch=1 \
- ${RPSRC}/pxa_keys-r9.patch;patch=1 \
- ${RPSRC}/tsc2101-r19.patch;patch=1 \
- ${RPSRC}/hx2750_test1-r8.patch;patch=1 \
- ${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1 \
- ${RPSRC}/pm_changes-r1.patch;patch=1 \
- ${RPSRC}/locomo_kbd_tweak-r2.patch;patch=1 \
-# ${RPSRC}/pxa27x_overlay-r8.patch;patch=1 \
- ${RPSRC}/w100_extaccel-r2.patch;patch=1 \
- ${RPSRC}/w100_extmem-r1.patch;patch=1 \
- ${RPSRC}/poodle_pm-r6.patch;patch=1 \
- ${RPSRC}/poodle_lcd_hack-r0.patch;patch=1 \
- ${RPSRC}/poodle_asoc_fix-r1.patch;patch=1 \
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.26.tar.bz2;name=kernel \
+ ${RPSRC}/lzo_jffs2_sysfs-r1.patch;patch=1;name=rppatch1 \
+ ${RPSRC}/hx2750_base-r34.patch;patch=1;name=rppatch2 \
+ ${RPSRC}/hx2750_bl-r9.patch;patch=1;name=rppatch3 \
+ ${RPSRC}/hx2750_pcmcia-r3.patch;patch=1;name=rppatch4 \
+ ${RPSRC}/pxa_keys-r9.patch;patch=1;name=rppatch5 \
+ ${RPSRC}/tsc2101-r19.patch;patch=1;name=rppatch6 \
+ ${RPSRC}/hx2750_test1-r8.patch;patch=1;name=rppatch7 \
+ ${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1;name=rppatch8 \
+ ${RPSRC}/pm_changes-r1.patch;patch=1;name=rppatch9 \
+ ${RPSRC}/locomo_kbd_tweak-r2.patch;patch=1;name=rppatch10 \
+# ${RPSRC}/pxa27x_overlay-r8.patch;patch=1;name=rppatch11 \
+ ${RPSRC}/w100_extaccel-r2.patch;patch=1;name=rppatch12 \
+ ${RPSRC}/w100_extmem-r1.patch;patch=1;name=rppatch13 \
+ ${RPSRC}/poodle_pm-r6.patch;patch=1;name=rppatch14 \
+ ${RPSRC}/poodle_lcd_hack-r0.patch;patch=1;name=rppatch15 \
+ ${RPSRC}/poodle_asoc_fix-r1.patch;patch=1;name=rppatch16 \
file://zaurus-i2c-init.patch;patch=1;status=upstream \
-# ${RPSRC}/logo_oh-r1.patch.bz2;patch=1;status=unmergable \
- ${RPSRC}/pxa-linking-bug.patch;patch=1;status=unmergable \
+# ${RPSRC}/logo_oh-r1.patch.bz2;patch=1;status=unmergable;name=rppatch17 \
+ ${RPSRC}/pxa-linking-bug.patch;patch=1;status=unmergable;name=rppatch18 \
file://hostap-monitor-mode.patch;patch=1;status=unmergable \
file://serial-add-support-for-non-standard-xtals-to-16c950-driver.patch;patch=1;status=unmergable \
- ${RPSRC}/mmcsd_large_cards-r1.patch;patch=1;status=hack \
- ${RPSRC}/mmcsd_no_scr_check-r2.patch;patch=1;status=hack \
- ${RPSRC}/integrator_rgb-r1.patch;patch=1;status=hack \
- ${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1;status=hack \
+ ${RPSRC}/mmcsd_large_cards-r1.patch;patch=1;status=hack;name=rppatch19 \
+ ${RPSRC}/mmcsd_no_scr_check-r2.patch;patch=1;status=hack;name=rppatch20 \
+ ${RPSRC}/integrator_rgb-r1.patch;patch=1;status=hack;name=rppatch21 \
+ ${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1;status=hack;name=rppatch22 \
file://sharpsl-rc-r1.patch;patch=1 \
file://spitz_h_rewrite.patch;patch=1 \
file://pxa-serial-hack.patch;patch=1;status=hack \
@@ -57,14 +58,14 @@ SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.26.tar.bz2 \
file://defconfig"
# FIXMEs before made default
-# ${RPSRC}/mmcsd_no_scr_check-r1.patch;patch=1;status=hack
+# ${RPSRC}/mmcsd_no_scr_check-r1.patch;patch=1;status=hack;name=rppatch50
# Add this to enable pm debug code (useful with a serial lead)
-# ${RPSRC}/sharpsl_pm_debug-r0.patch;patch=1
+# ${RPSRC}/sharpsl_pm_debug-r0.patch;patch=1;name=rppatch51
# Disabled until I find the reason this gives issues with cdc_subset
-# ${RPSRC}/usb_rndis_tweaks-r0.patch;patch=1 \
+# ${RPSRC}/usb_rndis_tweaks-r0.patch;patch=1;name=rppatch52 \
SRC_URI_append_collie = "\
@@ -86,45 +87,5 @@ SRC_URI_append_zylonite ="\
S = "${WORKDIR}/linux-2.6.26"
-SRC_URI[md5sum] = "5169d01c405bc3f866c59338e217968c"
-SRC_URI[sha256sum] = "666488e2511393fdb901eaf1e67275bcc38ab37c930e8a9adb290a95c1721a2a"
-SRC_URI[md5sum] = "a8b75ef4190dfc0afcfa8789d3e4c64c"
-SRC_URI[sha256sum] = "3fed945b590db46a902fa434054b967dd1bf4af1ee5f5643e00d1d66a9d69543"
-SRC_URI[md5sum] = "38e1ea5768cba4be72088a8a12d4b1af"
-SRC_URI[sha256sum] = "837b95b128815f3d6689d2ecfbdc9a28023bae5f45879513f3b4c2ad12f459ee"
-SRC_URI[md5sum] = "ebb78f58e9c84c73b90e9cbdde5f89d6"
-SRC_URI[sha256sum] = "7578448fc2adbfc820158b2467dbb127ab012b3a97ad95366d8d1af002defbce"
-SRC_URI[md5sum] = "896d3e29ab5715b7558b972fba626425"
-SRC_URI[sha256sum] = "29f21117a17f945783f2eee5d5c89e10959fed44ac423ad9809d6afc0db5996c"
-SRC_URI[md5sum] = "c1358d4c210d1d701b5b0d96d8e73c12"
-SRC_URI[sha256sum] = "8697e76beb6ea44ce450e8cb9bed764803fe189eaea89e0aa72ebd1974bc52e4"
-SRC_URI[md5sum] = "c70fa3e0184842e4f6822b7002eac33e"
-SRC_URI[sha256sum] = "7ca39d0df0a102114eabcd39df94ff271d81a71d9ef9f61915ac0a04031b68d1"
-SRC_URI[md5sum] = "33eed5a26b2776508500532c07956dc4"
-SRC_URI[sha256sum] = "a93c7f0caa8e212a4515ce209918e250e80d2643317732d707d4f25649457545"
-SRC_URI[md5sum] = "aeea5a2614fd8f9ae7d729d1ea1dddba"
-SRC_URI[sha256sum] = "1bd129c7a68537533c77267992eaf490ff64bcc3d01c6f4b51343b8f266ae99e"
-SRC_URI[md5sum] = "e10058b52841d138630b69b954bea0b9"
-SRC_URI[sha256sum] = "779561c658ccb190f3a2cd7626e4a229834c5f9b093be8f7a06bbfaf12121b9c"
-SRC_URI[md5sum] = "c51ae4d5fa800ec81660fdf5b776fae6"
-SRC_URI[sha256sum] = "af92b078cb52f9c58964d49b074a5d09de601435c8e84cec817b636fc53c8eeb"
-SRC_URI[md5sum] = "2c958056e0a82da4d85810ea51b9e07b"
-SRC_URI[sha256sum] = "c8e0cf191fb60b26eb5481c24d162c3675c72bc940c42393af2f0b62897de90f"
-SRC_URI[md5sum] = "a17be90788c4ccd6ee8253659b9321f8"
-SRC_URI[sha256sum] = "56dfd5365848095793faa31ee1cf753c10891dd076944d3533b05c6547965134"
-SRC_URI[md5sum] = "e897eb0dc64c2862091f97e20f580de6"
-SRC_URI[sha256sum] = "66283a36122d77a4118a1b2e48af92c03ae09b3e53fe7875e7fe3db1486a522c"
-SRC_URI[md5sum] = "05766128b2b0abdd01048e5e08430600"
-SRC_URI[sha256sum] = "5fcd54adf3c8e7e99078a585683926224b5b49a99e4e675694621c3e08e6aad0"
-SRC_URI[md5sum] = "7c766563674dec668baa5f650a14b7cd"
-SRC_URI[sha256sum] = "3f78e714248cdaa0b83f530a3b7f80da02446b179e86fbb043d57c3e05ae0d7e"
-SRC_URI[md5sum] = "ce6d8a7a25cc1c9593417746bcf84ca0"
-SRC_URI[sha256sum] = "24aac1d158095007a10a47e38320a1618fab2d536f19caff94f4dd0ab29f306b"
-SRC_URI[md5sum] = "9b69a1f5951ebd26d5b29ac326c5c414"
-SRC_URI[sha256sum] = "8de4e1a8696c2f47ed1b9009498b4f89ba9dd3fbda6083531ef40c35ce001996"
-SRC_URI[md5sum] = "b60a6035a3e84ba68771fef999ccc96f"
-SRC_URI[sha256sum] = "fe3dcba12eab368a5c14e6c247886bcbaa3fafc662ea8de00fd579f956a21a71"
-SRC_URI[md5sum] = "15a09026135382c716a11633344ba3c4"
-SRC_URI[sha256sum] = "49521feb1a6e2bc9b355e93b3251e3c74ebe2327eb89c6e681347464e81e3664"
-SRC_URI[md5sum] = "b67218e773a236631b41a1718049bbc7"
-SRC_URI[sha256sum] = "f6ddc6636b2a8e4392dab43fdcfd9521e2d7f9022e56c39ecee66d50a94bdc98"
+SRC_URI[kernel.md5sum] = "5169d01c405bc3f866c59338e217968c"
+SRC_URI[kernel.sha256sum] = "666488e2511393fdb901eaf1e67275bcc38ab37c930e8a9adb290a95c1721a2a"