aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/keylaunch/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/keylaunch/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/keylaunch/files')
-rw-r--r--recipes/keylaunch/files/makefile-fix.patch15
-rw-r--r--recipes/keylaunch/files/unbreak-keyevents.patch24
2 files changed, 39 insertions, 0 deletions
diff --git a/recipes/keylaunch/files/makefile-fix.patch b/recipes/keylaunch/files/makefile-fix.patch
new file mode 100644
index 0000000000..d9c57e05ac
--- /dev/null
+++ b/recipes/keylaunch/files/makefile-fix.patch
@@ -0,0 +1,15 @@
+--- keylaunch-2.0.10/Makefile.orig 2007-05-25 18:13:39.000000000 +0200
++++ keylaunch-2.0.10/Makefile 2007-05-25 18:15:47.000000000 +0200
+@@ -31,8 +31,10 @@
+ $(CC) $(LDFLAGS) $(OBJS) $(LIBS) -o $@
+
+ install-program: all
+- install -sD $(PROG) $(DESTDIR)$(PREFIX)/bin/$(PROG)
+- install -D -m 644 $(PROG)rc $(DESTDIR)/etc/$(PROG)rc
++ install -d $(DESTDIR)$(PREFIX)/bin
++ install -s $(PROG) $(DESTDIR)$(PREFIX)/bin/$(PROG)
++ install -d $(DESTDIR)/etc
++ install -m 644 $(PROG)rc $(DESTDIR)/etc/$(PROG)rc
+ install -d $(DESTDIR)/etc/X11/Xsession.d
+ install 90$(PROG) $(DESTDIR)/etc/X11/Xsession.d/90$(PROG)
+ install -d $(DESTDIR)/etc/X11/Xinit.d
diff --git a/recipes/keylaunch/files/unbreak-keyevents.patch b/recipes/keylaunch/files/unbreak-keyevents.patch
new file mode 100644
index 0000000000..ee13cc9a63
--- /dev/null
+++ b/recipes/keylaunch/files/unbreak-keyevents.patch
@@ -0,0 +1,24 @@
+upstream: http://bugs.linuxtogo.org/show_bug.cgi?id=123
+
+# HG changeset patch
+# User "Paul Sokolovsky <pfalcon@users.sourceforge.net>"
+# Date 1196027570 -7200
+# Node ID 282176e5c55dba673756b4707716f06a5c8b37e2
+# Parent 833c989472a7987681ea3b8cbd6f9eb77293177a
+We of course still want to receive key events even after subscribing to
+property events. This fixes when keylaunch doesn't receive forwarded
+power buttons events from gpe-login --autolock in its locked state.
+In plain words: now power button works with autolock screen.
+
+diff -r 833c989472a7 -r 282176e5c55d keylaunch.c
+--- a/keylaunch.c Sun Nov 25 22:04:29 2007 +0200
++++ b/keylaunch.c Sun Nov 25 23:52:50 2007 +0200
+@@ -682,7 +682,7 @@ main (int argc, char *argv[])
+ {
+ initialize (argc, argv);
+
+- XSelectInput (dpy, DefaultRootWindow (dpy), PropertyChangeMask);
++ XSelectInput (dpy, DefaultRootWindow (dpy), PropertyChangeMask | KeyPressMask | KeyReleaseMask);
+ gpe_launch_monitor_display (dpy);
+
+ signal (SIGCHLD, SIG_IGN);