aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/keymaps
diff options
context:
space:
mode:
authorKlaus Kurzmann <mok@fluxnetz.de>2010-10-02 13:26:20 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-10-27 23:08:28 +0200
commitd838df9eace1c7c185c2a0a77a2b1630121dc87f (patch)
tree6797df56545c29b5e0cbaa3b2fd9b7d96cf48699 /recipes/keymaps
parent7d66ee089b1efcb8a07c90c1ca586c27703b1cfe (diff)
downloadopenembedded-d838df9eace1c7c185c2a0a77a2b1630121dc87f.tar.gz
keymaps: add keymap for the nokia900
bump PR of task-base and task-boot to pickup keyboard for nokia900 Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/keymaps')
-rw-r--r--recipes/keymaps/files/nokia900/keymap-2.6.map69
-rw-r--r--recipes/keymaps/keymaps_1.0.bb5
2 files changed, 72 insertions, 2 deletions
diff --git a/recipes/keymaps/files/nokia900/keymap-2.6.map b/recipes/keymaps/files/nokia900/keymap-2.6.map
new file mode 100644
index 0000000000..8bda01d6a7
--- /dev/null
+++ b/recipes/keymaps/files/nokia900/keymap-2.6.map
@@ -0,0 +1,69 @@
+keymaps 0-2,4
+#
+keycode 14 = Delete
+keycode 16 = q
+ altgr keycode 16 = one
+keycode 17 = w
+ altgr keycode 17 = two
+keycode 18 = e
+ altgr keycode 18 = three
+keycode 19 = r
+ altgr keycode 19 = four
+keycode 20 = t
+ altgr keycode 20 = five
+keycode 21 = y
+ altgr keycode 21 = six
+keycode 22 = u
+ altgr keycode 22 = seven
+keycode 23 = i
+ altgr keycode 23 = eight
+keycode 24 = o
+ altgr keycode 24 = nine
+keycode 25 = p
+ altgr keycode 25 = zero
+keycode 28 = Return
+keycode 29 = Control
+ altgr keycode 29 = Escape
+keycode 30 = a
+ altgr keycode 30 = asterisk
+keycode 31 = s
+ altgr keycode 31 = plus
+keycode 32 = d
+ altgr keycode 32 = numbersign
+keycode 33 = f
+ altgr keycode 33 = minus
+keycode 34 = g
+ altgr keycode 34 = underscore
+keycode 35 = h
+ altgr keycode 35 = parenleft
+keycode 36 = j
+ altgr keycode 36 = parenright
+keycode 37 = k
+ altgr keycode 37 = ampersand
+keycode 38 = l
+ altgr keycode 38 = exclam
+keycode 42 = Shift
+keycode 44 = z
+ altgr keycode 44 = bar
+keycode 45 = x
+ altgr keycode 45 = dollar
+keycode 46 = c
+ altgr keycode 46 = percent
+keycode 47 = v
+ altgr keycode 47 = slash
+keycode 48 = b
+ altgr keycode 48 = backslash
+keycode 49 = n
+ altgr keycode 49 = quotedbl
+keycode 50 = m
+ altgr keycode 50 = apostrophe
+keycode 51 = comma semicolon equal
+keycode 52 = period colon question
+keycode 57 = space Tab at
+keycode 100 = AltGr
+keycode 103 = Up
+keycode 105 = Left
+ altgr keycode 105 = less
+keycode 106 = Right
+ altgr keycode 106 = greater
+keycode 108 = Down
diff --git a/recipes/keymaps/keymaps_1.0.bb b/recipes/keymaps/keymaps_1.0.bb
index f8cd77f56c..c17ee375f2 100644
--- a/recipes/keymaps/keymaps_1.0.bb
+++ b/recipes/keymaps/keymaps_1.0.bb
@@ -3,7 +3,7 @@ SECTION = "base"
RDEPENDS_${PN} = "console-tools"
LICENSE = "GPL"
PACKAGE_ARCH = "${MACHINE}"
-PR = "r25"
+PR = "r26"
inherit update-rc.d
@@ -29,6 +29,7 @@ SRC_URI_append_jornada6xx = " file://keymap-uk-620-660.map \
file://keymap-sp.map \
file://keymap-uk.map \
"
+SRC_URI_append_nokia900 = " file://keymap-2.6.map"
INITSCRIPT_NAME = "keymap"
@@ -39,7 +40,7 @@ do_install () {
install -m 0755 ${WORKDIR}/keymap ${D}${sysconfdir}/init.d/
case ${MACHINE} in
- c7x0 | tosa | spitz | akita | borzoi | collie | poodle | jornada6xx | h2200 | h4000 | hx4700 | htcuniversal | qemux86 | omap3-pandora )
+ c7x0 | tosa | spitz | akita | borzoi | collie | poodle | jornada6xx | h2200 | h4000 | hx4700 | htcuniversal | qemux86 | omap3-pandora | nokia900 )
install -m 0644 ${WORKDIR}/keymap-*.map ${D}${sysconfdir}
;;
*)