aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/keyring/keyring_0.6.8.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/keyring/keyring_0.6.8.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/keyring/keyring_0.6.8.bb')
-rw-r--r--recipes/keyring/keyring_0.6.8.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/keyring/keyring_0.6.8.bb b/recipes/keyring/keyring_0.6.8.bb
new file mode 100644
index 0000000000..5739255826
--- /dev/null
+++ b/recipes/keyring/keyring_0.6.8.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Stores accounts and passwords in an encrypted file."
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gdbm"
+PR = "r2"
+
+SRC_URI = "http://www.scrypt.net/~celer/kweb/Keyring-0.6.8.tgz \
+ file://keyring-0.6.8-datatype.patch;patch=1"
+S = "${WORKDIR}/Keyring"
+
+inherit palmtop
+
+QPEDIR = "${OPIEDIR}"
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics/keyring
+ install -m 0755 keyring ${D}${palmtopdir}/bin/
+ install -m 0644 keyring.desktop \
+ ${D}${palmtopdir}/apps/Applications/
+ install -m 0644 ${S}/Keyring.png \
+ ${S}/keyring-pwlist.png \
+ ${D}${palmtopdir}/pics/
+
+ # The following should appear in an assoicated DOC package.
+
+ install -d ${D}${palmtopdir}/help/html
+ install -m 0644 ${S}/*.html ${D}${palmtopdir}/help/html/
+}
+
+PACKAGES = "${PN}-dbg ${PN} ${PN}-help"
+FILES_${PN} = " ${palmtopdir}${base_bindir} ${palmtopdir}/apps ${palmtopdir}/pics"
+FILES_${PN}-help = " ${palmtopdir}/help/html"
+