aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kismet
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/kismet
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/kismet')
-rw-r--r--recipes/kismet/files/glibc3.3.2-getopt-throw.diff36
-rw-r--r--recipes/kismet/files/no-chmod.diff173
-rw-r--r--recipes/kismet/files/no-chmod.patch173
-rw-r--r--recipes/kismet/files/no-strip.diff45
-rw-r--r--recipes/kismet/kismet-2007-10-R1/fix_strip.patch47
-rw-r--r--recipes/kismet/kismet-newcore_svn.bb12
-rw-r--r--recipes/kismet/kismet.inc36
-rw-r--r--recipes/kismet/kismet_2007-01-R1b.bb3
-rw-r--r--recipes/kismet/kismet_2007-10-R1.bb5
-rw-r--r--recipes/kismet/kismet_svn.bb10
10 files changed, 540 insertions, 0 deletions
diff --git a/recipes/kismet/files/glibc3.3.2-getopt-throw.diff b/recipes/kismet/files/glibc3.3.2-getopt-throw.diff
new file mode 100644
index 0000000000..7032e3d736
--- /dev/null
+++ b/recipes/kismet/files/glibc3.3.2-getopt-throw.diff
@@ -0,0 +1,36 @@
+--- getopt.h.o 2004-10-10 19:48:48.409249432 +0200
++++ getopt.h 2004-10-10 19:51:42.610766776 +0200
+@@ -20,6 +20,14 @@
+
+ #include "config.h"
+
++#ifndef __THROW
++# if defined __cplusplus && __GNUC_PREREQ (2,8)
++# define __THROW throw ()
++# else
++# define __THROW
++# endif
++#endif
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+@@ -103,15 +111,15 @@
+ /* Many other libraries have conflicting prototypes for getopt, with
+ differences in the consts, in stdlib.h. To avoid compilation
+ errors, only prototype getopt for the GNU C library. */
+-extern int getopt (int argc, char *const *argv, const char *shortopts);
++extern int getopt (int argc, char *const *argv, const char *shortopts) __THROW;
+ #else /* not __GNU_LIBRARY__ */
+ /* extern int getopt (); */
+ #endif /* not __GNU_LIBRARY__ */
+ extern int getopt_long (int argc, char *const *argv, const char *shortopts,
+- const struct option *longopts, int *longind);
++ const struct option *longopts, int *longind) __THROW;
+ extern int getopt_long_only (int argc, char *const *argv,
+ const char *shortopts,
+- const struct option *longopts, int *longind);
++ const struct option *longopts, int *longind) __THROW;
+
+ /* Internal only. Users should not call this directly. */
+ extern int _getopt_internal (int argc, char *const *argv,
diff --git a/recipes/kismet/files/no-chmod.diff b/recipes/kismet/files/no-chmod.diff
new file mode 100644
index 0000000000..9520d1df5b
--- /dev/null
+++ b/recipes/kismet/files/no-chmod.diff
@@ -0,0 +1,173 @@
+--- Makefile.in.o 2004-10-16 15:55:52.836093688 +0200
++++ Makefile.in 2004-10-16 16:06:38.966866880 +0200
+@@ -130,52 +130,52 @@
+ fi
+
+ binuserinstall:
+- install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(PS) $(BIN)/$(PS);
+- install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(DRONE) $(BIN)/$(DRONE);
++ install -m 755 $(PS) $(BIN)/$(PS);
++ install -m 755 $(DRONE) $(BIN)/$(DRONE);
+
+ binsuidinstall:
+- install -o $(INSTUSR) -g $(INSTGRP) -m 4755 $(PS) $(BIN)/$(PS);
+- install -o $(INSTUSR) -g $(INSTGRP) -m 4755 $(DRONE) $(BIN)/$(DRONE);
++ install -m 4755 $(PS) $(BIN)/$(PS);
++ install -m 4755 $(DRONE) $(BIN)/$(DRONE);
+
+ commoninstall:
+ mkdir -p $(ETC)
+ mkdir -p $(BIN)
+
+- install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet $(BIN)/kismet
+- install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(NC) $(BIN)/$(NC)
+- # install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(HOPPER) $(BIN)/$(HOPPER)
++ install -m 755 scripts/kismet $(BIN)/kismet
++ install -m 755 $(NC) $(BIN)/$(NC)
++ # install -m 755 $(HOPPER) $(BIN)/$(HOPPER)
+ @if test "$(ZAURUS)" = "yes"; then \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(BUZZER) $(BIN)/buzzme; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(BUZZER) $(BIN)/buzzme; \
++ install -m 755 $(BUZZER) $(BIN)/buzzme; \
++ echo install -m 755 $(BUZZER) $(BIN)/buzzme; \
+ fi
+-#install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet_monitor $(BIN)/kismet_monitor
+-#install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet_unmonitor $(BIN)/kismet_unmonitor
++#install -m 755 scripts/kismet_monitor $(BIN)/kismet_monitor
++#install -m 755 scripts/kismet_unmonitor $(BIN)/kismet_unmonitor
+ mkdir -p $(MAN)/man1
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet.1 $(MAN)/man1/kismet.1
+- # install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_monitor.1 $(MAN)/man1/kismet_monitor.1
+- # install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_hopper.1 $(MAN)/man1/kismet_hopper.1
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_drone.1 $(MAN)/man1/kismet_drone.1
++ install -m 644 man/kismet.1 $(MAN)/man1/kismet.1
++ # install -m 644 man/kismet_monitor.1 $(MAN)/man1/kismet_monitor.1
++ # install -m 644 man/kismet_hopper.1 $(MAN)/man1/kismet_hopper.1
++ install -m 644 man/kismet_drone.1 $(MAN)/man1/kismet_drone.1
+ mkdir -p $(MAN)/man5
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet.conf.5 $(MAN)/man5/kismet.conf.5
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_ui.conf.5 $(MAN)/man5/kismet_ui.conf.5
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_drone.conf.5 $(MAN)/man5/kismet_drone.conf.5
++ install -m 644 man/kismet.conf.5 $(MAN)/man5/kismet.conf.5
++ install -m 644 man/kismet_ui.conf.5 $(MAN)/man5/kismet_ui.conf.5
++ install -m 644 man/kismet_drone.conf.5 $(MAN)/man5/kismet_drone.conf.5
+
+ @if test "$(GPSLBUILD)" = "$(GPSL)"; then \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(GPSL) $(BIN)/$(GPSL); \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(GPSL) $(BIN)/$(GPSL); \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/gpsmap.1 $(MAN)/man1/gpsmap.1; \
+- echo install -o $(INSTUSR) -g $(MANGRP) -m 644 man/gpsmap.1 $(MAN)/man1/gpsmap.1; \
++ install -m 755 $(GPSL) $(BIN)/$(GPSL); \
++ echo install -m 755 $(GPSL) $(BIN)/$(GPSL); \
++ install -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
++ echo install -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
++ install -m 644 man/gpsmap.1 $(MAN)/man1/gpsmap.1; \
++ echo install -m 644 man/gpsmap.1 $(MAN)/man1/gpsmap.1; \
+ fi
+
+ mkdir -p $(WAV)
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 wav/new_network.wav $(WAV)/new_network.wav
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 wav/traffic.wav $(WAV)/traffic.wav
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 wav/junk_traffic.wav $(WAV)/junk_traffic.wav
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 wav/alert.wav $(WAV)/alert.wav
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/ap_manuf $(ETC)/ap_manuf;
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/client_manuf $(ETC)/client_manuf;
++ install -m 644 wav/new_network.wav $(WAV)/new_network.wav
++ install -m 644 wav/traffic.wav $(WAV)/traffic.wav
++ install -m 644 wav/junk_traffic.wav $(WAV)/junk_traffic.wav
++ install -m 644 wav/alert.wav $(WAV)/alert.wav
++ install -m 644 conf/ap_manuf $(ETC)/ap_manuf;
++ install -m 644 conf/client_manuf $(ETC)/client_manuf;
+
+ @if test -f $(BIN)/kismet_curses; then \
+ echo "Removing old kismet_curses binary. The panels frontend is now kismet_client."; \
+@@ -188,22 +188,22 @@
+ @if test -f $(ETC)/kismet.conf; then \
+ $(MAKE) -e checkconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ echo install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+ echo "Installed config into $(ETC)/kismet.conf."; \
+ fi
+ @if test -f $(ETC)/kismet_drone.conf; then \
+ $(MAKE) -e checkdroneconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ echo install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+ echo "Installed drone config into $(ETC)/kismet_drone.conf."; \
+ fi
+ @if test -f $(ETC)/kismet_ui.conf; then \
+ $(MAKE) -e checkuiconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ echo install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+ echo "Installed UI config into $(ETC)/kismet_ui.conf."; \
+ fi
+ @echo "Installed kismet into $(BIN)/."
+@@ -221,22 +221,22 @@
+ @if test -f $(ETC)/kismet.conf; then \
+ $(MAKE) -e checkconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ echo install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+ echo "Installed config into $(ETC)/kismet.conf."; \
+ fi
+ @if test -f $(ETC)/kismet_drone.conf; then \
+ $(MAKE) -e checkdroneconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ echo install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+ echo "Installed drone config into $(ETC)/kismet_drone.conf."; \
+ fi
+ @if test -f $(ETC)/kismet_ui.conf; then \
+ $(MAKE) -e checkuiconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ echo install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+ echo "Installed UI config into $(ETC)/kismet_ui.conf."; \
+ fi
+ @echo "Installed kismet into $(BIN)/."
+@@ -252,11 +252,11 @@
+ forceinstall: $(PS)
+ $(MAKE) -e commoninstall
+ $(MAKE) -e binuserinstall
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+ echo "Installed config into $(ETC)/kismet.conf.";
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+ echo "Installed drone config into $(ETC)/kismet_drone.conf.";
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+ echo "Installed UI config into $(ETC)/kismet_ui.conf.";
+ @echo "Installed kismet into $(BIN)/."
+ @echo "If you have not done so already, read the README file and the FAQ file. Additional"
+@@ -271,11 +271,11 @@
+ suidforceinstall: $(PS)
+ $(MAKE) -e commoninstall
+ $(MAKE) -e binsuidinstall
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+ echo "Installed config into $(ETC)/kismet.conf.";
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+ echo "Installed drone config into $(ETC)/kismet_drone.conf.";
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+ echo "Installed UI config into $(ETC)/kismet_ui.conf.";
+ @echo "Installed kismet into $(BIN)/."
+ @echo "If you have not done so already, read the README file and the FAQ file. Additional"
diff --git a/recipes/kismet/files/no-chmod.patch b/recipes/kismet/files/no-chmod.patch
new file mode 100644
index 0000000000..b22c513b68
--- /dev/null
+++ b/recipes/kismet/files/no-chmod.patch
@@ -0,0 +1,173 @@
+--- kismet-2006-04-R1/Makefile.in.orig 2006-09-14 11:37:20.000000000 +0100
++++ kismet-2006-04-R1/Makefile.in 2006-09-14 11:38:01.000000000 +0100
+@@ -130,52 +130,52 @@
+ fi
+
+ binuserinstall:
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(PS) $(BIN)/$(PS);
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(DRONE) $(BIN)/$(DRONE);
++ install -m 755 $(PS) $(BIN)/$(PS);
++ install -m 755 $(DRONE) $(BIN)/$(DRONE);
+
+ binsuidinstall:
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 4755 $(PS) $(BIN)/$(PS);
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 4755 $(DRONE) $(BIN)/$(DRONE);
++ install -m 4755 $(PS) $(BIN)/$(PS);
++ install -m 4755 $(DRONE) $(BIN)/$(DRONE);
+
+ commoninstall:
+ mkdir -p $(ETC)
+ mkdir -p $(BIN)
+
+- install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet $(BIN)/kismet
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(NC) $(BIN)/$(NC)
+- # install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(HOPPER) $(BIN)/$(HOPPER)
++ install -m 755 scripts/kismet $(BIN)/kismet
++ install -m 755 $(NC) $(BIN)/$(NC)
++ # install -m 755 $(HOPPER) $(BIN)/$(HOPPER)
+ @if test "$(ZAURUS)" = "yes"; then \
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(BUZZER) $(BIN)/buzzme; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(BUZZER) $(BIN)/buzzme; \
++ install -m 755 $(BUZZER) $(BIN)/buzzme; \
++ echo install -m 755 $(BUZZER) $(BIN)/buzzme; \
+ fi
+-#install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet_monitor $(BIN)/kismet_monitor
+-#install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet_unmonitor $(BIN)/kismet_unmonitor
++#install -m 755 scripts/kismet_monitor $(BIN)/kismet_monitor
++#install -m 755 scripts/kismet_unmonitor $(BIN)/kismet_unmonitor
+ mkdir -p $(MAN)/man1
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet.1 $(MAN)/man1/kismet.1
+- # install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_monitor.1 $(MAN)/man1/kismet_monitor.1
+- # install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_hopper.1 $(MAN)/man1/kismet_hopper.1
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_drone.1 $(MAN)/man1/kismet_drone.1
++ install -m 644 man/kismet.1 $(MAN)/man1/kismet.1
++ # install -m 644 man/kismet_monitor.1 $(MAN)/man1/kismet_monitor.1
++ # install -m 644 man/kismet_hopper.1 $(MAN)/man1/kismet_hopper.1
++ install -m 644 man/kismet_drone.1 $(MAN)/man1/kismet_drone.1
+ mkdir -p $(MAN)/man5
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet.conf.5 $(MAN)/man5/kismet.conf.5
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_ui.conf.5 $(MAN)/man5/kismet_ui.conf.5
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_drone.conf.5 $(MAN)/man5/kismet_drone.conf.5
++ install -m 644 man/kismet.conf.5 $(MAN)/man5/kismet.conf.5
++ install -m 644 man/kismet_ui.conf.5 $(MAN)/man5/kismet_ui.conf.5
++ install -m 644 man/kismet_drone.conf.5 $(MAN)/man5/kismet_drone.conf.5
+
+ @if test "$(GPSLBUILD)" = "$(GPSL)"; then \
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(GPSL) $(BIN)/$(GPSL); \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(GPSL) $(BIN)/$(GPSL); \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/gpsmap.1 $(MAN)/man1/gpsmap.1; \
+- echo install -o $(INSTUSR) -g $(MANGRP) -m 644 man/gpsmap.1 $(MAN)/man1/gpsmap.1; \
++ install -m 755 $(GPSL) $(BIN)/$(GPSL); \
++ echo install -m 755 $(GPSL) $(BIN)/$(GPSL); \
++ install -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
++ echo install -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
++ install -m 644 man/gpsmap.1 $(MAN)/man1/gpsmap.1; \
++ echo install -m 644 man/gpsmap.1 $(MAN)/man1/gpsmap.1; \
+ fi
+
+ mkdir -p $(WAV)
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 wav/new_network.wav $(WAV)/new_network.wav
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 wav/traffic.wav $(WAV)/traffic.wav
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 wav/junk_traffic.wav $(WAV)/junk_traffic.wav
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 wav/alert.wav $(WAV)/alert.wav
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/ap_manuf $(ETC)/ap_manuf;
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/client_manuf $(ETC)/client_manuf;
++ install -m 644 wav/new_network.wav $(WAV)/new_network.wav
++ install -m 644 wav/traffic.wav $(WAV)/traffic.wav
++ install -m 644 wav/junk_traffic.wav $(WAV)/junk_traffic.wav
++ install -m 644 wav/alert.wav $(WAV)/alert.wav
++ install -m 644 conf/ap_manuf $(ETC)/ap_manuf;
++ install -m 644 conf/client_manuf $(ETC)/client_manuf;
+
+ @if test -f $(BIN)/kismet_curses; then \
+ echo "Removing old kismet_curses binary. The panels frontend is now kismet_client."; \
+@@ -188,22 +188,22 @@
+ @if test -f $(ETC)/kismet.conf; then \
+ $(MAKE) -e checkconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ echo install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+ echo "Installed config into $(ETC)/kismet.conf."; \
+ fi
+ @if test -f $(ETC)/kismet_drone.conf; then \
+ $(MAKE) -e checkdroneconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ echo install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+ echo "Installed drone config into $(ETC)/kismet_drone.conf."; \
+ fi
+ @if test -f $(ETC)/kismet_ui.conf; then \
+ $(MAKE) -e checkuiconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ echo install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+ echo "Installed UI config into $(ETC)/kismet_ui.conf."; \
+ fi
+ @echo "Installed kismet into $(BIN)/."
+@@ -221,22 +221,22 @@
+ @if test -f $(ETC)/kismet.conf; then \
+ $(MAKE) -e checkconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ echo install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+ echo "Installed config into $(ETC)/kismet.conf."; \
+ fi
+ @if test -f $(ETC)/kismet_drone.conf; then \
+ $(MAKE) -e checkdroneconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ echo install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+ echo "Installed drone config into $(ETC)/kismet_drone.conf."; \
+ fi
+ @if test -f $(ETC)/kismet_ui.conf; then \
+ $(MAKE) -e checkuiconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ echo install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+ echo "Installed UI config into $(ETC)/kismet_ui.conf."; \
+ fi
+ @echo "Installed kismet into $(BIN)/."
+@@ -252,11 +252,11 @@
+ forceinstall: $(PS)
+ $(MAKE) -e commoninstall
+ $(MAKE) -e binuserinstall
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+ echo "Installed config into $(ETC)/kismet.conf.";
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+ echo "Installed drone config into $(ETC)/kismet_drone.conf.";
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+ echo "Installed UI config into $(ETC)/kismet_ui.conf.";
+ @echo "Installed kismet into $(BIN)/."
+ @echo "If you have not done so already, read the README file and the FAQ file. Additional"
+@@ -271,11 +271,11 @@
+ suidforceinstall: $(PS)
+ $(MAKE) -e commoninstall
+ $(MAKE) -e binsuidinstall
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+ echo "Installed config into $(ETC)/kismet.conf.";
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+ echo "Installed drone config into $(ETC)/kismet_drone.conf.";
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+ echo "Installed UI config into $(ETC)/kismet_ui.conf.";
+ @echo "Installed kismet into $(BIN)/."
+ @echo "If you have not done so already, read the README file and the FAQ file. Additional"
diff --git a/recipes/kismet/files/no-strip.diff b/recipes/kismet/files/no-strip.diff
new file mode 100644
index 0000000000..a4a8f85344
--- /dev/null
+++ b/recipes/kismet/files/no-strip.diff
@@ -0,0 +1,45 @@
+--- Makefile.in.o 2004-10-08 18:59:21.294566720 +0200
++++ Makefile.in 2004-10-08 18:59:40.034717784 +0200
+@@ -130,23 +130,23 @@
+ fi
+
+ binuserinstall:
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(PS) $(BIN)/$(PS);
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(DRONE) $(BIN)/$(DRONE);
++ install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(PS) $(BIN)/$(PS);
++ install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(DRONE) $(BIN)/$(DRONE);
+
+ binsuidinstall:
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 4755 $(PS) $(BIN)/$(PS);
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 4755 $(DRONE) $(BIN)/$(DRONE);
++ install -o $(INSTUSR) -g $(INSTGRP) -m 4755 $(PS) $(BIN)/$(PS);
++ install -o $(INSTUSR) -g $(INSTGRP) -m 4755 $(DRONE) $(BIN)/$(DRONE);
+
+ commoninstall:
+ mkdir -p $(ETC)
+ mkdir -p $(BIN)
+
+ install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet $(BIN)/kismet
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(NC) $(BIN)/$(NC)
+- # install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(HOPPER) $(BIN)/$(HOPPER)
++ install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(NC) $(BIN)/$(NC)
++ # install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(HOPPER) $(BIN)/$(HOPPER)
+ @if test "$(ZAURUS)" = "yes"; then \
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(BUZZER) $(BIN)/buzzme; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(BUZZER) $(BIN)/buzzme; \
++ install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(BUZZER) $(BIN)/buzzme; \
++ echo install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(BUZZER) $(BIN)/buzzme; \
+ fi
+ #install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet_monitor $(BIN)/kismet_monitor
+ #install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet_unmonitor $(BIN)/kismet_unmonitor
+@@ -161,8 +161,8 @@
+ install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_drone.conf.5 $(MAN)/man5/kismet_drone.conf.5
+
+ @if test "$(GPSLBUILD)" = "$(GPSL)"; then \
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(GPSL) $(BIN)/$(GPSL); \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(GPSL) $(BIN)/$(GPSL); \
++ install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(GPSL) $(BIN)/$(GPSL); \
++ echo install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(GPSL) $(BIN)/$(GPSL); \
+ install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
+ echo install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
+ install -o $(INSTUSR) -g $(MANGRP) -m 644 man/gpsmap.1 $(MAN)/man1/gpsmap.1; \
diff --git a/recipes/kismet/kismet-2007-10-R1/fix_strip.patch b/recipes/kismet/kismet-2007-10-R1/fix_strip.patch
new file mode 100644
index 0000000000..54e7a9b1b7
--- /dev/null
+++ b/recipes/kismet/kismet-2007-10-R1/fix_strip.patch
@@ -0,0 +1,47 @@
+Index: kismet-2007-10-R1/Makefile.in
+===================================================================
+--- kismet-2007-10-R1.orig/Makefile.in 2008-03-06 15:20:37.000000000 +0000
++++ kismet-2007-10-R1/Makefile.in 2008-03-06 15:21:07.000000000 +0000
+@@ -138,23 +138,23 @@
+ fi
+
+ binuserinstall:
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(PS) $(BIN)/$(PS);
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(DRONE) $(BIN)/$(DRONE);
++ install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(PS) $(BIN)/$(PS);
++ install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(DRONE) $(BIN)/$(DRONE);
+
+ binsuidinstall:
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 4755 $(PS) $(BIN)/$(PS);
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 4755 $(DRONE) $(BIN)/$(DRONE);
++ install -o $(INSTUSR) -g $(INSTGRP) -m 4755 $(PS) $(BIN)/$(PS);
++ install -o $(INSTUSR) -g $(INSTGRP) -m 4755 $(DRONE) $(BIN)/$(DRONE);
+
+ commoninstall:
+ mkdir -p $(ETC)
+ mkdir -p $(BIN)
+
+ install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(WRAP) $(BIN)/kismet
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(NC) $(BIN)/$(NC)
+- # install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(HOPPER) $(BIN)/$(HOPPER)
++ install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(NC) $(BIN)/$(NC)
++ # install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(HOPPER) $(BIN)/$(HOPPER)
+ @if test "$(ZAURUS)" = "yes"; then \
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(BUZZER) $(BIN)/buzzme; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(BUZZER) $(BIN)/buzzme; \
++ install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(BUZZER) $(BIN)/buzzme; \
++ echo install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(BUZZER) $(BIN)/buzzme; \
+ fi
+ #install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet_monitor $(BIN)/kismet_monitor
+ #install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet_unmonitor $(BIN)/kismet_unmonitor
+@@ -169,8 +169,8 @@
+ install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_drone.conf.5 $(MAN)/man5/kismet_drone.conf.5
+
+ @if test "$(GPSLBUILD)" = "$(GPSL)"; then \
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(GPSL) $(BIN)/$(GPSL); \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(GPSL) $(BIN)/$(GPSL); \
++ install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(GPSL) $(BIN)/$(GPSL); \
++ echo install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(GPSL) $(BIN)/$(GPSL); \
+ install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
+ echo install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
+ install -o $(INSTUSR) -g $(MANGRP) -m 644 man/gpsmap.1 $(MAN)/man1/gpsmap.1; \
diff --git a/recipes/kismet/kismet-newcore_svn.bb b/recipes/kismet/kismet-newcore_svn.bb
new file mode 100644
index 0000000000..6f3c00bdcb
--- /dev/null
+++ b/recipes/kismet/kismet-newcore_svn.bb
@@ -0,0 +1,12 @@
+require kismet.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+PV = "0.0+svnr${SRCREV}"
+PR = "r3"
+
+SRC_URI = "svn://svn.kismetwireless.net/code/branch/;module=kismet-newcore;proto=http"
+
+EXTRA_OECONF += "--disable-gpsmap"
+
+S = "${WORKDIR}/kismet-newcore"
diff --git a/recipes/kismet/kismet.inc b/recipes/kismet/kismet.inc
new file mode 100644
index 0000000000..efc987cf0c
--- /dev/null
+++ b/recipes/kismet/kismet.inc
@@ -0,0 +1,36 @@
+DESCRIPTION = "Kismet is an 802.11 layer2 wireless network detector, sniffer, and intrusion detection system"
+HOMEPAGE = "http://www.kismetwireless.net/"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+DEPENDS = "expat gmp imagemagick tiff fakeroot-native zlib bzip2 libpcap"
+
+SRC_URI = "http://www.kismetwireless.net/code/kismet-${PV}.tar.gz"
+
+EXTRA_OECONF = "--enable-wsp100 --with-pcap=linux \
+ --with-linuxheaders=${STAGING_KERNEL_DIR}/include"
+
+inherit autotools
+
+# .depend is needed by the main compile but can run in parallel
+PARALLE_MAKE = ""
+
+fakeroot do_install() {
+ oe_runmake "DESTDIR=${D}" suidinstall
+}
+
+do_install_append() {
+ if test -e ${WORKDIR}/kismet.conf; then
+ install -m 644 ${WORKDIR}/kismet.conf ${D}${sysconfdir}/
+ fi
+}
+
+PACKAGES =+ "${PN}-sounds ${PN}-gpsmap"
+
+FILES_${PN}-sounds = "${datadir}/kismet/wav"
+RDEPENDS_${PN}-sounds = "sox"
+
+FILES_${PN}-gpsmap = "${bindir}/gpsmap*"
+RDEPENDS_${PN}-gpsmap = "gpsd"
+
+CONFFILES_${PN} = "${sysconfdir}/kismet.conf ${sysconfdir}/kismet_ui.conf ${sysconfdir}/kismet_drone.conf"
+
diff --git a/recipes/kismet/kismet_2007-01-R1b.bb b/recipes/kismet/kismet_2007-01-R1b.bb
new file mode 100644
index 0000000000..ef1cf86c98
--- /dev/null
+++ b/recipes/kismet/kismet_2007-01-R1b.bb
@@ -0,0 +1,3 @@
+require kismet.inc
+
+PR = "r3"
diff --git a/recipes/kismet/kismet_2007-10-R1.bb b/recipes/kismet/kismet_2007-10-R1.bb
new file mode 100644
index 0000000000..4786543ec8
--- /dev/null
+++ b/recipes/kismet/kismet_2007-10-R1.bb
@@ -0,0 +1,5 @@
+require kismet.inc
+
+SRC_URI += "file://fix_strip.patch;patch=1"
+
+PR = "r5"
diff --git a/recipes/kismet/kismet_svn.bb b/recipes/kismet/kismet_svn.bb
new file mode 100644
index 0000000000..878678052a
--- /dev/null
+++ b/recipes/kismet/kismet_svn.bb
@@ -0,0 +1,10 @@
+require kismet.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+PV = "2007-10-R1+svnr${SRCREV}"
+PR = "r2"
+
+SRC_URI = "svn://svn.kismetwireless.net/code/;module=trunk;proto=http"
+
+S = "${WORKDIR}/trunk"