aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kismet
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2011-04-15 20:08:02 +0000
committerutx@penguin.cz <utx@penguin.cz>2011-04-15 20:08:02 +0000
commit20ade7e02f3c7afa941ee1825ba23997aeaef7b8 (patch)
treea244c90b98ea08086414d06e4de33f69b684f371 /recipes/kismet
parent3a14edb399582ab9b51bd1833ebef1eff785d326 (diff)
downloadopenembedded-20ade7e02f3c7afa941ee1825ba23997aeaef7b8.tar.gz
kismet: Updated to version 2010-07-R1.
Signed-off-by: Stanislav Brabec <utx@penguin.cz>
Diffstat (limited to 'recipes/kismet')
-rw-r--r--recipes/kismet/kismet-2010-07-R1/hardcoded-usr.patch11
-rw-r--r--recipes/kismet/kismet-2010-07-R1/kismet-2008-05-R1-infinite-loop.diff20
-rw-r--r--recipes/kismet/kismet-2010-07-R1/kismet-2008-05-R1-nonvoid.diff10
-rw-r--r--recipes/kismet/kismet_2010-07-R1.bb22
4 files changed, 63 insertions, 0 deletions
diff --git a/recipes/kismet/kismet-2010-07-R1/hardcoded-usr.patch b/recipes/kismet/kismet-2010-07-R1/hardcoded-usr.patch
new file mode 100644
index 0000000000..1973768479
--- /dev/null
+++ b/recipes/kismet/kismet-2010-07-R1/hardcoded-usr.patch
@@ -0,0 +1,11 @@
+--- kismet-2010-07-R1/configure.in
++++ kismet-2010-07-R1/configure.in
+@@ -407,7 +407,7 @@
+ AC_SUBST(wantclient)
+
+ # Add additional cflags since some distros bury panel.h
+-CPPFLAGS="$CPPFLAGS -I/usr/include/ncurses"
++CPPFLAGS="$CPPFLAGS `ncurses-config --cflags`"
+
+ termcontrol="none";
+
diff --git a/recipes/kismet/kismet-2010-07-R1/kismet-2008-05-R1-infinite-loop.diff b/recipes/kismet/kismet-2010-07-R1/kismet-2008-05-R1-infinite-loop.diff
new file mode 100644
index 0000000000..958fede18b
--- /dev/null
+++ b/recipes/kismet/kismet-2010-07-R1/kismet-2008-05-R1-infinite-loop.diff
@@ -0,0 +1,20 @@
+--- extra/kismet2cwgd.cc
++++ extra/kismet2cwgd.cc
+@@ -874,7 +874,7 @@
+
+ // Break up the path to the gpsxml file and form a path based on that
+ unsigned int lastslash = 0;
+- for (unsigned int x = origxmlfile.find('/'); x != string::npos;
++ for (string::size_type x = origxmlfile.find('/'); x != string::npos;
+ lastslash = x, x = origxmlfile.find('/', lastslash+1)) {
+ // We don't actually need to do anything...
+ }
+@@ -882,7 +882,7 @@
+ comp = origxmlfile.substr(0, lastslash);
+
+ lastslash = 0;
+- for (unsigned int x = orignetfile.find('/'); x != string::npos;
++ for (string::size_type x = orignetfile.find('/'); x != string::npos;
+ lastslash = x, x = orignetfile.find('/', lastslash+1)) {
+ // We don't actually need to do anything...
+ }
diff --git a/recipes/kismet/kismet-2010-07-R1/kismet-2008-05-R1-nonvoid.diff b/recipes/kismet/kismet-2010-07-R1/kismet-2008-05-R1-nonvoid.diff
new file mode 100644
index 0000000000..e068f8dac5
--- /dev/null
+++ b/recipes/kismet/kismet-2010-07-R1/kismet-2008-05-R1-nonvoid.diff
@@ -0,0 +1,10 @@
+--- pcapsource.cc
++++ pcapsource.cc
+@@ -2914,6 +2914,7 @@
+ return -1;
+
+ }
++ return -1;
+ }
+ #endif
+
diff --git a/recipes/kismet/kismet_2010-07-R1.bb b/recipes/kismet/kismet_2010-07-R1.bb
new file mode 100644
index 0000000000..ea4181facc
--- /dev/null
+++ b/recipes/kismet/kismet_2010-07-R1.bb
@@ -0,0 +1,22 @@
+require kismet.inc
+
+# patches *.diff are from openSUSE
+# FIXME:
+#SRC_URI += "file://fix_strip.patch"
+SRC_URI += "file://hardcoded-usr.patch"
+
+do_configure_prepend() {
+ # OE still has only ncurses5 with config script called ncurses-config.
+ # mangle ncursesw5-config check to nonsense to prevent access to the host ncursesw5-config
+ sed -i 's/ncurses5-config/ncurses-config/g;s/ncursesw5-config/ncursesw-not-avaliable-in-oe-config/g' configure.in
+}
+# FIXME:
+fakeroot do_install() {
+ oe_runmake "DESTDIR=${D}" install
+}
+CONFFILES_${PN} = "${sysconfdir}/kismet.conf ${sysconfdir}/kismet_drone.conf"
+
+PR = "r0"
+
+SRC_URI[md5sum] = "85e59186eb529889118b5635f35cf57d"
+SRC_URI[sha256sum] = "b1bae7a97e7a904bf620f285aa0d62ebc1fd3b54b671fbca125405036f949e80"