aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/klibc
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-10-27 18:46:05 +0100
committerJeremy Lainé <jeremy.laine@m4x.org>2009-10-27 18:46:05 +0100
commit6f36bd6e28bce49b72e5a3cff77e0c74b8f65e41 (patch)
tree1948ec9ae2e217677a6b985056ebb4d070496b5a /recipes/klibc
parenteeac84ae328fa18770c3724a23ff847f954f60dc (diff)
downloadopenembedded-6f36bd6e28bce49b72e5a3cff77e0c74b8f65e41.tar.gz
klibc-1.5.15: fix build against 2.6.31 linux headers
* apply patches from Ubuntu to build against 2.6.31 linux headers
Diffstat (limited to 'recipes/klibc')
-rw-r--r--recipes/klibc/klibc-1.5.15/mntproc-definitions.patch20
-rw-r--r--recipes/klibc/klibc-1.5.15/signal-cleanup.patch32
-rw-r--r--recipes/klibc/klibc_1.5.15.bb2
-rw-r--r--recipes/klibc/klibc_1.5.15.inc2
4 files changed, 55 insertions, 1 deletions
diff --git a/recipes/klibc/klibc-1.5.15/mntproc-definitions.patch b/recipes/klibc/klibc-1.5.15/mntproc-definitions.patch
new file mode 100644
index 0000000000..eea606be2b
--- /dev/null
+++ b/recipes/klibc/klibc-1.5.15/mntproc-definitions.patch
@@ -0,0 +1,20 @@
+Description: MNTPROC_MNT and MNTPROC_UMNT are no longer defined by the
+ kernel. Hack around this by restoring the old definitions.
+Upstream: http://thread.gmane.org/gmane.linux.nfs/28059 suggests a better
+ fix is in progress.
+
+diff -Nur -x '*.orig' -x '*~' klibc-1.5.15/usr/kinit/nfsmount/mount.c klibc-1.5.15.new/usr/kinit/nfsmount/mount.c
+--- klibc-1.5.15/usr/kinit/nfsmount/mount.c 2009-01-04 19:28:03.000000000 +0000
++++ klibc-1.5.15.new/usr/kinit/nfsmount/mount.c 2009-10-04 22:52:44.000000000 +0100
+@@ -44,6 +44,11 @@
+
+ #define MNT_REPLY_MINSIZE (sizeof(struct rpc_reply) + sizeof(uint32_t))
+
++#ifndef MNTPROC_MNT
++# define MNTPROC_MNT 1
++# define MNTPROC_UMNT 3
++#endif /* MNTPROC_MNT */
++
+ static int get_ports(uint32_t server, const struct nfs_mount_data *data)
+ {
+ uint32_t nfs_ver, mount_ver;
diff --git a/recipes/klibc/klibc-1.5.15/signal-cleanup.patch b/recipes/klibc/klibc-1.5.15/signal-cleanup.patch
new file mode 100644
index 0000000000..fd41f4d7b7
--- /dev/null
+++ b/recipes/klibc/klibc-1.5.15/signal-cleanup.patch
@@ -0,0 +1,32 @@
+Description: Cope with header changes in kernel commit
+ 63b852a6b67d0820d388b0ecd0da83ccb4048b8d.
+
+diff -Nur -x '*.orig' -x '*~' klibc-1.5.15/usr/include/arch/i386/klibc/archsignal.h klibc-1.5.15.new/usr/include/arch/i386/klibc/archsignal.h
+--- klibc-1.5.15/usr/include/arch/i386/klibc/archsignal.h 2009-10-04 23:10:17.000000000 +0100
++++ klibc-1.5.15.new/usr/include/arch/i386/klibc/archsignal.h 2009-10-05 09:35:14.000000000 +0100
+@@ -96,7 +96,7 @@
+ #define MINSIGSTKSZ 2048
+ #define SIGSTKSZ 8192
+
+-#include <asm-generic/signal.h>
++#include <asm-generic/signal-defs.h>
+
+ /* This uses gcc anonymous union support... */
+ struct siginfo;
+diff -Nur -x '*.orig' -x '*~' klibc-1.5.15/usr/include/arch/sparc/klibc/archsignal.h klibc-1.5.15.new/usr/include/arch/sparc/klibc/archsignal.h
+--- klibc-1.5.15/usr/include/arch/sparc/klibc/archsignal.h 2009-01-04 19:28:03.000000000 +0000
++++ klibc-1.5.15.new/usr/include/arch/sparc/klibc/archsignal.h 2009-10-05 09:37:31.000000000 +0100
+@@ -11,13 +11,6 @@
+ #define __WANT_POSIX1B_SIGNALS__
+ #include <asm/signal.h>
+
+-struct sigaction {
+- __sighandler_t sa_handler;
+- unsigned long sa_flags;
+- void (*sa_restorer)(void); /* Not used by Linux/SPARC */
+- sigset_t sa_mask;
+-};
+-
+ /* Not actually used by the kernel... */
+ #define SA_RESTORER 0x80000000
+
diff --git a/recipes/klibc/klibc_1.5.15.bb b/recipes/klibc/klibc_1.5.15.bb
index 13fe8a2499..31c4fbca3d 100644
--- a/recipes/klibc/klibc_1.5.15.bb
+++ b/recipes/klibc/klibc_1.5.15.bb
@@ -1,4 +1,4 @@
require klibc_1.5.15.inc
-PR = "r2"
+PR = "r3"
KLIBC_FETCHDIR = "Testing"
diff --git a/recipes/klibc/klibc_1.5.15.inc b/recipes/klibc/klibc_1.5.15.inc
index 89378b7e7f..f6f5b879ef 100644
--- a/recipes/klibc/klibc_1.5.15.inc
+++ b/recipes/klibc/klibc_1.5.15.inc
@@ -2,6 +2,8 @@ require klibc-common.inc
SRC_URI += "file://staging.patch;patch=1 \
file://klibc_kexecsyscall.patch;patch=1 \
+ file://mntproc-definitions.patch;patch=1 \
+ file://signal-cleanup.patch;patch=1 \
"
# we want only the shared programms and the lib so we chose them manually