summaryrefslogtreecommitdiffstats
path: root/recipes/klibc
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2010-08-16 02:08:32 +0200
committerAndrea Adami <andrea.adami@gmail.com>2010-08-16 02:08:32 +0200
commit0681d2a77bd797afc529dfe854bdd69816a3d4f8 (patch)
treebd48b29b2715aa2c705ef4da87057044e22dd8e7 /recipes/klibc
parent49277f5511d0098229eb2995d31c59ff9fb64869 (diff)
downloadopenembedded-0681d2a77bd797afc529dfe854bdd69816a3d4f8.tar.gz
klibc: bump to 1.5.19
* add getrusage patch * remove version 1.5.18 * staging of klcc is still broken. WIP
Diffstat (limited to 'recipes/klibc')
-rw-r--r--recipes/klibc/klibc-1.5.19/arm-signal-cleanup.patch (renamed from recipes/klibc/klibc-1.5.18/arm-signal-cleanup.patch)0
-rw-r--r--recipes/klibc/klibc-1.5.19/dash_readopt.patch (renamed from recipes/klibc/klibc-1.5.18/dash_readopt.patch)0
-rw-r--r--recipes/klibc/klibc-1.5.19/fstype-sane-vfat-and-jffs2-for-1.5.patch (renamed from recipes/klibc/klibc-1.5.18/fstype-sane-vfat-and-jffs2-for-1.5.patch)0
-rw-r--r--recipes/klibc/klibc-1.5.19/getrusage.patch34
-rw-r--r--recipes/klibc/klibc-1.5.19/isystem.patch (renamed from recipes/klibc/klibc-1.5.18/isystem.patch)0
-rw-r--r--recipes/klibc/klibc-1.5.19/klibc-config-eabi.patch (renamed from recipes/klibc/klibc-1.5.18/klibc-config-eabi.patch)0
-rw-r--r--recipes/klibc/klibc-1.5.19/klibc-x86-KLIBCARCHINCFLAGS.patch (renamed from recipes/klibc/klibc-1.5.18/klibc-x86-KLIBCARCHINCFLAGS.patch)0
-rw-r--r--recipes/klibc/klibc-1.5.19/klibc_kexecsyscall.patch (renamed from recipes/klibc/klibc-1.5.18/klibc_kexecsyscall.patch)0
-rw-r--r--recipes/klibc/klibc-1.5.19/mntproc-definitions.patch (renamed from recipes/klibc/klibc-1.5.18/mntproc-definitions.patch)0
-rw-r--r--recipes/klibc/klibc-1.5.19/modprobe.patch (renamed from recipes/klibc/klibc-1.5.18/modprobe.patch)0
-rw-r--r--recipes/klibc/klibc-1.5.19/socket.h.patch (renamed from recipes/klibc/klibc-1.5.18/socket.h.patch)6
-rw-r--r--recipes/klibc/klibc-1.5.19/staging.patch (renamed from recipes/klibc/klibc-1.5.18/staging.patch)0
-rw-r--r--recipes/klibc/klibc-1.5.19/wc.patch (renamed from recipes/klibc/klibc-1.5.18/wc.patch)0
-rw-r--r--recipes/klibc/klibc-utils-static_1.5.19.bb (renamed from recipes/klibc/klibc-utils-static_1.5.18.bb)4
-rw-r--r--recipes/klibc/klibc.inc3
-rw-r--r--recipes/klibc/klibc_1.5.19.bb (renamed from recipes/klibc/klibc_1.5.18.bb)4
16 files changed, 43 insertions, 8 deletions
diff --git a/recipes/klibc/klibc-1.5.18/arm-signal-cleanup.patch b/recipes/klibc/klibc-1.5.19/arm-signal-cleanup.patch
index b95d6aec95..b95d6aec95 100644
--- a/recipes/klibc/klibc-1.5.18/arm-signal-cleanup.patch
+++ b/recipes/klibc/klibc-1.5.19/arm-signal-cleanup.patch
diff --git a/recipes/klibc/klibc-1.5.18/dash_readopt.patch b/recipes/klibc/klibc-1.5.19/dash_readopt.patch
index 0633417f38..0633417f38 100644
--- a/recipes/klibc/klibc-1.5.18/dash_readopt.patch
+++ b/recipes/klibc/klibc-1.5.19/dash_readopt.patch
diff --git a/recipes/klibc/klibc-1.5.18/fstype-sane-vfat-and-jffs2-for-1.5.patch b/recipes/klibc/klibc-1.5.19/fstype-sane-vfat-and-jffs2-for-1.5.patch
index 041f67988c..041f67988c 100644
--- a/recipes/klibc/klibc-1.5.18/fstype-sane-vfat-and-jffs2-for-1.5.patch
+++ b/recipes/klibc/klibc-1.5.19/fstype-sane-vfat-and-jffs2-for-1.5.patch
diff --git a/recipes/klibc/klibc-1.5.19/getrusage.patch b/recipes/klibc/klibc-1.5.19/getrusage.patch
new file mode 100644
index 0000000000..224ab321d7
--- /dev/null
+++ b/recipes/klibc/klibc-1.5.19/getrusage.patch
@@ -0,0 +1,34 @@
+linux-libc-dev: <linux/resource.h> getrusage() prototype should be protected from user space
+see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=575381
+guard added with 2.6.32
+Index: klibc-1.5.19/usr/include/sys/resource.h
+===================================================================
+--- klibc-1.5.19.old/usr/include/sys/resource.h 2010-07-07 14:07:48.000000000 +0200
++++ klibc-1.5.19/usr/include/sys/resource.h 2010-08-16 01:51:14.000000000 +0200
+@@ -12,6 +12,9 @@
+ __extern int getpriority(int, int);
+ __extern int setpriority(int, int, int);
+
++#include <linux/version.h>
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,32)
+ __extern int getrusage(int, struct rusage *);
++#endif
+
+ #endif /* _SYS_RESOURCE_H */
+Index: klibc-1.5.19/usr/klibc/SYSCALLS.def
+===================================================================
+--- klibc-1.5.19.old/usr/klibc/SYSCALLS.def 2010-08-16 01:49:02.000000000 +0200
++++ klibc-1.5.19/usr/klibc/SYSCALLS.def 2010-08-16 01:55:07.000000000 +0200
+@@ -49,7 +49,12 @@
+ <alpha,ia64> int getpriority(int, int);
+ <!alpha,ia64> int getpriority::__getpriority(int, int);
+ int setpriority(int, int, int);
++
++#include <linux/version.h>
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,32)
+ int getrusage(int, struct rusage *);
++#endif
++
+ int sched_setscheduler(pid_t, int, const struct sched_param *);
+ int sched_yield();
+ <i386> int prctl@varadic(int, unsigned long, unsigned long, unsigned long, unsigned long);
diff --git a/recipes/klibc/klibc-1.5.18/isystem.patch b/recipes/klibc/klibc-1.5.19/isystem.patch
index ccdf9ed92d..ccdf9ed92d 100644
--- a/recipes/klibc/klibc-1.5.18/isystem.patch
+++ b/recipes/klibc/klibc-1.5.19/isystem.patch
diff --git a/recipes/klibc/klibc-1.5.18/klibc-config-eabi.patch b/recipes/klibc/klibc-1.5.19/klibc-config-eabi.patch
index 86517f0594..86517f0594 100644
--- a/recipes/klibc/klibc-1.5.18/klibc-config-eabi.patch
+++ b/recipes/klibc/klibc-1.5.19/klibc-config-eabi.patch
diff --git a/recipes/klibc/klibc-1.5.18/klibc-x86-KLIBCARCHINCFLAGS.patch b/recipes/klibc/klibc-1.5.19/klibc-x86-KLIBCARCHINCFLAGS.patch
index 65de61fa9e..65de61fa9e 100644
--- a/recipes/klibc/klibc-1.5.18/klibc-x86-KLIBCARCHINCFLAGS.patch
+++ b/recipes/klibc/klibc-1.5.19/klibc-x86-KLIBCARCHINCFLAGS.patch
diff --git a/recipes/klibc/klibc-1.5.18/klibc_kexecsyscall.patch b/recipes/klibc/klibc-1.5.19/klibc_kexecsyscall.patch
index 9b2dca4738..9b2dca4738 100644
--- a/recipes/klibc/klibc-1.5.18/klibc_kexecsyscall.patch
+++ b/recipes/klibc/klibc-1.5.19/klibc_kexecsyscall.patch
diff --git a/recipes/klibc/klibc-1.5.18/mntproc-definitions.patch b/recipes/klibc/klibc-1.5.19/mntproc-definitions.patch
index 5db24cd3aa..5db24cd3aa 100644
--- a/recipes/klibc/klibc-1.5.18/mntproc-definitions.patch
+++ b/recipes/klibc/klibc-1.5.19/mntproc-definitions.patch
diff --git a/recipes/klibc/klibc-1.5.18/modprobe.patch b/recipes/klibc/klibc-1.5.19/modprobe.patch
index d89010cc1c..d89010cc1c 100644
--- a/recipes/klibc/klibc-1.5.18/modprobe.patch
+++ b/recipes/klibc/klibc-1.5.19/modprobe.patch
diff --git a/recipes/klibc/klibc-1.5.18/socket.h.patch b/recipes/klibc/klibc-1.5.19/socket.h.patch
index 71c93729d8..864fa2296c 100644
--- a/recipes/klibc/klibc-1.5.18/socket.h.patch
+++ b/recipes/klibc/klibc-1.5.19/socket.h.patch
@@ -63,9 +63,9 @@ Index: klibc-1.5.16/usr/include/sys/socket.h
};
-
+#endif
-
- __extern int socket(int, int, int);
- __extern int bind(int, struct sockaddr *, int);
+ /* Ancillary data structures and cmsg macros are also hidden under __KERNEL__ */
+ #ifndef CMSG_FIRSTHDR
+ /*
Index: klibc-1.5.16/usr/kinit/nfsmount/nfsmount.h
===================================================================
--- a/usr/kinit/nfsmount/nfsmount.h 2009-01-04 20:28:03.000000000 +0100
diff --git a/recipes/klibc/klibc-1.5.18/staging.patch b/recipes/klibc/klibc-1.5.19/staging.patch
index 9418c6b764..9418c6b764 100644
--- a/recipes/klibc/klibc-1.5.18/staging.patch
+++ b/recipes/klibc/klibc-1.5.19/staging.patch
diff --git a/recipes/klibc/klibc-1.5.18/wc.patch b/recipes/klibc/klibc-1.5.19/wc.patch
index 9063a5a1c3..9063a5a1c3 100644
--- a/recipes/klibc/klibc-1.5.18/wc.patch
+++ b/recipes/klibc/klibc-1.5.19/wc.patch
diff --git a/recipes/klibc/klibc-utils-static_1.5.18.bb b/recipes/klibc/klibc-utils-static_1.5.19.bb
index 2b6494d960..beb62b258a 100644
--- a/recipes/klibc/klibc-utils-static_1.5.18.bb
+++ b/recipes/klibc/klibc-utils-static_1.5.19.bb
@@ -16,5 +16,5 @@ KLIBC_UTILS_PKGNAME = "klibc-utils-static"
require klibc-utils.inc
require klibc.inc
-SRC_URI[md5sum] = "5c8b6577b9acb3809cace6e118cdd55b"
-SRC_URI[sha256sum] = "e4104f8b34a5f354222bd4622f50b58c6218bf70614450d68539cbef666b6446"
+SRC_URI[md5sum] = "1b713fe65c345e687666b9f94b12f0a0"
+SRC_URI[sha256sum] = "de0fa51d47b7363e064a3e6f26dabcb458d371a14e78e6407d49bb3386a24a97"
diff --git a/recipes/klibc/klibc.inc b/recipes/klibc/klibc.inc
index fc8862c3bb..c0e08b2703 100644
--- a/recipes/klibc/klibc.inc
+++ b/recipes/klibc/klibc.inc
@@ -6,7 +6,7 @@ minimal entaglement, and portability, not speed."
LICENSE = "BSD-ADV"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-INC_PR = "r18"
+INC_PR = "r0"
KLIBC_ARCH = '${TARGET_ARCH}'
KLIBC_ARCH_armeb = 'arm'
@@ -38,6 +38,7 @@ SRC_URI += "file://fstype-sane-vfat-and-jffs2-for-1.5.patch \
file://socket.h.patch \
file://isystem.patch \
file://klibc-x86-KLIBCARCHINCFLAGS.patch \
+ file://getrusage.patch \
"
S = "${WORKDIR}/klibc-${PV}"
diff --git a/recipes/klibc/klibc_1.5.18.bb b/recipes/klibc/klibc_1.5.19.bb
index 880ed74763..98075c46a2 100644
--- a/recipes/klibc/klibc_1.5.18.bb
+++ b/recipes/klibc/klibc_1.5.19.bb
@@ -60,5 +60,5 @@ RDEPENDS_${KLIBC_UTILS_PKGNAME}-wc = "${PN} (=${PV}-${PR})"
require klibc-utils.inc
require klibc.inc
-SRC_URI[md5sum] = "5c8b6577b9acb3809cace6e118cdd55b"
-SRC_URI[sha256sum] = "e4104f8b34a5f354222bd4622f50b58c6218bf70614450d68539cbef666b6446"
+SRC_URI[md5sum] = "1b713fe65c345e687666b9f94b12f0a0"
+SRC_URI[sha256sum] = "de0fa51d47b7363e064a3e6f26dabcb458d371a14e78e6407d49bb3386a24a97"