summaryrefslogtreecommitdiffstats
path: root/recipes/klimt
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/klimt
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/klimt')
-rw-r--r--recipes/klimt/klimt_0.6.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/klimt/klimt_0.6.1.bb b/recipes/klimt/klimt_0.6.1.bb
new file mode 100644
index 0000000000..4e516fc90d
--- /dev/null
+++ b/recipes/klimt/klimt_0.6.1.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Klimt is a software OpenGL rendering library for Qt/Embedded based Palmtop Environments"
+SECTION = "opie/libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/klimt/klimt-src-${PV}.zip"
+S = "${WORKDIR}/klimt/build/LinuxQTE"
+
+EXTRA_QMAKEVARS_POST += " QMAKE_CXXFLAGS+=-fpermissive"
+
+inherit opie
+
+do_stage() {
+ oe_libinstall -so libKlimt ${STAGING_LIBDIR}/
+ cp -pPR ${S}/../../include/* ${STAGING_INCDIR}/
+}
+
+do_install() {
+ oe_libinstall -so libKlimt ${D}${palmtopdir}/lib
+}