aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/knights/knights_1.14.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/knights/knights_1.14.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/knights/knights_1.14.bb')
-rw-r--r--recipes/knights/knights_1.14.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/knights/knights_1.14.bb b/recipes/knights/knights_1.14.bb
new file mode 100644
index 0000000000..dc3e026376
--- /dev/null
+++ b/recipes/knights/knights_1.14.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Chess Game for Qt/Embedded based palmtop environments. \
+Uses the Phalanx chess engine."
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "phalanx"
+RDEPENDS = "phalanx"
+PR = "r2"
+
+SRC_URI = "http://www.openzaurus.org/mirror/knights.tar.gz \
+ file://libqpe-opie.patch;patch=1 \
+ file://gcc3.patch;patch=1"
+S = "${WORKDIR}/knights"
+
+inherit palmtop
+
+QMAKE_PROFILES = "knights.pro"
+
+do_configure_prepend() {
+ printf "TEMPLATE=subdirs\nSUBDIRS=qtcompat microkde knights\n" >knights.pro
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Games \
+ ${D}${palmtopdir}/pics
+ install -D -m 755 knights/knights ${D}${palmtopdir}/bin/knights
+ install -D -m 644 knights.desktop ${D}${palmtopdir}/apps/Games/knights.desktop
+ install -d ${D}${palmtopdir}/pics
+ cp -pPR pics/knights ${D}${palmtopdir}/pics/
+}