aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/knights
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/knights
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/knights')
-rw-r--r--recipes/knights/knights-1.14/gcc3.patch16
-rw-r--r--recipes/knights/knights-1.14/libqpe-opie.patch26
-rw-r--r--recipes/knights/knights_1.14.bb31
3 files changed, 73 insertions, 0 deletions
diff --git a/recipes/knights/knights-1.14/gcc3.patch b/recipes/knights/knights-1.14/gcc3.patch
new file mode 100644
index 0000000000..be6a06562c
--- /dev/null
+++ b/recipes/knights/knights-1.14/gcc3.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- knights/knights/knights.cpp~gcc3 2002-09-01 14:06:29.000000000 +0200
++++ knights/knights/knights.cpp 2004-01-16 00:30:04.000000000 +0100
+@@ -24,7 +24,7 @@
+ #include <qpe/qpeapplication.h>
+ #include <qpe/applnk.h>
+ #include "aboutdialog.h"
+-Knights::Knights(QWidget *parent, const char *name, const QString &args="") : QMainWindow(parent, name)
++Knights::Knights(QWidget *parent, const char *name, const QString &args) : QMainWindow(parent, name)
+ {
+ setCaption("Knights");
+ InitAll = TRUE;
diff --git a/recipes/knights/knights-1.14/libqpe-opie.patch b/recipes/knights/knights-1.14/libqpe-opie.patch
new file mode 100644
index 0000000000..ca47227732
--- /dev/null
+++ b/recipes/knights/knights-1.14/libqpe-opie.patch
@@ -0,0 +1,26 @@
+--- knights/knights/core.cpp~knights-opie 2002-09-01 12:02:49.000000000 +0200
++++ knights/knights/core.cpp 2003-06-24 14:38:11.000000000 +0200
+@@ -24,9 +24,8 @@
+ #include <qmessagebox.h>
+ #include <qpe/fileselector.h>
+ #include "core.h"
+-#include "qinputdialog.h"
++#include <qtcompat/qinputdialog.h>
+ #include <unistd.h>
+-#include "qinputdialog.h"
+
+ ///////////////////////////////////////
+ //
+@@ -864,9 +863,9 @@
+ if (fileSelectorDialog->exec()==QDialog::Accepted)
+ {
+
+- const DocLnk *d = selector->selected();
+- load(*d);
+- delete d;
++ // const DocLnk *d = selector->selected();
++ // load(*d);
++ // delete d;
+ }
+ delete fileSelectorDialog;
+
diff --git a/recipes/knights/knights_1.14.bb b/recipes/knights/knights_1.14.bb
new file mode 100644
index 0000000000..dc3e026376
--- /dev/null
+++ b/recipes/knights/knights_1.14.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Chess Game for Qt/Embedded based palmtop environments. \
+Uses the Phalanx chess engine."
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "phalanx"
+RDEPENDS = "phalanx"
+PR = "r2"
+
+SRC_URI = "http://www.openzaurus.org/mirror/knights.tar.gz \
+ file://libqpe-opie.patch;patch=1 \
+ file://gcc3.patch;patch=1"
+S = "${WORKDIR}/knights"
+
+inherit palmtop
+
+QMAKE_PROFILES = "knights.pro"
+
+do_configure_prepend() {
+ printf "TEMPLATE=subdirs\nSUBDIRS=qtcompat microkde knights\n" >knights.pro
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Games \
+ ${D}${palmtopdir}/pics
+ install -D -m 755 knights/knights ${D}${palmtopdir}/bin/knights
+ install -D -m 644 knights.desktop ${D}${palmtopdir}/apps/Games/knights.desktop
+ install -d ${D}${palmtopdir}/pics
+ cp -pPR pics/knights ${D}${palmtopdir}/pics/
+}