summaryrefslogtreecommitdiffstats
path: root/recipes/kobodeluxe/kobodeluxe_0.5.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/kobodeluxe/kobodeluxe_0.5.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/kobodeluxe/kobodeluxe_0.5.1.bb')
-rw-r--r--recipes/kobodeluxe/kobodeluxe_0.5.1.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/recipes/kobodeluxe/kobodeluxe_0.5.1.bb b/recipes/kobodeluxe/kobodeluxe_0.5.1.bb
new file mode 100644
index 0000000000..e94f03b628
--- /dev/null
+++ b/recipes/kobodeluxe/kobodeluxe_0.5.1.bb
@@ -0,0 +1,55 @@
+DESCRIPTION = "Fast-paced 2D top-down shooter where you have to destroy space station"
+SECTION = "games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+AUTHOR = "David Olofson <david@olofson.net>"
+HOMEPAGE = "http://olofson.net/kobodl"
+
+PR = "r5"
+
+DEPENDS = "libsdl-image virtual/libsdl"
+
+RDEPENDS_${PN} = "${PN}-data"
+
+SRC_URI = "http://olofson.net/kobodl/download/KoboDeluxe-${PV}.tar.bz2 \
+ file://fighter-48.xpm \
+ file://debian-kobo.patch;patch=1 \
+ file://kobodeluxe-putenv.patch;patch=1 \
+ file://kobodeluxe-sysconf-support.patch;patch=1 \
+ file://kobodeluxe-menu-pointer.patch;patch=1 \
+ file://kobodeluxe-dimension-autoswap.patch;patch=1 \
+ file://default-config \
+ "
+
+S = "${WORKDIR}/KoboDeluxe-${PV}"
+
+inherit autotools sdl
+
+APPIMAGE = "${WORKDIR}/fighter-48.xpm"
+APPNAME = "kobodl"
+
+EXTRA_OECONF = "--disable-opengl --disable-sdltest --enable-touchscreen"
+
+export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
+
+do_configure_prepend() {
+ sed -i \
+ -e "s|width WIDTH_HERE|width ${MACHINE_DISPLAY_WIDTH_PIXELS}|" \
+ -e "s|height HEIGHT_HERE|height ${MACHINE_DISPLAY_HEIGHT_PIXELS}|" \
+ ${WORKDIR}/default-config
+}
+
+do_install_append() {
+ # Provide a default (working) configuration file
+ install -d ${D}${sysconfdir}/kobo-deluxe
+ install -m 755 ${WORKDIR}/default-config ${D}${sysconfdir}/kobo-deluxe
+}
+
+PACKAGES += "${PN}-data"
+
+FILES_${PN} += "${sysconfdir}"
+CONFFILES_${PN} = "${sysconfdir}/kobo-deluxe/default-config"
+
+FILES_${PN}-data = "${datadir}"
+
+PACKAGE_ARCH_${PN}-data = "all"