summaryrefslogtreecommitdiffstats
path: root/recipes/krb
diff options
context:
space:
mode:
authorTim 'timtim' Ellis <tim.ellis@foonas.org>2009-05-17 21:50:09 +0100
committerTim 'timtim' Ellis <tim.ellis@foonas.org>2009-05-17 21:50:09 +0100
commit3edb5ad048d14852989f885ba03b8bb9f47e01c1 (patch)
treeff07a1f1fae1d3cef3fadcb1bafe674a24bda8ea /recipes/krb
parentd3db0654a6051ad4b9bd67623a2c9e5186b045ef (diff)
downloadopenembedded-3edb5ad048d14852989f885ba03b8bb9f47e01c1.tar.gz
krb5: Force cp to work due to an permissions issue
Diffstat (limited to 'recipes/krb')
-rw-r--r--recipes/krb/files/copyperms.patch12
-rw-r--r--recipes/krb/krb5_1.6.3.bb6
2 files changed, 16 insertions, 2 deletions
diff --git a/recipes/krb/files/copyperms.patch b/recipes/krb/files/copyperms.patch
new file mode 100644
index 0000000000..b0abb72cf0
--- /dev/null
+++ b/recipes/krb/files/copyperms.patch
@@ -0,0 +1,12 @@
+diff -urN src.old/config/pre.in src/config/pre.in
+--- src.old/config/pre.in 2006-10-15 19:19:28.000000000 +0100
++++ src/config/pre.in 2009-05-17 21:28:54.000000000 +0100
+@@ -258,7 +258,7 @@
+ transform = @program_transform_name@
+
+ RM = rm -f
+-CP = cp
++CP = cp -f
+ MV = mv -f
+ CHMOD=chmod
+ RANLIB = @RANLIB@
diff --git a/recipes/krb/krb5_1.6.3.bb b/recipes/krb/krb5_1.6.3.bb
index 5fc75b4c7e..a1694b2d5c 100644
--- a/recipes/krb/krb5_1.6.3.bb
+++ b/recipes/krb/krb5_1.6.3.bb
@@ -1,14 +1,15 @@
DESCRIPTION = "A network authentication protocol"
HOMEPAGE = "http://web.mit.edu/Kerberos/"
SECTION = "console/network"
-PR = "r5"
+PR = "r6"
LICENSE = "MIT"
DEPENDS = "perl-native ncurses e2fsprogs-libs"
inherit autotools binconfig
SRC_URI = "http://web.mit.edu/kerberos/dist/krb5/1.6/krb5-1.6.3-signed.tar \
- file://fix-uclibc-ruserpass-collision.patch"
+ file://fix-uclibc-ruserpass-collision.patch \
+ file://copyperms.patch"
S = "${WORKDIR}/${PN}-${PV}/src/"
# Will clean this up...
@@ -23,6 +24,7 @@ FILES_${PN}-doc += /usr/share/examples
krb5_do_unpack() {
tar xzf ${WORKDIR}/krb5-1.6.3.tar.gz -C ${WORKDIR}/
patch -d ${S} -p1 < ${WORKDIR}/fix-uclibc-ruserpass-collision.patch
+ patch -d ${S} -p1 < ${WORKDIR}/copyperms.patch
}
python do_unpack() {