summaryrefslogtreecommitdiffstats
path: root/recipes/lame
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-11-04 22:58:41 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-11-04 22:58:41 +0000
commita74f86eab3b1482e3528c6ec61edde8f68f34917 (patch)
treea904d179dffb67475c86057a561b458a4ce97e99 /recipes/lame
parente0e13253cda40005f5f24bb09db68b66636d2924 (diff)
downloadopenembedded-a74f86eab3b1482e3528c6ec61edde8f68f34917.tar.gz
lame: Fix possible linking QA error.
Diffstat (limited to 'recipes/lame')
-rw-r--r--recipes/lame/lame/ldflags-qa.patch43
-rw-r--r--recipes/lame/lame_3.96.1.bb5
2 files changed, 46 insertions, 2 deletions
diff --git a/recipes/lame/lame/ldflags-qa.patch b/recipes/lame/lame/ldflags-qa.patch
new file mode 100644
index 0000000000..b92f9ca0cd
--- /dev/null
+++ b/recipes/lame/lame/ldflags-qa.patch
@@ -0,0 +1,43 @@
+https://sourceforge.net/tracker/?func=detail&aid=2892273&group_id=290&atid=300290
+
+Depending on configure arguments libmp3lame may be built only as a
+shared library. But lame frntends link command using this library
+has -static.
+
+Such clash may cause ugly libtool behavior.
+
+In context of lame, linking should probably respect configure flags
+and link frontend dynamically if shared linking is enabled.
+
+As a consequence of bug in libtool, this combination
+with --disable-static may create incorrect binary. For more see:
+http://lists.gnu.org/archive/html/bug-libtool/2009-11/msg00004.html
+
+Signed-off-by: Stanislav Brabec <utx@penguin.cz>
+
+Index: lame-3.96.1/frontend/Makefile.am
+===================================================================
+--- lame-3.96.1.orig/frontend/Makefile.am
++++ lame-3.96.1/frontend/Makefile.am
+@@ -50,7 +50,7 @@ mp3x__EXEEXT__SOURCES = mp3x.c gtkanal.c
+ endif
+
+ CFLAGS = @CFLAGS@ @GTK_CFLAGS@ @FRONTEND_CFLAGS@
+-LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@ -static
++LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@
+
+ INCLUDES = -I$(top_srcdir)/libmp3lame -I$(top_srcdir)/include -I$(top_builddir)
+
+Index: lame-3.96.1/frontend/Makefile.in
+===================================================================
+--- lame-3.96.1.orig/frontend/Makefile.in
++++ lame-3.96.1/frontend/Makefile.in
+@@ -91,7 +91,7 @@ LDADD = @LDADD@ \
+ $(top_builddir)/libmp3lame/libmp3lame.la \
+ @FRONTEND_LDADD@
+
+-LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@ -static
++LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@
+ LIBOBJS = @LIBOBJS@
+ LIBS = @LIBS@
+ LIBTOOL = @LIBTOOL@
diff --git a/recipes/lame/lame_3.96.1.bb b/recipes/lame/lame_3.96.1.bb
index ab9a99c064..9507032307 100644
--- a/recipes/lame/lame_3.96.1.bb
+++ b/recipes/lame/lame_3.96.1.bb
@@ -1,11 +1,12 @@
SECTION = "console/utils"
DESCRIPTION = "Not an MP3 encoder"
LICENSE = "LGPL"
-PR = "r4"
+PR = "r5"
SRC_URI = "${SOURCEFORGE_MIRROR}/lame/lame-${PV}.tar.gz \
file://no-gtk1.patch;patch=1 \
- file://Makefile-lm.patch;patch=1"
+ file://Makefile-lm.patch;patch=1 \
+ file://ldflags-qa.patch;patch=1"
inherit autotools