aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/latencytop/latencytop/cc-var.patch
diff options
context:
space:
mode:
authorBen Gardiner <bengardiner@nanometrics.ca>2010-05-31 05:48:24 +0000
committerEric Bénard <eric@eukrea.com>2010-10-04 22:58:14 +0200
commit72816b2be90da3c04c06106f190c2f3657a4f6cf (patch)
tree12b2f7b230792cf08e9b32dd281eab6ec47d21f0 /recipes/latencytop/latencytop/cc-var.patch
parent51f101e880c388e0f7bdf876930e1f3749b2dae0 (diff)
downloadopenembedded-72816b2be90da3c04c06106f190c2f3657a4f6cf.tar.gz
latencytop: add version 0.5
Add a new recipe to for latencytop. * patch the makefile to disable GTK support, use the LDFLAGS and use ncurses instead of the 'w' variant. Signed-off-by: Ben Gardiner <bengardiner@nanometrics.ca> Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'recipes/latencytop/latencytop/cc-var.patch')
-rw-r--r--recipes/latencytop/latencytop/cc-var.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/latencytop/latencytop/cc-var.patch b/recipes/latencytop/latencytop/cc-var.patch
new file mode 100644
index 0000000000..70b9ebbd66
--- /dev/null
+++ b/recipes/latencytop/latencytop/cc-var.patch
@@ -0,0 +1,15 @@
+--- latencytop-0.5/Makefile.orig 2010-05-27 16:45:23.051146454 -0400
++++ latencytop-0.5/Makefile 2010-05-27 16:49:14.660573483 -0400
+@@ -23,10 +23,10 @@ endif
+
+ # We write explicity this "implicit rule"
+ %.o : %.c
+- gcc -c $(CFLAGS) $(XCFLAGS) $< -o $@
++ $(CC) -c $(CFLAGS) $(XCFLAGS) $< -o $@
+
+ latencytop: $(OBJS) latencytop.h Makefile
+- gcc $(CFLAGS) $(OBJS) $(LDF) -o latencytop
++ $(CC) $(CFLAGS) $(OBJS) $(LDF) -o latencytop
+
+ clean:
+ rm -f *~ latencytop DEADJOE *.o