aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libaal/libaal_1.0.4.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libaal/libaal_1.0.4.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libaal/libaal_1.0.4.bb')
-rw-r--r--recipes/libaal/libaal_1.0.4.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/libaal/libaal_1.0.4.bb b/recipes/libaal/libaal_1.0.4.bb
new file mode 100644
index 0000000000..af847f50c6
--- /dev/null
+++ b/recipes/libaal/libaal_1.0.4.bb
@@ -0,0 +1,24 @@
+# This is the support library for reiser4progs, required when
+# building that package. The libraries from this build must
+# be installed on the system to use the reiser4progs programs
+PR = "r1"
+DESCRIPTION = "Library for user-level code accessing Reiser4 filesystems"
+HOMEPAGE = "http://www.namesys.com"
+SECTION = "base"
+LICENSE = "GPLv2"
+
+SRC_URI = "ftp://ftp.namesys.com/pub/reiser4progs/old-versions/${P}.tar.gz"
+
+inherit autotools
+
+# This disables anything which uses libminimal - that library
+# is used for boot loader stuff and so is not required unless
+# the system will boot from a Reiser4 file system, the same
+# setting must exist for the reiser4progs build
+DISABLE_LIBMINIMAL ?= "--disable-libminimal"
+EXTRA_OECONF = "${DISABLE_LIBMINIMAL}"
+
+do_stage() {
+ echo "NOTE: stage package ${PF} is: (${PN},${PV},${PR})"
+ autotools_stage_all
+}