aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libacpi
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2009-11-15 03:52:44 +0300
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2009-11-15 03:52:44 +0300
commit02676a9fbb22dfe78f45132392315736e351d187 (patch)
tree8d9b85ea742cfbfbc5bbfa4cbd8f28ed6e46bfde /recipes/libacpi
parent5d8c04d65c3335f7e440bea4bee690dce0422997 (diff)
downloadopenembedded-02676a9fbb22dfe78f45132392315736e351d187.tar.gz
libacpi: steal from Poky
Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'recipes/libacpi')
-rw-r--r--recipes/libacpi/files/makefile-fix.patch45
-rw-r--r--recipes/libacpi/libacpi_0.2.bb24
2 files changed, 69 insertions, 0 deletions
diff --git a/recipes/libacpi/files/makefile-fix.patch b/recipes/libacpi/files/makefile-fix.patch
new file mode 100644
index 0000000000..9193929767
--- /dev/null
+++ b/recipes/libacpi/files/makefile-fix.patch
@@ -0,0 +1,45 @@
+---
+ Makefile | 6 +++---
+ config.mk | 3 ++-
+ 2 files changed, 5 insertions(+), 4 deletions(-)
+
+Index: libacpi-0.2/Makefile
+===================================================================
+--- libacpi-0.2.orig/Makefile 2007-07-29 14:09:34.000000000 +0200
++++ libacpi-0.2/Makefile 2008-09-26 10:34:53.000000000 +0200
+@@ -25,16 +25,16 @@ ${OBJ}: config.mk libacpi.h
+
+ libacpi.a: ${OBJ}
+ @echo AR $@
+- @${AR} $@ ${OBJ}
++ ${AR} ${ARFLAGS} $@ ${OBJ}
+ @${RANLIB} $@
+
+ libacpi.so: ${OBJ}
+ @echo LD $@
+- @${LD} ${SOFLAGS} -o $@.${SOVERSION} ${OBJ}
++ @${CC} ${SOFLAGS} -o $@.${SOVERSION} ${OBJ}
+
+ test-libacpi: ${OBJ_test}
+ @echo LD $@
+- @${LD} -o $@ ${OBJ_test} ${LDFLAGS}
++ @${CC} -o $@ ${OBJ_test} ${LDFLAGS}
+ @strip $@
+
+ install: all
+Index: libacpi-0.2/config.mk
+===================================================================
+--- libacpi-0.2.orig/config.mk 2007-07-29 14:09:34.000000000 +0200
++++ libacpi-0.2/config.mk 2008-09-26 10:34:33.000000000 +0200
+@@ -9,9 +9,10 @@ MANPREFIX = ${PREFIX}/share/man
+ # flags
+ SOFLAGS = -shared -Wl,-soname,${SONAME}
+ CFLAGS += -fPIC -g --pedantic -Wall -Wextra
++ARFLAGS = cr
+
+ # Compiler and linker
+ CC = cc
+ LD = ${CC}
+-AR = ar cr
++AR = ar
+ RANLIB = ranlib
diff --git a/recipes/libacpi/libacpi_0.2.bb b/recipes/libacpi/libacpi_0.2.bb
new file mode 100644
index 0000000000..f3990306b1
--- /dev/null
+++ b/recipes/libacpi/libacpi_0.2.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "ACPI data gathering library."
+SECTION = "base"
+HOMEPAGE = "http://www.ngolde.de/libacpi.html"
+LICENSE = "MIT"
+PR = "r1"
+
+SRC_URI = "http://www.ngolde.de/download/libacpi-${PV}.tar.gz \
+ file://makefile-fix.patch;patch=1 "
+
+PACKAGES += "${PN}-bin"
+
+FILES_${PN} = "${libdir}/libacpi.so.*"
+FILES_${PN}-bin = "${bindir}"
+
+COMPATIBLE_HOST = '(x86_64|i.86.*)-(linux|freebsd.*)'
+
+do_stage() {
+ install -m 0644 libacpi.h ${STAGING_INCDIR}
+ oe_libinstall -so libacpi ${STAGING_LIBDIR}
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D} PREFIX=${exec_prefix}
+}