summaryrefslogtreecommitdiffstats
path: root/recipes/libc-client/libc-client_2007b.bb
diff options
context:
space:
mode:
authorGraeme Gregory <gg@slimlogic.co.uk>2009-12-10 13:00:18 -0700
committerGraeme Gregory <dp@xora.org.uk>2009-12-10 20:12:06 +0000
commit80de94f8a7d3ef4ac6493cfb67b2e0f519d74f46 (patch)
tree899e142acec4a44f6609887b34c9d7250bbb0e5a /recipes/libc-client/libc-client_2007b.bb
parente4eafe3dd1444305b2998c7ac0006596de4e831b (diff)
downloadopenembedded-80de94f8a7d3ef4ac6493cfb67b2e0f519d74f46.tar.gz
libc-client_2007b.bb : move to newer version converted to new staging
I picked this version as being the same one debian uses. The old version hasnt compiled for a long time anyway due to misbalanced quotes so I removed it. Updated the DEPENDS line for some missing ones
Diffstat (limited to 'recipes/libc-client/libc-client_2007b.bb')
-rw-r--r--recipes/libc-client/libc-client_2007b.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/libc-client/libc-client_2007b.bb b/recipes/libc-client/libc-client_2007b.bb
new file mode 100644
index 0000000000..bacc910a13
--- /dev/null
+++ b/recipes/libc-client/libc-client_2007b.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "UW c-client library for mail protocols"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "University of Washingtons Free-Fork License"
+DEPENDS = "libpam openssl libpam"
+
+SRC_URI = "ftp://ftp.cac.washington.edu/imap/imap-${PV}.tar.Z \
+ file://quote_cctype.patch;patch=1"
+
+S = "${WORKDIR}/imap-${PV}"
+
+EXTRA_OEMAKE = "CC='${CC}'"
+
+HEADERS = "src/c-client/*.h src/osdep/unix/*.h c-client/auths.c c-client/linkage.c c-client/linkage.h c-client/osdep.h"
+
+do_compile() {
+ echo "SSLINCLUDE=${STAGING_INCDIR}/openssl SSLLIB=${STAGING_LIBDIR}" > ${S}/SPECIALS
+ oe_runmake lnp
+}
+
+do_install() {
+ install -d ${D}${includedir}/c-client
+ install ${HEADERS} ${D}${includedir}/c-client
+ install -d ${D}${libdir}
+ install c-client/c-client.a ${D}${libdir}/libc-client.a
+}
+