aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libcap
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2011-01-14 09:41:56 +0000
committerKhem Raj <raj.khem@gmail.com>2011-01-15 15:45:29 -0800
commit9086784ba8e85b92bdf65355d9de58dc29a71958 (patch)
tree0143a7cd6a0b07da4e639fc2aa83f1e386acf25f /recipes/libcap
parent53f46652f6ec25d9ed66ffcdf1afb8764e7ad35c (diff)
downloadopenembedded-9086784ba8e85b92bdf65355d9de58dc29a71958.tar.gz
libcap2: fix build with and without libpam
* Add libpam to depends if DISTRO_FEATURES contains pam. * Fixes the following compile error, when libpam-dev is installed on the host, but not built for the target: pam_cap.c:19:34: error: security/pam_modules.h: No such file or directory pam_cap.c:20:34: error: security/_pam_macros.h: No such file or directory Signed-off-by: Andreas Oberritter <obi@opendreambox.org> CC: Frans Meulenbroeks <fransmeulenbroeks@gmail.com> CC: Otavio Salvador <otavio@ossystems.com.br> CC: Tom Rini <tom_rini@mentor.com> CC: Khem Raj <raj.khem@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/libcap')
-rw-r--r--recipes/libcap/libcap2-2.16/make.patch18
-rw-r--r--recipes/libcap/libcap2_2.16.bb6
2 files changed, 18 insertions, 6 deletions
diff --git a/recipes/libcap/libcap2-2.16/make.patch b/recipes/libcap/libcap2-2.16/make.patch
index 3672f77c63..b8508e4a63 100644
--- a/recipes/libcap/libcap2-2.16/make.patch
+++ b/recipes/libcap/libcap2-2.16/make.patch
@@ -1,6 +1,8 @@
---- libcap-2.16/Make.Rules.orig 2009-03-07 18:50:23.000000000 +0100
-+++ libcap-2.16/Make.Rules 2009-03-07 18:50:44.000000000 +0100
-@@ -45,19 +45,12 @@
+Index: libcap-2.16/Make.Rules
+===================================================================
+--- libcap-2.16.orig/Make.Rules 2008-12-04 08:03:30.000000000 +0100
++++ libcap-2.16/Make.Rules 2011-01-13 22:51:04.568844000 +0100
+@@ -45,25 +45,18 @@
KERNEL_HEADERS := $(topdir)/libcap/include
IPATH += -I$(topdir)/libcap/include -I$(KERNEL_HEADERS)
@@ -19,5 +21,13 @@
-LD=$(CC) -Wl,-x -shared
-LDFLAGS := #-g
- SYSTEM_HEADERS = /usr/include
+-SYSTEM_HEADERS = /usr/include
++SYSTEM_HEADERS ?= /usr/include
INCS=$(topdir)/libcap/include/sys/capability.h
+ LDFLAGS += -L$(topdir)/libcap
+ CFLAGS += -Dlinux $(WARNINGS) $(DEBUG) $(IPATH)
+-PAM_CAP := $(shell if [ -f /usr/include/security/pam_modules.h ]; then echo yes ; else echo no ; fi)
++PAM_CAP := $(shell if [ -f $(SYSTEM_HEADERS)/security/pam_modules.h ]; then echo yes ; else echo no ; fi)
+ INDENT := $(shell if [ -n "$(which indent 2>/dev/null)" ]; then echo "| indent -kr" ; fi)
+ DYNAMIC := $(shell if [ ! -d "$(topdir)/.git" ]; then echo yes; fi)
+ LIBATTR := yes
diff --git a/recipes/libcap/libcap2_2.16.bb b/recipes/libcap/libcap2_2.16.bb
index 97b03d5621..beb45f2234 100644
--- a/recipes/libcap/libcap2_2.16.bb
+++ b/recipes/libcap/libcap2_2.16.bb
@@ -2,8 +2,8 @@ DESCRIPTION = "Libcap is a library for getting and setting POSIX.1e (formerly PO
PRIORITY = "optional"
SECTION = "libs"
LICENSE = "GPL"
-DEPENDS = "bison-native flex-native attr"
-PR = "r2"
+DEPENDS = "bison-native flex-native attr ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
+PR = "r3"
BUILD_CFLAGS += "-I${S}/libcap/include"
CFLAGS += "-I${S}/libcap/include"
@@ -15,6 +15,8 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/libs/security/linux-privs/libcap2/libca
S = "${WORKDIR}/libcap-${PV}"
+EXTRA_OEMAKE = "SYSTEM_HEADERS=${STAGING_INCDIR}"
+
do_install() {
install -d ${D}${includedir}/sys
install -m 0644 libcap/include/sys/capability.h ${D}${includedir}/sys/