aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libcwd
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libcwd
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libcwd')
-rw-r--r--recipes/libcwd/libcwd_0.99.47.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/libcwd/libcwd_0.99.47.bb b/recipes/libcwd/libcwd_0.99.47.bb
new file mode 100644
index 0000000000..38453c89e5
--- /dev/null
+++ b/recipes/libcwd/libcwd_0.99.47.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Libcwd is a thread-safe, full-featured debugging support library for C++ developers. \
+It includes ostream-based debug output with custom debug channels and devices, \
+powerful memory allocation debugging support, as well as run-time support for \
+printing source line number information and demangled type names."
+SECTION = "devel/libs"
+LICENSE = "QPL"
+HOMEPAGE = "http://libcwd.sourceforge.net"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libcwd/libcwd-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+PARALLEL_MAKE = ""
+
+PACKAGES =+ "${PN}-config ${PN}-mt"
+FILES_${PN} = "${libdir}/libcwd.so*"
+FILES_${PN}-mt = "${libdir}/libcwd_r.so*"
+FILES_${PN}-config = "${datadir}"
+RRECOMMENDS_${PN} = "${PN}-config"
+RRECOMMENDS_${PN}-mt = "${PN}-config"