aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libdbi
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2009-07-30 17:18:07 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-07-30 17:42:58 +0200
commit838abf1993f474976515aa9d7bbb709a6d4044d2 (patch)
treed18de355c947d8b9932bfd7bc2dd68fa55ffabfc /recipes/libdbi
parentc5322a7b31c6dffbd58881ae830b5598977e9f05 (diff)
downloadopenembedded-838abf1993f474976515aa9d7bbb709a6d4044d2.tar.gz
libdbi: Introduce libdbi 0.8.2
Diffstat (limited to 'recipes/libdbi')
-rw-r--r--recipes/libdbi/libdbi.inc22
-rw-r--r--recipes/libdbi/libdbi_0.7.2.bb23
-rw-r--r--recipes/libdbi/libdbi_0.8.2.bb1
3 files changed, 24 insertions, 22 deletions
diff --git a/recipes/libdbi/libdbi.inc b/recipes/libdbi/libdbi.inc
new file mode 100644
index 0000000000..9d533d94b0
--- /dev/null
+++ b/recipes/libdbi/libdbi.inc
@@ -0,0 +1,22 @@
+# libdbi OE build file
+# Copyright (C) 2005, Koninklijke Philips Electronics NV. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Database Independent Abstraction Layer for C"
+HOMEPAGE = "http://libdbi.sourceforge.net/"
+LICENSE = "LGPL"
+SECTION = "libs"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libdbi/libdbi-${PV}.tar.gz"
+
+inherit autotools
+
+do_stage () {
+ autotools_stage_includes
+ cd ./src/.libs/
+ oe_libinstall -so libdbi ${STAGING_LIBDIR}
+}
+
+do_configure () {
+ autotools_do_configure
+}
diff --git a/recipes/libdbi/libdbi_0.7.2.bb b/recipes/libdbi/libdbi_0.7.2.bb
index 8737890368..bd54419686 100644
--- a/recipes/libdbi/libdbi_0.7.2.bb
+++ b/recipes/libdbi/libdbi_0.7.2.bb
@@ -1,22 +1 @@
-# libdbi OE build file
-# Copyright (C) 2005, Koninklijke Philips Electronics NV. All Rights Reserved
-# Released under the MIT license (see packages/COPYING)
-
-DESCRIPTION = "Database Independent Abstraction Layer for C"
-HOMEPAGE = "http://libdbi.sourceforge.net/"
-LICENSE = "LGPL"
-SECTION = "libs"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/libdbi/libdbi-${PV}.tar.gz"
-
-inherit autotools
-
-do_stage () {
- autotools_stage_includes
- cd ./src/.libs/
- oe_libinstall -so libdbi ${STAGING_LIBDIR}
-}
-
-do_configure () {
- autotools_do_configure
-} \ No newline at end of file
+require ${PN}.inc
diff --git a/recipes/libdbi/libdbi_0.8.2.bb b/recipes/libdbi/libdbi_0.8.2.bb
new file mode 100644
index 0000000000..bd54419686
--- /dev/null
+++ b/recipes/libdbi/libdbi_0.8.2.bb
@@ -0,0 +1 @@
+require ${PN}.inc