aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libdca
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2011-02-04 01:15:53 +0000
committerAndreas Oberritter <obi@opendreambox.org>2011-02-11 12:43:24 +0000
commit7ae30cf534a60ccab84be5314b77e6656a7eecc2 (patch)
treef4f93696544f7b705e95ec89f7bc188521f3cf3c /recipes/libdca
parent98ceb8ba471f5ac0c9630eddc80471dcba6ef458 (diff)
downloadopenembedded-7ae30cf534a60ccab84be5314b77e6656a7eecc2.tar.gz
libdca-0.0.5-3: initial recipe (Debian)
Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Diffstat (limited to 'recipes/libdca')
-rw-r--r--recipes/libdca/libdca_0.0.5-3.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/libdca/libdca_0.0.5-3.bb b/recipes/libdca/libdca_0.0.5-3.bb
new file mode 100644
index 0000000000..5bc023a5b4
--- /dev/null
+++ b/recipes/libdca/libdca_0.0.5-3.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "decoding library for DTS Coherent Acoustics streams"
+SECTION = "libs/multimedia"
+LICENSE = "GPLv2+"
+
+SRC_URI = "git://git.debian.org/pkg-multimedia/${PN}.git;protocol=git"
+
+SRCREV = "6031938c28a2e66eed6f2b9bac1467364e25068d"
+S = "${WORKDIR}/git"
+
+inherit autotools lib_package pkgconfig
+
+do_unpackpost() {
+ QUILT_PATCHES=debian/patches quilt push -a
+ # single precision is enough and speeds up libdca by about 10-15%
+ sed -i -e 's/double/sample_t/g' ${S}/libdca/*.{ch}
+}
+
+addtask unpackpost after do_unpack before do_patch