aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libedit/libedit_20050118.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libedit/libedit_20050118.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libedit/libedit_20050118.bb')
-rw-r--r--recipes/libedit/libedit_20050118.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes/libedit/libedit_20050118.bb b/recipes/libedit/libedit_20050118.bb
new file mode 100644
index 0000000000..eee231a22a
--- /dev/null
+++ b/recipes/libedit/libedit_20050118.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "BSD replacement for libreadline"
+HOMEPAGE = "http://cvsweb.netbsd.org/bsdweb.cgi/src/lib/libedit/"
+SECTION = "libs"
+LICENSE="BSD"
+DEPENDS = "ncurses"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.linux.ee/pub/gentoo/distfiles/distfiles/libedit-${PV}.tar.bz2 \
+ file://20031222-debian-to-gentoo.patch;patch=1;pnum=1 \
+ file://libedit-add-soname.diff;patch=1;pnum=0"
+
+S = "${WORKDIR}/netbsd-cvs"
+
+CFLAGS += "-I. -include ../glibc-bsd-glue/bsdcompat.h -I../glibc-compat -I../glibc-bsd-glue"
+
+do_configure() {
+ mv ${WORKDIR}/glibc-*/*.c .
+ oe_runmake .depend
+}
+
+do_compile() {
+ oe_runmake LIBS="-lncurses ${LDFLAGS}"
+}
+
+do_stage() {
+ oe_libinstall -a -so libedit ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/editline/
+ install readline/readline.h ${STAGING_INCDIR}/editline/
+ install histedit.h ${STAGING_INCDIR}/editline/
+}
+
+do_install() {
+ install -d ${D}${libdir} ${D}${includedir}/editline ${D}${mandir}
+ oe_libinstall -a -so libedit ${D}${libdir}
+ install readline/readline.h ${D}${includedir}/editline/
+ install histedit.h ${D}${includedir}/editline/
+ install *.[35] ${D}${mandir}
+}
+
+FILES_${PN} = "${libdir}/libedit.so"