aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libelf
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libelf
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libelf')
-rw-r--r--recipes/libelf/libelf_0.8.3.bb33
-rw-r--r--recipes/libelf/libelf_0.8.6.bb32
2 files changed, 65 insertions, 0 deletions
diff --git a/recipes/libelf/libelf_0.8.3.bb b/recipes/libelf/libelf_0.8.3.bb
new file mode 100644
index 0000000000..65e3e66628
--- /dev/null
+++ b/recipes/libelf/libelf_0.8.3.bb
@@ -0,0 +1,33 @@
+SECTION = "libs"
+DESCRIPTION = "an ELF object file access library \
+The elf library provides routines to access, and manipulate, Elf object \
+files. It is still not complete, but is required for a number of programs, \
+such as Eli (a state of the art compiler generation system), and Elk (the \
+Extension Language Kit - an implementation of the Scheme programming \
+language.)"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.mr511.de/software/libelf-${PV}.tar.gz"
+
+inherit autotools
+
+do_configure_prepend () {
+ if test ! -e acinclude.m4; then
+ cp aclocal.m4 acinclude.m4
+ fi
+}
+
+do_install () {
+ oe_runmake 'prefix=${D}${prefix}' 'exec_prefix=${D}${exec_prefix}' \
+ 'libdir=${D}${libdir}' 'includedir=${D}${includedir}' \
+ install
+}
+
+do_stage () {
+ oe_libinstall -so -C lib libelf ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/libelf
+ for i in libelf.h nlist.h gelf.h sys_elf.h; do
+ install -m 0644 lib/$i ${STAGING_INCDIR}/libelf/
+ done
+ make includedir=${STAGING_INCDIR} install-compat
+}
diff --git a/recipes/libelf/libelf_0.8.6.bb b/recipes/libelf/libelf_0.8.6.bb
new file mode 100644
index 0000000000..4bd548e600
--- /dev/null
+++ b/recipes/libelf/libelf_0.8.6.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "libelf is an ELF object file access library. \
+The elf library provides routines to access, and manipulate, Elf object files."
+LICENSE = "LGPL"
+SECTION = "libs"
+
+SRC_URI = "http://www.mr511.de/software/libelf-${PV}.tar.gz \
+ http://www.stud.uni-hannover.de/~michael/software/libelf-${PV}.tar.gz"
+
+inherit autotools
+
+PARALLEL_MAKE = ""
+
+do_configure_prepend () {
+ if test ! -e acinclude.m4; then
+ cp aclocal.m4 acinclude.m4
+ fi
+}
+
+do_install () {
+ oe_runmake 'prefix=${D}${prefix}' 'exec_prefix=${D}${exec_prefix}' \
+ 'libdir=${D}${libdir}' 'includedir=${D}${includedir}' \
+ install
+}
+
+do_stage () {
+ oe_libinstall -so -C lib libelf ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/libelf
+ for i in libelf.h nlist.h gelf.h sys_elf.h; do
+ install -m 0644 lib/$i ${STAGING_INCDIR}/libelf/
+ done
+ make includedir=${STAGING_INCDIR} install-compat
+}