aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libfakekey
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libfakekey
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libfakekey')
-rw-r--r--recipes/libfakekey/files/configure-fix.patch10
-rw-r--r--recipes/libfakekey/libfakekey_svn.bb19
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes/libfakekey/files/configure-fix.patch b/recipes/libfakekey/files/configure-fix.patch
new file mode 100644
index 0000000000..9a40622c4f
--- /dev/null
+++ b/recipes/libfakekey/files/configure-fix.patch
@@ -0,0 +1,10 @@
+--- /tmp/configure.ac 2008-06-02 17:13:41.006467345 +0200
++++ libfakekey/configure.ac 2008-06-02 17:13:55.109795271 +0200
+@@ -19,6 +19,7 @@
+ AC_SUBST(LT_CURRENT)
+ AC_SUBST(LT_REVISION)
+ LT_AGE=0
++AC_SUBST(LT_AGE)
+
+ LT_VERSION_INFO="$LT_CURRENT:$LT_REVISION:$LT_AGE"
+ AC_SUBST(LT_VERSION_INFO)
diff --git a/recipes/libfakekey/libfakekey_svn.bb b/recipes/libfakekey/libfakekey_svn.bb
new file mode 100644
index 0000000000..946080cf33
--- /dev/null
+++ b/recipes/libfakekey/libfakekey_svn.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Matchbox keyboard"
+LICENSE = "GPL"
+DEPENDS = "libxtst"
+SECTION = "x11/wm"
+PV = "0.2+svnr${SRCREV}"
+PR = "r1"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
+ file://configure-fix.patch;patch=1"
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools pkgconfig gettext
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/fakekey
+ install -m 0644 ${S}/fakekey/fakekey.h ${STAGING_INCDIR}/fakekey
+ oe_libinstall -so -C src libfakekey ${STAGING_LIBDIR}
+}