aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libgcrypt
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libgcrypt
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libgcrypt')
-rw-r--r--recipes/libgcrypt/files/add-pkgconfig-support.patch62
-rw-r--r--recipes/libgcrypt/libgcrypt-1.4.0/add-pkgconfig-support.patch49
-rw-r--r--recipes/libgcrypt/libgcrypt-1.4.1/add-pkgconfig-support.patch49
-rw-r--r--recipes/libgcrypt/libgcrypt.inc24
-rw-r--r--recipes/libgcrypt/libgcrypt_1.1.91.bb33
-rw-r--r--recipes/libgcrypt/libgcrypt_1.2.4.bb3
-rw-r--r--recipes/libgcrypt/libgcrypt_1.4.0.bb3
-rw-r--r--recipes/libgcrypt/libgcrypt_1.4.1.bb2
8 files changed, 225 insertions, 0 deletions
diff --git a/recipes/libgcrypt/files/add-pkgconfig-support.patch b/recipes/libgcrypt/files/add-pkgconfig-support.patch
new file mode 100644
index 0000000000..9b00e8262a
--- /dev/null
+++ b/recipes/libgcrypt/files/add-pkgconfig-support.patch
@@ -0,0 +1,62 @@
+diff -Nur libgcrypt-1.2.4/configure.ac libgcrypt11-1.2.4/configure.ac
+--- libgcrypt-1.2.4/configure.ac 2007-02-01 19:41:06.000000000 +0100
++++ libgcrypt11-1.2.4/configure.ac 2007-02-11 13:05:36.000000000 +0100
+@@ -808,6 +808,7 @@
+ src/Makefile
+ src/gcrypt.h
+ src/libgcrypt-config
++src/libgcrypt.pc
+ tests/Makefile
+ w32-dll/Makefile
+ ])
+diff -Nur libgcrypt-1.2.4/src/libgcrypt.pc.in libgcrypt11-1.2.4/src/libgcrypt.pc.in
+--- libgcrypt-1.2.4/src/libgcrypt.pc.in 1970-01-01 01:00:00.000000000 +0100
++++ libgcrypt11-1.2.4/src/libgcrypt.pc.in 2007-02-11 13:03:30.000000000 +0100
+@@ -0,0 +1,32 @@
++# Process this file with autoconf to produce a pkg-config metadata file.
++# Copyright (C) 2002, 2003, 2004, 2005, 2006 Free Software Foundation
++# Author: Simon Josefsson
++#
++# This file is free software; as a special exception the author gives
++# unlimited permission to copy and/or distribute it, with or without
++# modifications, as long as this notice is preserved.
++#
++# This file is distributed in the hope that it will be useful, but
++# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
++# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
++
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++# API info
++api_version=@LIBGCRYPT_CONFIG_API_VERSION@
++
++# Misc information.
++symmetric_ciphers=@LIBGCRYPT_CIPHERS@
++asymmetric_ciphers=@LIBGCRYPT_PUBKEY_CIPHERS@
++digests=@LIBGCRYPT_DIGESTS@
++
++Name: libgcrypt
++Description: GNU crypto library
++URL: http://www.gnupg.org
++Version: @VERSION@
++Libs: -L${libdir} @LIBGCRYPT_CONFIG_LIBS@
++Libs.private: @GPG_ERROR_LIBS@
++Cflags: -I${includedir} @LIBGCRYPT_CONFIG_CFLAGS@ @GPG_ERROR_CFLAGS@
+diff -Nur libgcrypt-1.2.4/src/Makefile.am libgcrypt11-1.2.4/src/Makefile.am
+--- libgcrypt-1.2.4/src/Makefile.am 2006-11-30 16:38:18.000000000 +0100
++++ libgcrypt11-1.2.4/src/Makefile.am 2007-02-11 13:10:03.000000000 +0100
+@@ -27,6 +27,11 @@
+
+ lib_LTLIBRARIES = libgcrypt.la
+
++# Pkg-config script.
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = libgcrypt.pc
++DISTCLEANFILES = $(pkgconfig_DATA)
++
+ if HAVE_LD_VERSION_SCRIPT
+ libgcrypt_version_script_cmd = -Wl,--version-script=$(srcdir)/libgcrypt.vers
+ else
diff --git a/recipes/libgcrypt/libgcrypt-1.4.0/add-pkgconfig-support.patch b/recipes/libgcrypt/libgcrypt-1.4.0/add-pkgconfig-support.patch
new file mode 100644
index 0000000000..a4e5a65d65
--- /dev/null
+++ b/recipes/libgcrypt/libgcrypt-1.4.0/add-pkgconfig-support.patch
@@ -0,0 +1,49 @@
+Index: libgcrypt-1.4.0/configure.ac
+===================================================================
+--- libgcrypt-1.4.0.orig/configure.ac
++++ libgcrypt-1.4.0/configure.ac
+@@ -1072,6 +1072,7 @@ cipher/Makefile
+ doc/Makefile
+ src/Makefile
+ src/gcrypt.h
++src/libgcrypt.pc
+ src/libgcrypt-config
+ src/versioninfo.rc
+ tests/Makefile
+Index: libgcrypt-1.4.0/src/libgcrypt.pc.in
+===================================================================
+--- /dev/null
++++ libgcrypt-1.4.0/src/libgcrypt.pc.in
+@@ -0,0 +1,32 @@
++# Process this file with autoconf to produce a pkg-config metadata file.
++# Copyright (C) 2002, 2003, 2004, 2005, 2006 Free Software Foundation
++# Author: Simon Josefsson
++#
++# This file is free software; as a special exception the author gives
++# unlimited permission to copy and/or distribute it, with or without
++# modifications, as long as this notice is preserved.
++#
++# This file is distributed in the hope that it will be useful, but
++# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
++# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
++
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++# API info
++api_version=@LIBGCRYPT_CONFIG_API_VERSION@
++
++# Misc information.
++symmetric_ciphers=@LIBGCRYPT_CIPHERS@
++asymmetric_ciphers=@LIBGCRYPT_PUBKEY_CIPHERS@
++digests=@LIBGCRYPT_DIGESTS@
++
++Name: libgcrypt
++Description: GNU crypto library
++URL: http://www.gnupg.org
++Version: @VERSION@
++Libs: -L${libdir} -lgcrypt
++Libs.private: -L${libdir} -lgpg-error
++Cflags: -I${includedir}
diff --git a/recipes/libgcrypt/libgcrypt-1.4.1/add-pkgconfig-support.patch b/recipes/libgcrypt/libgcrypt-1.4.1/add-pkgconfig-support.patch
new file mode 100644
index 0000000000..a4e5a65d65
--- /dev/null
+++ b/recipes/libgcrypt/libgcrypt-1.4.1/add-pkgconfig-support.patch
@@ -0,0 +1,49 @@
+Index: libgcrypt-1.4.0/configure.ac
+===================================================================
+--- libgcrypt-1.4.0.orig/configure.ac
++++ libgcrypt-1.4.0/configure.ac
+@@ -1072,6 +1072,7 @@ cipher/Makefile
+ doc/Makefile
+ src/Makefile
+ src/gcrypt.h
++src/libgcrypt.pc
+ src/libgcrypt-config
+ src/versioninfo.rc
+ tests/Makefile
+Index: libgcrypt-1.4.0/src/libgcrypt.pc.in
+===================================================================
+--- /dev/null
++++ libgcrypt-1.4.0/src/libgcrypt.pc.in
+@@ -0,0 +1,32 @@
++# Process this file with autoconf to produce a pkg-config metadata file.
++# Copyright (C) 2002, 2003, 2004, 2005, 2006 Free Software Foundation
++# Author: Simon Josefsson
++#
++# This file is free software; as a special exception the author gives
++# unlimited permission to copy and/or distribute it, with or without
++# modifications, as long as this notice is preserved.
++#
++# This file is distributed in the hope that it will be useful, but
++# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
++# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
++
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++# API info
++api_version=@LIBGCRYPT_CONFIG_API_VERSION@
++
++# Misc information.
++symmetric_ciphers=@LIBGCRYPT_CIPHERS@
++asymmetric_ciphers=@LIBGCRYPT_PUBKEY_CIPHERS@
++digests=@LIBGCRYPT_DIGESTS@
++
++Name: libgcrypt
++Description: GNU crypto library
++URL: http://www.gnupg.org
++Version: @VERSION@
++Libs: -L${libdir} -lgcrypt
++Libs.private: -L${libdir} -lgpg-error
++Cflags: -I${includedir}
diff --git a/recipes/libgcrypt/libgcrypt.inc b/recipes/libgcrypt/libgcrypt.inc
new file mode 100644
index 0000000000..691f4fe133
--- /dev/null
+++ b/recipes/libgcrypt/libgcrypt.inc
@@ -0,0 +1,24 @@
+DESCRIPTION = "A general purpose cryptographic library based on the code from GnuPG"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+DEPENDS = "libgpg-error"
+
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-${PV}.tar.gz \
+ file://add-pkgconfig-support.patch;patch=1"
+
+inherit autotools binconfig pkgconfig lib_package
+
+EXTRA_OECONF = "--without-pth --disable-asm --with-capabilities"
+
+ARM_INSTRUCTION_SET = "arm"
+
+do_install_append() {
+ install -d ${D}/${libdir}/pkgconfig/
+ cp ${S}/src/*.pc ${D}/${libdir}/pkgconfig/
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/libgcrypt/libgcrypt_1.1.91.bb b/recipes/libgcrypt/libgcrypt_1.1.91.bb
new file mode 100644
index 0000000000..0eaeaaf9fc
--- /dev/null
+++ b/recipes/libgcrypt/libgcrypt_1.1.91.bb
@@ -0,0 +1,33 @@
+PR = "r3"
+DESCRIPTION = "A general purpose cryptographic library based on the code from GnuPG"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+DEPENDS = "libgpg-error"
+
+PACKAGES =+ "libgcrypt-pthread libgcrypt-pthread-dev"
+
+# move libgcrypt-config into -dev package
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}"
+FILES_libgcrypt-pthread = "${libdir}/libgcrypt-pthread.so.*"
+FILES_libgcrypt-pthread-dev = "${libdir}/libgcrypt-pthread.*"
+
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/alpha/libgcrypt/libgcrypt-${PV}.tar.gz"
+
+inherit autotools binconfig
+
+EXTRA_OECONF = "--without-pth"
+
+do_stage() {
+ oe_libinstall -so -C src libgcrypt ${STAGING_LIBDIR}
+ oe_libinstall -so -C src libgcrypt-pthread ${STAGING_LIBDIR}
+ install -m 0755 src/libgcrypt-config ${STAGING_BINDIR_CROSS}/
+
+ install -d ${STAGING_INCDIR}/
+ for X in gcrypt.h gcrypt-module.h
+ do
+ install -m 0644 src/${X} ${STAGING_INCDIR}/${X}
+ done
+
+}
diff --git a/recipes/libgcrypt/libgcrypt_1.2.4.bb b/recipes/libgcrypt/libgcrypt_1.2.4.bb
new file mode 100644
index 0000000000..2fe98d62e3
--- /dev/null
+++ b/recipes/libgcrypt/libgcrypt_1.2.4.bb
@@ -0,0 +1,3 @@
+require libgcrypt.inc
+
+PR = "r2"
diff --git a/recipes/libgcrypt/libgcrypt_1.4.0.bb b/recipes/libgcrypt/libgcrypt_1.4.0.bb
new file mode 100644
index 0000000000..db3389b80e
--- /dev/null
+++ b/recipes/libgcrypt/libgcrypt_1.4.0.bb
@@ -0,0 +1,3 @@
+require libgcrypt.inc
+
+PR = "r3"
diff --git a/recipes/libgcrypt/libgcrypt_1.4.1.bb b/recipes/libgcrypt/libgcrypt_1.4.1.bb
new file mode 100644
index 0000000000..c0b5e6531c
--- /dev/null
+++ b/recipes/libgcrypt/libgcrypt_1.4.1.bb
@@ -0,0 +1,2 @@
+require libgcrypt.inc
+