aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libgee
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-10-10 02:00:31 -0700
committerKhem Raj <raj.khem@gmail.com>2010-10-10 02:00:31 -0700
commit88cb8237bcad77fc2a64a1e84b6be63c94ce8b58 (patch)
tree8d75c1f011d03e5538eee54bf25b269c6bdca6e7 /recipes/libgee
parent2f2ec0b55e6dc6881431b9a4911fa8aedc6d3325 (diff)
downloadopenembedded-88cb8237bcad77fc2a64a1e84b6be63c94ce8b58.tar.gz
libgee_0.5.2.bb/libgee_0.6.0.bb: Fix native recipe build
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/libgee')
-rw-r--r--recipes/libgee/libgee.inc9
-rw-r--r--recipes/libgee/libgee_0.5.2.bb7
-rw-r--r--recipes/libgee/libgee_0.6.0.bb5
3 files changed, 8 insertions, 13 deletions
diff --git a/recipes/libgee/libgee.inc b/recipes/libgee/libgee.inc
index 208e4e9c80..918f45b0a5 100644
--- a/recipes/libgee/libgee.inc
+++ b/recipes/libgee/libgee.inc
@@ -2,10 +2,15 @@ DESCRIPTION = "libgee is a collection library providing GObject-based interfaces
and classes for commonly used data structures."
HOMEPAGE = "http://live.gnome.org/Libgee"
SECTION = "libs"
-DEPENDS = "glib-2.0"
+DEPENDS = "glib-2.0 gobject-introspection"
BBCLASSEXTEND = "native"
-DEPENDS_virtclass-native = "glib-2.0-native"
LICENSE = "LGPL"
PE = "1"
inherit autotools vala
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
diff --git a/recipes/libgee/libgee_0.5.2.bb b/recipes/libgee/libgee_0.5.2.bb
index 364711d1ab..5c9462085f 100644
--- a/recipes/libgee/libgee_0.5.2.bb
+++ b/recipes/libgee/libgee_0.5.2.bb
@@ -6,10 +6,3 @@ S = "${WORKDIR}/${BPN}-${PV}"
SRC_URI[md5sum] = "fc5a36eb5f61154a1456cbb8b1798e41"
SRC_URI[sha256sum] = "8625ebfb479600046b9e36e1a8fd1142d624645dce66a6cd8c9067d8f7f5ce51"
-
-inherit autotools vala
-
-do_configure() {
- gnu-configize
- oe_runconf
-}
diff --git a/recipes/libgee/libgee_0.6.0.bb b/recipes/libgee/libgee_0.6.0.bb
index e499ed4b45..41bfce133b 100644
--- a/recipes/libgee/libgee_0.6.0.bb
+++ b/recipes/libgee/libgee_0.6.0.bb
@@ -1,12 +1,9 @@
require libgee.inc
-DEPENDS = "gobject-introspection-native"
PE = "1"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgee/0.6/${BPN}-${PV}.tar.bz2"
S = "${WORKDIR}/${BPN}-${PV}"
SRC_URI[md5sum] = "4eb513b23ab6ea78884989518a4acf6f"
SRC_URI[sha256sum] = "e586678d0a88637abeaaf850b62231000772e79ea6d9c4b45dc3cea99f778a7a"
-
-inherit autotools vala