summaryrefslogtreecommitdiffstats
path: root/recipes/libgpelaunch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libgpelaunch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libgpelaunch')
-rw-r--r--recipes/libgpelaunch/libgpelaunch_0.14.bb16
-rw-r--r--recipes/libgpelaunch/libgpelaunch_svn.bb20
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes/libgpelaunch/libgpelaunch_0.14.bb b/recipes/libgpelaunch/libgpelaunch_0.14.bb
new file mode 100644
index 0000000000..24ee20a1c6
--- /dev/null
+++ b/recipes/libgpelaunch/libgpelaunch_0.14.bb
@@ -0,0 +1,16 @@
+LICENSE = "LGPL"
+DESCRIPTION = "GPE program launcher library"
+SECTION = "libs"
+DEPENDS = "gtk+ startup-notification"
+PR = "r1"
+
+inherit autotools pkgconfig
+
+SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.bz2"
+
+
+FILES_${PN}-dbg += "/usr/libexec/libgpelaunch/.debug"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/libgpelaunch/libgpelaunch_svn.bb b/recipes/libgpelaunch/libgpelaunch_svn.bb
new file mode 100644
index 0000000000..c7c3c8e83e
--- /dev/null
+++ b/recipes/libgpelaunch/libgpelaunch_svn.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "GPE program launcher library"
+SECTION = "libs"
+LICENSE = "LGPL"
+DEPENDS = "gtk+ startup-notification"
+PV = "0.14+svn${SRCDATE}"
+PR = "r0"
+
+inherit autotools pkgconfig
+
+SRC_URI = "${GPE_SVN}"
+
+S = "${WORKDIR}/${PN}"
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN}-dbg += "${libexecdir}/libgpelaunch/.debug"
+
+DEFAULT_PREFERENCE = "-1"