aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libgpg-error/libgpg-error_0.6.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libgpg-error/libgpg-error_0.6.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libgpg-error/libgpg-error_0.6.bb')
-rw-r--r--recipes/libgpg-error/libgpg-error_0.6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/libgpg-error/libgpg-error_0.6.bb b/recipes/libgpg-error/libgpg-error_0.6.bb
new file mode 100644
index 0000000000..4929121167
--- /dev/null
+++ b/recipes/libgpg-error/libgpg-error_0.6.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "GPG-Error library"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/alpha/libgpg-error/libgpg-error-${PV}.tar.gz"
+
+inherit autotools binconfig
+
+do_stage() {
+ oe_libinstall -so -C src libgpg-error ${STAGING_LIBDIR}
+ install -d ${STAGING_BINDIR_CROSS}/
+ install -m 0755 src/gpg-error-config ${STAGING_BINDIR_CROSS}/
+
+ install -d ${STAGING_INCDIR}/
+ for X in gpg-error.h
+ do
+ install -m 0644 src/${X} ${STAGING_INCDIR}/${X}
+ done
+
+}