aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libgpod
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-03-25 13:36:41 +0100
committerKoen Kooi <koen@openembedded.org>2010-03-25 17:19:35 +0100
commitf58f17398a6f1fd27b867ed950d8f2d6960031e6 (patch)
tree2f174d5ec22eaf088406f22ec32c3610225c2bd4 /recipes/libgpod
parente46db08d8b07104d1e38f12d500491b4cd3ce683 (diff)
downloadopenembedded-f58f17398a6f1fd27b867ed950d8f2d6960031e6.tar.gz
libplist: add 1.2
Diffstat (limited to 'recipes/libgpod')
-rw-r--r--recipes/libgpod/libplist_1.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/libgpod/libplist_1.2.bb b/recipes/libgpod/libplist_1.2.bb
new file mode 100644
index 0000000000..6acefe5ff7
--- /dev/null
+++ b/recipes/libgpod/libplist_1.2.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "A library to handle Apple Property List format whereas it's binary or XML"
+LICENSE = "GPLv2/LGPLv2.1"
+
+DEPENDS = "libxml2 glib-2.0 swig python"
+
+inherit cmake pkgconfig
+
+SRC_URI = "http://github.com/downloads/JonathanBeck/libplist/libplist-${PV}.tar.bz2;name=archive"
+SRC_URI[archive.md5sum] = "a29e98e51977253f09a912c942f37a68"
+SRC_URI[archive.sha256sum] = "e8223809af55283188e8a1adfe97a59655c788f6d3048a7624f648d007f87558"
+
+LIBV = "0.10"
+
+python populate_packages_prepend () {
+ glibdir = bb.data.expand('${libdir}', d)
+ do_split_packages(d, glibdir, '^lib(.*)\.so\.*', 'lib%s', 'libplist %s library', extra_depends='', allow_links=True)
+}
+
+FILES_${PN} = "${libdir}/${PN}.so.*"
+PACKAGES =+ "${PN}-utils"
+FILES_${PN}-utils = "${bindir}/*"
+