summaryrefslogtreecommitdiffstats
path: root/recipes/libgtkstylus
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libgtkstylus
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libgtkstylus')
-rw-r--r--recipes/libgtkstylus/files/gtkstylus.sh5
-rw-r--r--recipes/libgtkstylus/files/makefile.patch11
-rw-r--r--recipes/libgtkstylus/libgtkstylus_0.1.bb17
-rw-r--r--recipes/libgtkstylus/libgtkstylus_0.3.bb19
-rw-r--r--recipes/libgtkstylus/libgtkstylus_svn.bb21
5 files changed, 73 insertions, 0 deletions
diff --git a/recipes/libgtkstylus/files/gtkstylus.sh b/recipes/libgtkstylus/files/gtkstylus.sh
new file mode 100644
index 0000000000..b1302ede0e
--- /dev/null
+++ b/recipes/libgtkstylus/files/gtkstylus.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+GTK_MODULES=libgtkstylus.so
+
+export GTK_MODULES
diff --git a/recipes/libgtkstylus/files/makefile.patch b/recipes/libgtkstylus/files/makefile.patch
new file mode 100644
index 0000000000..fadea69023
--- /dev/null
+++ b/recipes/libgtkstylus/files/makefile.patch
@@ -0,0 +1,11 @@
+--- libgtkstylus-0.3/Makefile.am.old 2005-01-16 15:56:07.000000000 +0000
++++ libgtkstylus-0.3/Makefile.am 2005-01-16 15:56:08.000000000 +0000
+@@ -3,7 +3,7 @@
+ module_LTLIBRARIES = libgtkstylus.la
+
+ INCLUDES = @STYLUS_CFLAGS@
+-LDADD = @STYLUS_LIBS@
++LIBS = @STYLUS_LIBS@
+
+ libgtkstylus_la_SOURCES = tap.c
+
diff --git a/recipes/libgtkstylus/libgtkstylus_0.1.bb b/recipes/libgtkstylus/libgtkstylus_0.1.bb
new file mode 100644
index 0000000000..cc624a4684
--- /dev/null
+++ b/recipes/libgtkstylus/libgtkstylus_0.1.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "GTK plugin for stylus based systems"
+SECTION = "libs"
+DEPENDS = "gtk+"
+PR = "r1"
+LICENSE = "LGPL"
+FILES_${PN} = "/etc ${libdir}/gtk-2.0"
+
+inherit autotools
+
+SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.bz2 \
+ file://gtkstylus.sh"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/profile.d
+ install ${WORKDIR}/gtkstylus.sh ${D}${sysconfdir}/profile.d/
+}
+
diff --git a/recipes/libgtkstylus/libgtkstylus_0.3.bb b/recipes/libgtkstylus/libgtkstylus_0.3.bb
new file mode 100644
index 0000000000..e19a8a9f26
--- /dev/null
+++ b/recipes/libgtkstylus/libgtkstylus_0.3.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "GTK plugin for stylus based systems"
+SECTION = "libs"
+DEPENDS = "gtk+"
+LICENSE = "LGPL"
+PR = "r5"
+
+inherit autotools
+
+SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.bz2 \
+ file://makefile.patch;patch=1 \
+ file://gtkstylus.sh"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/X11/Xsession.d
+ install -m 755 ${WORKDIR}/gtkstylus.sh ${D}/${sysconfdir}/X11/Xsession.d/45gtkstylus
+}
+
+FILES_${PN} = "/etc ${libdir}/gtk-2.0/*/modules/*.so*"
+
diff --git a/recipes/libgtkstylus/libgtkstylus_svn.bb b/recipes/libgtkstylus/libgtkstylus_svn.bb
new file mode 100644
index 0000000000..33122345a7
--- /dev/null
+++ b/recipes/libgtkstylus/libgtkstylus_svn.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "GTK plugin for stylus based systems"
+SECTION = "libs"
+LICENSE = "LGPL"
+DEPENDS = "gtk+"
+PV = "0.3+svn${SRCDATE}"
+PR = "r5"
+
+inherit autotools
+
+SRC_URI = "${GPE_SVN}"
+
+S = "${WORKDIR}/${PN}"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/X11/Xsession.d
+ install -m 755 ${S}/gtkstylus.sh ${D}/${sysconfdir}/X11/Xsession.d/45gtkstylus
+}
+
+FILES_${PN} = "/etc ${libdir}/gtk-2.0/*/modules/*.so*"
+
+DEFAULT_PREFERENCE = "-1"