aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libiconv/libiconv_1.11.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libiconv/libiconv_1.11.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libiconv/libiconv_1.11.bb')
-rw-r--r--recipes/libiconv/libiconv_1.11.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/libiconv/libiconv_1.11.bb b/recipes/libiconv/libiconv_1.11.bb
new file mode 100644
index 0000000000..de87486a87
--- /dev/null
+++ b/recipes/libiconv/libiconv_1.11.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "GNU libiconv - libiconv is for you if your application needs to support \
+multiple character encodings, but that support lacks from your system."
+HOMEPAGE = "http://www.gnu.org/software/libiconv"
+SECTION = "libs"
+PRIORITY = "optional"
+NOTES = "Needs to be stripped down to: ascii iso8859-1 eucjp iso-2022jp gb utf8"
+PROVIDES = "virtual/libiconv"
+PR = "r4"
+LICENSE = "LGPL"
+SRC_URI = "ftp://ftp.gnu.org/pub/gnu/libiconv/libiconv-${PV}.tar.gz"
+
+S = "${WORKDIR}/libiconv-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--enable-shared --enable-static --enable-relocatable"
+
+do_configure () {
+ rm -f m4/libtool.m4 libcharset/m4/libtool.m4
+ autotools_do_configure
+
+ # As we do not really regenerate the Makefiles... and they have stale deps to this file
+ touch m4/libtool.m4
+
+ # Fix stupid libtool... handling. rpath handling can't be disabled and the Makefile's can't be regenerated..
+ # (GNU sed required)
+ sed -i s/^hardcode_libdir_flag_spec/#hardcode_libdir_flag_spec/ ${S}/*-libtool
+}
+
+do_stage () {
+ oe_libinstall -so -a -C lib libiconv ${STAGING_LIBDIR}
+ oe_libinstall -so -C lib libiconv_plug_linux ${STAGING_LIBDIR}
+ oe_libinstall -so -a -C libcharset/lib libcharset ${STAGING_LIBDIR}
+ autotools_stage_includes
+}