aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libid3tag
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libid3tag
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libid3tag')
-rw-r--r--recipes/libid3tag/files/id3tag.pc11
-rw-r--r--recipes/libid3tag/libid3tag_0.15.1b.bb23
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes/libid3tag/files/id3tag.pc b/recipes/libid3tag/files/id3tag.pc
new file mode 100644
index 0000000000..e686000689
--- /dev/null
+++ b/recipes/libid3tag/files/id3tag.pc
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: id3tag
+Description: ID3 tag reading library
+Requires:
+Version: 0.15.0b
+Libs: -L${libdir} -lid3tag -lz
+Cflags: -I${includedir}
diff --git a/recipes/libid3tag/libid3tag_0.15.1b.bb b/recipes/libid3tag/libid3tag_0.15.1b.bb
new file mode 100644
index 0000000000..c9f4a0c0ba
--- /dev/null
+++ b/recipes/libid3tag/libid3tag_0.15.1b.bb
@@ -0,0 +1,23 @@
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "zlib"
+DESCRIPTION = "Library for interacting with ID3 tags."
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.mars.org/pub/mpeg/libid3tag-${PV}.tar.gz \
+ file://id3tag.pc"
+
+S = "${WORKDIR}/libid3tag-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "-enable-speed"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/id3tag.pc ${S}
+}
+do_stage() {
+ oe_libinstall -so libid3tag ${STAGING_LIBDIR}
+ install -m 0644 id3tag.h ${STAGING_INCDIR}
+}