aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libnet/libnet_1.1.2.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libnet/libnet_1.1.2.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libnet/libnet_1.1.2.1.bb')
-rw-r--r--recipes/libnet/libnet_1.1.2.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes/libnet/libnet_1.1.2.1.bb b/recipes/libnet/libnet_1.1.2.1.bb
new file mode 100644
index 0000000000..cb7700ac93
--- /dev/null
+++ b/recipes/libnet/libnet_1.1.2.1.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "A packet dissection and creation library"
+HOMEPAGE = "http://www.packetfactory.net/libnet/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "BSD"
+DEPENDS = "libpcap"
+# There are major API changes beween libnet v1.0 and libnet v1.1
+PROVIDES = "libnet-1.1"
+PR = "r3"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/libn/libnet/libnet_${PV}.orig.tar.gz \
+ file://support-uclibc.patch;patch=1 \
+ file://fix-endianess-test.patch;patch=1 \
+ file://new-autotools.patch;patch=1"
+
+S = "${WORKDIR}/libnet"
+
+inherit autotools binconfig
+
+do_configure_prepend() {
+ rm -f aclocal.m4 Makefile.am ltmain.sh
+}
+do_install_append () {
+ install -d ${D}${datadir}/man/man3/
+ install -d ${D}${bindir}
+ install -m 0644 ${S}/doc/man/man3/*.3 ${D}${datadir}/man/man3/
+ install -m 0755 ${S}/libnet-config ${D}${bindir}
+}
+do_stage () {
+ oe_runmake -C src 'DESTDIR=${STAGING_LIBDIR}' 'libdir=' install-libLIBRARIES
+ oe_runmake -C include 'DESTDIR=${STAGING_INCDIR}' 'includedir=' install-includeHEADERS
+ oe_runmake -C include/libnet 'DESTDIR=${STAGING_INCDIR}' 'includedir=' install-libnetincludeHEADERS
+}
+
+#static build
+FILES_${PN} = ""
+FILES_${PN}-dev += "${bindir}/libnet-config"
+
+CPPFLAGS_prepend = "-I${S}/libnet/include "