aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/liboil/liboil_0.3.15.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-05-10 10:23:29 -0700
committerKhem Raj <raj.khem@gmail.com>2009-05-10 10:23:29 -0700
commita81810bac25bbe1565ea5e327ba8ecc37010c595 (patch)
tree9e0aad9fa96048a71bf4ac233be1fae3df8d9709 /recipes/liboil/liboil_0.3.15.bb
parent914745ead79f70f33b762d66a43f906da2dbe19c (diff)
downloadopenembedded-a81810bac25bbe1565ea5e327ba8ecc37010c595.tar.gz
liboil_0.3.15: Consider the soft-float case.
__VFP_FP__ means that the floating point format in use is that of the ARM VFP. It does not tell if one has VFP unit or not. So using this define will still use VFP instructions on cpus which do not have VFP. To know that we also need to consider __SOFTFP__ which means that instead of floating point instructions, library calls are being generated for floating point math operations so that the code will run on a processor without an FPU.
Diffstat (limited to 'recipes/liboil/liboil_0.3.15.bb')
-rw-r--r--recipes/liboil/liboil_0.3.15.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes/liboil/liboil_0.3.15.bb b/recipes/liboil/liboil_0.3.15.bb
index 338121ac66..a077fb4e7d 100644
--- a/recipes/liboil/liboil_0.3.15.bb
+++ b/recipes/liboil/liboil_0.3.15.bb
@@ -1,12 +1,13 @@
DESCRIPTION = "Liboil is a library of simple functions that are optimized for various CPUs."
HOMEPAGE = "http://liboil.freedesktop.org/"
LICENSE = "various"
-PR = "r2"
+PR = "r4"
DEPENDS = "glib-2.0"
SRC_URI = "http://liboil.freedesktop.org/download/${P}.tar.gz \
file://autotools.patch;patch=1 \
+ file://arm-vfp.patch;patch=1 \
"
inherit autotools pkgconfig