aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/liboil
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/liboil
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/liboil')
-rw-r--r--recipes/liboil/liboil-0.3.11/ppc-detect-fpu.patch11
-rw-r--r--recipes/liboil/liboil-0.3.15/autotools.patch21
-rw-r--r--recipes/liboil/liboil_0.3.10.bb11
-rw-r--r--recipes/liboil/liboil_0.3.11.bb15
-rw-r--r--recipes/liboil/liboil_0.3.14.bb17
-rw-r--r--recipes/liboil/liboil_0.3.15.bb16
-rw-r--r--recipes/liboil/liboil_0.3.9.bb11
7 files changed, 102 insertions, 0 deletions
diff --git a/recipes/liboil/liboil-0.3.11/ppc-detect-fpu.patch b/recipes/liboil/liboil-0.3.11/ppc-detect-fpu.patch
new file mode 100644
index 0000000000..49485e3648
--- /dev/null
+++ b/recipes/liboil/liboil-0.3.11/ppc-detect-fpu.patch
@@ -0,0 +1,11 @@
+--- /m4/orig-as-gcc-inline-assembly.m4 2007-03-17 04:03:30.000000000 +0200
++++ /m4/as-gcc-inline-assembly.m4 2007-11-20 12:20:24.000000000 +0200
+@@ -38,7 +38,7 @@
+ [
+ AC_MSG_CHECKING([if compiler supports FPU instructions on PowerPC])
+
+- AC_TRY_COMPILE([], [__asm__ ("fadd 0,0,0"::) ], [flag_ok=yes], [flag_ok=no])
++ AC_TRY_COMPILE([], [double x = 0; __asm__ ("fadd 0,0,0"::"f" (x):"32") ], [flag_ok=yes], [flag_ok=no])
+
+ if test "X$flag_ok" = Xyes ; then
+ $1
diff --git a/recipes/liboil/liboil-0.3.15/autotools.patch b/recipes/liboil/liboil-0.3.15/autotools.patch
new file mode 100644
index 0000000000..53501e3991
--- /dev/null
+++ b/recipes/liboil/liboil-0.3.15/autotools.patch
@@ -0,0 +1,21 @@
+Index: liboil-0.3.15/configure.ac
+===================================================================
+--- liboil-0.3.15.orig/configure.ac 2008-07-01 06:45:53.000000000 +0200
++++ liboil-0.3.15/configure.ac 2008-09-25 13:44:18.633758105 +0200
+@@ -187,16 +187,6 @@
+ true)
+ fi
+
+-if test x$HAVE_GCC_ASM = xyes -a x$HAVE_ARM = xyes ; then
+- AS_COMPILER_FLAG(["-Wa,-mfpu=vfp"],
+- [VFP_CFLAGS="$VFP_CFLAGS -mfpu=vfp"],
+- true)
+- #AS_COMPILER_FLAG(["-Wa,-mfloat-abi=softfp"],
+- # [VFP_CFLAGS="$VFP_CFLAGS -mfloat-abi=softfp"],
+- # true)
+-fi
+-AC_SUBST(VFP_CFLAGS)
+-
+ #AS_COMPILER_FLAG(["-fasm-blocks"], HAVE_ASM_BLOCKS=yes, HAVE_ASM_BLOCKS=no)
+ HAVE_ASM_BLOCKS=no
+ if test "x$HAVE_ASM_BLOCKS" = "xyes"
diff --git a/recipes/liboil/liboil_0.3.10.bb b/recipes/liboil/liboil_0.3.10.bb
new file mode 100644
index 0000000000..94471a26fc
--- /dev/null
+++ b/recipes/liboil/liboil_0.3.10.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Liboil is a library of simple functions that are optimized for various CPUs."
+HOMEPAGE = "http://liboil.freedesktop.org/"
+LICENSE = "various"
+
+SRC_URI = "http://liboil.freedesktop.org/download/${P}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/liboil/liboil_0.3.11.bb b/recipes/liboil/liboil_0.3.11.bb
new file mode 100644
index 0000000000..44b4b5e088
--- /dev/null
+++ b/recipes/liboil/liboil_0.3.11.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Liboil is a library of simple functions that are optimized for various CPUs."
+HOMEPAGE = "http://liboil.freedesktop.org/"
+LICENSE = "various"
+PR ="r2"
+
+DEPENDS = "glib-2.0"
+
+SRC_URI = "http://liboil.freedesktop.org/download/${P}.tar.gz \
+ file://ppc-detect-fpu.patch;patch=1"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/liboil/liboil_0.3.14.bb b/recipes/liboil/liboil_0.3.14.bb
new file mode 100644
index 0000000000..ebbe6cfb97
--- /dev/null
+++ b/recipes/liboil/liboil_0.3.14.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Liboil is a library of simple functions that are optimized for various CPUs."
+HOMEPAGE = "http://liboil.freedesktop.org/"
+LICENSE = "various"
+
+# The configure script seems to have bogus checks, so let's not make it the default
+DEFAULT_PREFERENCE = "-1"
+
+DEPENDS = "glib-2.0"
+
+SRC_URI = "http://liboil.freedesktop.org/download/${P}.tar.gz \
+ "
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/liboil/liboil_0.3.15.bb b/recipes/liboil/liboil_0.3.15.bb
new file mode 100644
index 0000000000..338121ac66
--- /dev/null
+++ b/recipes/liboil/liboil_0.3.15.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Liboil is a library of simple functions that are optimized for various CPUs."
+HOMEPAGE = "http://liboil.freedesktop.org/"
+LICENSE = "various"
+PR = "r2"
+
+DEPENDS = "glib-2.0"
+
+SRC_URI = "http://liboil.freedesktop.org/download/${P}.tar.gz \
+ file://autotools.patch;patch=1 \
+ "
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/liboil/liboil_0.3.9.bb b/recipes/liboil/liboil_0.3.9.bb
new file mode 100644
index 0000000000..94471a26fc
--- /dev/null
+++ b/recipes/liboil/liboil_0.3.9.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Liboil is a library of simple functions that are optimized for various CPUs."
+HOMEPAGE = "http://liboil.freedesktop.org/"
+LICENSE = "various"
+
+SRC_URI = "http://liboil.freedesktop.org/download/${P}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}