aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libpcap
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-04-02 13:56:49 +0000
committerJeremy Lainé <jeremy.laine@m4x.org>2009-04-02 13:56:49 +0000
commitefbc7fe76ca09c3e760d1d42c35f97312a068ff6 (patch)
tree6b7ac49670ba604a6feafc1d37cdf572bf589e2e /recipes/libpcap
parent111de86113c682291a49c4a202c33b75a28e569e (diff)
downloadopenembedded-efbc7fe76ca09c3e760d1d42c35f97312a068ff6.tar.gz
libpcap: add patch to use LDFLAGS (fixes QA error)
Diffstat (limited to 'recipes/libpcap')
-rw-r--r--recipes/libpcap/libpcap-1.0.0/ldflags.patch12
-rw-r--r--recipes/libpcap/libpcap_1.0.0.bb3
2 files changed, 14 insertions, 1 deletions
diff --git a/recipes/libpcap/libpcap-1.0.0/ldflags.patch b/recipes/libpcap/libpcap-1.0.0/ldflags.patch
new file mode 100644
index 0000000000..66ab5f725f
--- /dev/null
+++ b/recipes/libpcap/libpcap-1.0.0/ldflags.patch
@@ -0,0 +1,12 @@
+diff -urN libpcap-1.0.0.orig/Makefile.in libpcap-1.0.0/Makefile.in
+--- libpcap-1.0.0.orig/Makefile.in 2008-10-28 01:26:13.000000000 +0000
++++ libpcap-1.0.0/Makefile.in 2009-04-02 13:54:20.000000000 +0000
+@@ -326,7 +326,7 @@
+ #
+ libpcap.so: $(OBJ)
+ @rm -f $@
+- $(CC) -shared -Wl,-soname,$@.1 -o $@.`cat $(srcdir)/VERSION` $(OBJ) $(DAGLIBS)
++ $(CC) $(LDFLAGS) -shared -Wl,-soname,$@.1 -o $@.`cat $(srcdir)/VERSION` $(OBJ) $(DAGLIBS)
+
+ #
+ # The following rule succeeds, but the result is untested.
diff --git a/recipes/libpcap/libpcap_1.0.0.bb b/recipes/libpcap/libpcap_1.0.0.bb
index b85bf4c5d4..6dfc056930 100644
--- a/recipes/libpcap/libpcap_1.0.0.bb
+++ b/recipes/libpcap/libpcap_1.0.0.bb
@@ -1,9 +1,10 @@
require libpcap.inc
-PR = "r5"
+PR = "r6"
SRC_URI = "http://www.tcpdump.org/release/libpcap-${PV}.tar.gz"
SRC_URI += "file://aclocal.patch;patch=1"
SRC_URI += "file://ieee80215-arphrd.patch;patch=1"
+SRC_URI += "file://ldflags.patch;patch=1"
do_compile () {
oe_runmake