aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/librsync/librsync_0.9.7.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/librsync/librsync_0.9.7.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/librsync/librsync_0.9.7.bb')
-rw-r--r--recipes/librsync/librsync_0.9.7.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/librsync/librsync_0.9.7.bb b/recipes/librsync/librsync_0.9.7.bb
new file mode 100644
index 0000000000..eb8bb2671c
--- /dev/null
+++ b/recipes/librsync/librsync_0.9.7.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "librsync is a free software library that implements the rsync \
+remote-delta algorithm. This algorithm allows efficient remote updates of a \
+file, without requiring the old and new versions to both be present at the \
+sending end."
+HOMEPAGE = "http://librsync.sourceforge.net/"
+SECTION = "libs"
+LICENSE = "LGPL"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/librsync/librsync-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-build-docs --enable-shared "
+
+do_stage() {
+ oe_libinstall -a -so -C .libs librsync ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/
+ for i in librsync.h librsync-config.h
+ do
+ install -m 0644 ${S}/$i ${STAGING_INCDIR}/$i
+ done
+}